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1 Software Introduction

1.1 Overview

Houseplan is a powerful, easy-to-learn, lightweight and compatible software that can create stunning 3D
models and renderings efficiently. It not only supports generating 3D architectural entities with one click, but also
offers more advanced tools that help to customize and refine your designs, as well as produce high-quality images
and animations without any hassle. In addition to being of great help to architectural planning projects, it can also
be used in various other industries that require 3D modelling and rendering. Its powerful modelling methods and
real-time rendering engine, as well as the large amount of 3D model and texture resources, allow you to obtain the

best work experience and high-quality results with lowest budgets.

1.2 System requirements

1.2.1 Hardware requirements

Minimum Recommended
CPU Intel 15-6 processor Intel 15-9 and above
Monitors 1440 x 900 true color display 1920 x 1080 or higher configuration
Video Card Nvidia GTX1050Ti Nvidia GTX1660Ti or higher
RAM 16GB 16GB or higher
Hard Drive 1T (recommended) 2T (recommended)
Mouse, trackball or another Mouse, trackball or another pointing
Others
pointing device device

1.2.2 Software Configuration

0S Win 7 (64-bit) / Win10 (64-bit) / Win 11

1.3 Houseplan Interface Overview

The user interface consists of a quick access toolbar, ribbon, property palette, status bar, file tab, command

line and workspace.
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Quick Access Toolbar: Allows quick access to frequently used tools such as New, Open, Save, Save As, Undo,

Redo, Layer Control, Element on/off and Layers.

Ribbon: Displays task-based tools relevant to the current workspace that consists of nine tabs. Each tab consists

of a series of panels of related functions.
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Property Palette: Displays the properties of selected object and can be modified.
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0]

| Auto Hae

Status Bar: It is composed by cursor coordinate position, tools that affect the drawing environment (Orthogonal,
Polar Axis, Snap, Follow, and Reference), slider to adjust camera speed, view mode buttons (Isometric, Perspective),

effect switch buttons (Shadow, Anti-Aliasing, Light Projection), and community button.

Camers Speed _— 0 liometric ]Fe.‘;ur!!luf Shadow | Anti-Alaimg [il-;?lt Projection

File Tab: Located above the command line, displays one or more opened files.

Untitled2 Untitlec3 Untitiedd Untitleds

Command Line: Shows the command prompt during the execution of a tool or command.

Workspace: Displays visible area of current opened file.
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2 Home Menu

This chapter introduces basic features of Houseplan, such as creating and saving projects, parameter settings,
drawing lines, planes, and volumes, designing building models, deconstructing interior structure, etc., allowing users

to quickly create new projects and improve design efficiency.

2.1 File Panel

2.1.1 New

Select "Home Tab > File Panel > E New" to create a new blank drawing.

2.1.2 Open

Select "Home Tab > File Panel > Open" to open a file in *.cpi format.
Note: Multiple documents can be opened at the same time, and you can switch between documents by Ctrl+

Tab, and copy (Ctrl+ C) and paste (Ctrl+ V) data between documents.

2.1.3 Save

Select "Home Tab > File Panel > E Save" to save the current file.

Note:
(D Saved file is in *.cpi format. When saving an existing file, the original file will be saved as *.cpi.bak. If
the original file is needed, remove the .bak suffix.
2 The default auto save interval is 30 minutes. Set the save interval and location in "Home Tab > Manage

Panel > Settings > Auto Save".

2.1.4 Save As

Select "Home Tab > File Panel > E Save As" to save the current file as *.cpi format only.

2.1.5 Save Selected

Select "Home Tab > File Panel > Save Selected" to select and save existing objects or elements on

workspace as *.cpi format.
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2.2 Manage Panel
2.2.1 Properties

Select "Home Tab > Manage Panel > Properties" to close/open the property palette.

Properties E X
B Slope Eoof

Auto Hide

Color attached to la. .. 77,114, 165

FEoom plane heizht

wall antity

Detailed parameter 0.0o

Flat top height 0.00

Teae
125

Hanzing board enclosure

2.2.2 Settings

Allows to manage Hoseplan parameters regarding to command shortcut customization, workspace background

color, auto save function, switch themes and reset to default option.

fif

Select "Home Tab > Manage Panel >

Settings" to open the following dialog box.

Simplify Commands Set Background Auto Save

Switch Theme Reset
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2.2.2.1 Simplify Commands

Sets a key shortcut to quick access a command similar as command alias. Select "Home Tab > Manage Panel >

Settings > Simplify Commands" to open the following dialog box.

Simplify Commands

I 5 i I O
Home Insert Edit Modeling Wiew Material SCene Video g
Serial number Command description Command name Simplify command
1 Mew MEW
2 Open OPEM
3 Save SAVE
4 Save As SAVEAS
5 Save Selected SAVESEL
=] Properties SHOW _SZ%5
Fi Settings SetParam
3 Polyline PLIMNE PL
9 Line Segment LIME L
10 Arc ARC
11 Spline SPLIME SPL
12 Circle CIRCLE I
13 Ellipze ELLIPSE
14 Regular Polygon MPOLYGOM
15 Vertical Line FACEVERTICALLIME
16 Spiral Line SPIRALLIME
17 Cloud Line CLOUD
18 Rectangle RECTANGLE REC

1. Enter a custom shortcut command in the "Simplify Command" column, and enter it on the command line

when it is used.
2. Click on the B button to save the simplified command.
3. Click on the button to open a list of defined "simplify command" for easy access and modification.

4. Update the simplified command list by clicking on the o button to import the simplified command list

configuration file.

5. Click the s button to select a storage location to export the current list of simplified commands as a

configuration file.
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2.2.2.2 Set Background

Sets the background color of the workspace in axonometric mode. Select "Home Tab > Manage Panel > T‘LT

Settings > Set Background". Select the color, and click "OK" to apply the settings.

Basic colors:

Set Parameters e . I_ I_ I_
Simplify C d Set Backg d Auto 5 .I_I_ .
implify Commands et Backagroun uto Save

NN |

HE N L
Switch Theme Reset

HE N ]

HE N

2.2.2.3 Auto Save

Custom colars:

Define Custom Colors =3

Sets the interval and save path for backup files to be saved automatically. Select "Home Tab > Manage Panel >

il

Settings > Auto

Save" to bring up the following dialog box.

Interval {min): | 30

ot |

Save path: C:\Users\Administrator\Documents\HousePlan Da |

Confirm Cancel

Enter or select the interval time and click the [D button to set the save path; click the "Confirm" button to

apply the settings.

Note: The backup file format is *.cpi.
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2.2.2.4 Switch Theme

Toggles the available skin or themes provided by Hoseplan. Select "Home Tab > Manage Panel > Settings >

Switch Theme " to switch the theme.

OEBEBE S Houseplan 2023

Home Insert Edit Modeling A Scene Video Services

LhizB88 8| B ) = bl d fol 7

New Open Save Save Save Properties Settings Line Rectangle Box Building Cross-section Building Balcony Window Door Rooftop Awning Outdoor Glass
A5 Selected Extrusion  Extrusion Gallery Stairs  Curtain Wall

File Manage Drraw Building

. OFE B B g | ¥ Bulding = | |[%gF Bulding both= | Houseplan 2023
Home

nsert Edit Modeinig View Rtaterial Scene Wl

"EEEE B Mo 8 B B ITHEHOARSS EH
Mew  Open  ave  Sawe Save  Properties Sethngs | Lme Bectangle  Sox Bullding Cross-saction Sulcng Salcony Windew  Door  Rooltop dwning Qutdcor  @lass
&5 Selected v % % Letrusion  betrusion  Gallery 2 Stairs  Curtain Wall

Filz Manage Dirawe Buiding

2.2.2.5 Reset

Select "Home Tab > Manage Panel > Settings > Reset", to restore all settings in the software to the state

they were in when the software was installed.

2.3 Draw Panel

2.3.1 Line

2.3.1.1 Polyline

Creates a polyline. Select "Home Tab > Draw Panel > Line > Polyline", there are two ways to draw.
1. Direct draw a polyline
(1) Draw a straight-line segment: After specifying the starting point, specify the next point, or continue
specifying more points until the target position, and press Enter.
(2) To draw a circular line segment: Type or input “A” and press Enter, specify the next point, or continue

specifying more points until the target position, and press Enter.
Note: The arc is tangent to the previous segment of the polyline.

During the process of drawing a single line segment, straight lines and arcs can be drawn at any time by
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switching between the “L” and “A” keys. To close, enter “C” and press enter; to abandon the previous operation,
enter “U” and press enter.
2. Drawing 3D polylines

Type or input “S” to enter and specify the next point, or you can continue specifying the second and third
points until the target position and press Enter. To close, enter “C” and press Enter; to abort the previous
operation, enter “U” and press enter.

Note: When drawing a three-dimensional

polyline, open the "polar axis", as shown in @

the figure, so that you can snap to the

auxiliary lines when drawing.

2.3.1.2 Line Segment

)
Creates line segments. Select "Home Tab > Draw Panel > E==24 Line > . Line Segment", specify the start

and end points, and generate a line segment.

2.3.1.3 Arc

[

II H n
Creates an arc. Select "Home Tab > Draw Panel > E===4 Line > ﬁ Arc" and there are two ways to draw.

1. Draws an arc by directly specifying three points.
2. Enter or type “C” and press enter, draw the arc by the specified circle center. Specify the circle center, start

point and end point to generate.

2.3.1.4 Spline

f

Il II._.Il'l I . .
Creates a spline. Select the item "Home Tab > Draw Panel > E=224 Line > g\ Spline" to draw a spline at the

specified point.
1. Draw an unclosed spline: Specify the starting point and endpoint tangents separately to generate the splines.
2. Draw a closed spline: Enter or type “C” and specify the tangent direction. To abort the previous operation,

type “U” and press enter.

2.3.1.5 Circle

\ .
Creates a circle. Select "Home Tab > Draw Panel > Line > B34 Circle" to create a circle with the specified

center and radius.
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2.3.1.6 Ellipse

r"’u-‘-‘ﬁ
. " . Kl S " . .
Creates an ellipse. Select "Home Tab > Draw Panel > Line > Ellipse" to create an ellipse with the

specified center and axis length.

2.3.1.7 Regular Polygon

Creates a regular polygon. Select "Home Tab > Draw Panel > Line > Regular Polygon", enter a value

to determine the number of sides, and then start drawing. There are three ways to generate.

1. Draws a square polygon internal to a circle: Specifying the center
point and entering the radius generates a square polygon with the
following effect.

2. Draw a regular polygon based on the specified side lengths: Input

or Enter “E” and press Enter to specify two points as the lengths of

the sides of the regular polygon.
3. To draw a square polygon tangent to a circle: Input or Enter
“C”, specify the center point, enter the radius, and

generate a square polygon with the following effect.

2.3.1.8 Vertical Line

Create vertical lines. Select "Home Tab > Draw Panel >

o

Line > L—"I

Vertical Line", specify the first point, and use the

normal direction to the plane of the point as the direction of the vertical line, and specify the second point or
enter a value to determine the length of the vertical line.
Note: If the specified point does not snap to a plane, the generated plumb line is perpendicular to the XOY

plane.

2.3.1.9 Spiral Line

Creates spiral object. Select "Home Tab > Draw Panel > Line > Spiral Line". First specify the center

of the bottom circle, then directly specify or enter a value to determine the bottom radius and top radius, then enter
a value to determine the number of turns and equal degrees, and then directly specify or enter a value to determine
the height to draw the spiral.
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Note: You can modify alias, layer color, bottom radius, top radius, tilt angle, number of spiral turns, helix height,

floor elevation and other parameters in property palette.

2.3.1.10 Cloud Line

. " ) - . .
Creates a cloud line. Select "Home Tab > Draw Panel > Line > E Cloud Line", specify the starting
point, and move the cursor to draw. There are three ways to draw.

1. Direct drawing forward cloud lines.
2. Enter or input “F” and press Enter to draw reverse cloud line.
3. Enter or input “A” and press Enter to set the arc length.

Note: You can modify alias, layer color, whether it is closed, and the floor elevation in property palette.

2.3.2 Rectangle

2.3.2.1 Rectangle

Creates a rectangular plane. Select "Home Tab > Draw Panel > Rectangle > Rectangle" and specify
two corner points to draw a rectangle.

Note: You can modify alias, layer color, length, width, number of building floors, floor elevation and other

parameter information in property palette.

2.3.2.2 Polygon

Creates a polygonal plane. Select "Home Tab > Draw Panel > Rectangle > ~ Polygon", specify the

starting point, and draw the polygon directly; or enter “S” to draw the polygon in 3D space. To abort the previous

operation, type “U” and press enter.

2.3.2.3 Spline Plane

Creates a spline plane. Select "Home Tab > Draw Panel Rectangle > Spline Plane", enter the plane

width, and draw at the specified point.

2.3.3 Box

2.3.3.1 Box

Creates a box. Select "Home Tab > Draw Panel > 4 Box", specify two corner points, and then
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specify or enter a value to determine the height.

2.3.3.2 Cylinder

Creates a cylinder. Select "Home Tab > Draw Panel > 4 Cylinder", specify the center of the circle

first, then specify or enter values to determine the radius and height respectively.

2.3.3.3 Cone

4 Box > m Cone" to specify the center of the base, and

Creates a cone. Select "Home Tab > Draw Panel >

then specify or enter values to determine the base radius, top radius and height.

2.3.3.4 Donut

Creates a ring volume. Select "Home Tab > Draw Panel >

circle first, then specify the radius and circle radius directly or enter a value.

2.3.3.5 Pyramid

Creates a prismatic cone. Select "Home Tab > Draw Panel| > 885 Box > - Pyramid", first specify the center
point, then enter a value to determine the number of sides of the base polygon of the pyramid, then directly specify
or enter a value to determine the radius of the base external circle, the radius of the top external circle and the

height.

2.3.3.6 Sphere

I/-

=

Y

Box > B Sphere" and specify the center of the

Creates a sphere. Select "Home Tab > Draw Panel > @

sphere first, then specify the radius directly or enter a value to determine the radius.

2.4 Building Panel

2.4.1 Building Extrusion
Extrudes planes, 3d solids, or surfaces of buildings to achieve building definitions or modifications of their

shape. Select "Home Tab > Building Panel >E Building Extrusion" to extrude the building in the following two

ways.
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1. Building Extrusion: Move the cursor to a plane to highlight it, then press and hold the left button to extrude

or enter a value to determine the extrude distance.

(1) Select a plane and extrude (Y) (all
entities move) or [click the entities on
selected plane (stay) / extrude without
entities move (N) / enter distance
value]:

(2) Select a plane and extrude (N) (no
entity move) or [click the entities on
selected plane (move) / extrude with
all entities move (Y) / enter distance

value]:

2. Standard Floor Extrusion: When the building
is extruded upwards, if there is a plane object
or 3D solid or volume that is less than 2 meters away from the building around the top floor of the building,

then it will be copied out each floor as the building floor is extruded.
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Note:
@ The building must have at least one floor to take effect.
@ Only supports the above-ground floors of the building.
Building Properties:

(1) Building name: Allows input a
building name.

(2) Building  height:  Automatically
calculates the building height and it
cannot be modified. Building height
= difference between interior and
exterior height + (floor height *

number of floors) + height of roof

components. When there is more
than one roofing component, the

higher one is counted in the building height.

(3) Floor Properties: To set the properties of the floor, double click on the property palette or click on

button to open the dialog box shown below.
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IR

Flaor number Flaor height Area Factor Capacity factor
5 3.00 306.36 1.00 1.00
4 3.00 306.36 1.00 1.00
3 3.00 306.36 1.00 1.00
2 3.00 306.36 1.00 1.00
1 3.00 306.36 1.00 1.00
Sum 128.00 13328.16

@ Define floor: Click E button and select a floor in the list to bind interior elements to selected
floors (should use “Show Floor” tool to hide the selected floor roof). You can select many
floors, modify interior elements of one floor and others will change too.

Note:
@ Hold down SHIFT or CTRL to select multiple floors.
@ After binding, different colors represent different standard floors.
8 =B

Awning Cutdoor Glass Building Move Show Draw Floor
Stairs Curtain Wall Attachment Components Floors  Wall Hole

Building
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@ Separate floor: Click . button and select one or more floors in the list. When same interior
elements are bonded to other floors, this tool helps disconnect the selected floor to others,

when you modify the separated floor, others will be not changed.

Modify the interior elements like furniture or walls in the selected floor.
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L |

(3 Delete bonded Floor: Click i button and select a defined floor in the list to delete the

specified floor in multiple instanced standard floor.
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_

Floor Height: Displays the height of each floor, can be changed manually.
Area: Displays the geometric area of the current floor.

Factor: Affects the calculation of the area, converted according to the height of the floor.

Q@ @ @ ®

Capacity Factor: Affects the capacity area, counted by the height of the floor.
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(4) Number of floors: The number of floors
above and below ground can be
modified and the building dynamically
changes accordingly.

(5) Indoor and outdoor height difference:
The difference between the indoor and
the outdoor floor on the ground floor,
which is to shown when there is no
above-ground floor.

(6) Above-ground height of basement: The

height of the basement above the
ground; this item is not displayed when
there is no basement.
(7) Base area: The software calculates the base area based on the building outline and cannot be modified.
(8) Apron: Floor lines can be turned on and off.
(9) Elevation: Reads the building's z coordinate in the scene; can be modified manually.
Note:
@ Extruding planes and volumes automatically generates buildings with the corresponding number of
floors according to the default floor height.

@ The data in the property palette updates in real time during extrusion.

2.4.2 Cross-section Extrusion

Extrudes a plane into a volume or 3D solid. Select "Home Tab > Building Panel > EE Cross-section Extrusion",
move the cursor to the plane, hold down the left button to extrude or enter a distance. There are two types of
extrusion.

1. Extruding directly with any plane edges as boundary.

2. Type “S” and press Enter to extrude with the outermost edges of a plane as the boundary when lines or

edges split the plane.

Note:
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@ When no boundary is specified, the edges of a plane or volume, or other lines on the plane, "splits"
a plane into several areas, and the cursor will snap to one of the individual areas, extruding it into a

volume; when the entity boundary is specified, the edges outside the selected entity will no longer

"split" the entity interval.

@ When cross-section extrusion is performed on a volume, the newly generated volume is integral to the
original entity, which is a local extrusion and transformation of the original entity. Whereas lines or

planes on the volume are used to divide a given plane into parts and act as auxiliary lines.

@ As shown below, it is convenient to extrude section planes on a building.
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2.4.3 Building Gallery

Hoseplan provides a wide range of building base outlines and enables the organization of building assets by

adding, deleting and modifying operations on the building gallery, providing easy access to design projects.

Select "Home Tab > Building Panel > int Building Gallery" to open the following dialog box.

Building Gallery

vila ] | 1
Clear 002 003 004
Rename
Impeort DWG i—-rlj‘
Import Resource i [E] =
Export Resource 006 oo7 008
e 009 11
Delete
Areg; 208.77 outline; 17 =15

1. Applying the gallery: Drag the building outline directly into workspace.

Page 22 of 236



Houseplan Make stunning 3D scheme with speed and ease

CRRRREERN

Anpe: - A Qg Hamn

2. New: Right-click on a blank space in the gallery list to create a new gallery.
3. Edit the gallery: Right-click on the gallery name to show the context menu, as shown above.
(1) Delete: Removes the selected gallery title from the list.
(2) Clear: Removes all building outlines in the selected gallery title.
(3) Rename: Changes the name of the selected gallery title.
(4) Import DWG: Building outlines can be imported into the gallery by selecting the "Import DWG"

command, which brings up the dialog box shown below.

(D Enter directly or click on the B

button to select the folder where
Floder path(dwag file):
the drawings need to be C:\Program Files\Gstarsoft\Houseplan 1.0 (64-bit)\s: B
imported. Specify the balcony layer name(Others are buildings):
IZNT
@ Enter the balcony layer name
(ZZYT) at Specify Balcony Layer Confirm Cancel

Name, and the entities for the
other layers default to the

building outline.
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Note:

@ The imported drawing must be closed
lines, and the layers need to be
regularized.

@ The building outline imported by the
user should be a dwg format file and the

drawing units should be in meters.

(5) Export Resource, Import Resource.
(D Exports the building outline drawings under this category, as well as the *.bmp and *.ini files
generated from the *.dwg drawings of the building outline, as compressed files in *.zip format.

@ Imports the exported *.zip file into the gallery.

Building Gallery

T o™ -l

Clear

Rename

Import DWG
Import Resource [E] i__l"?

Export Resource o0& 007 008

= M

QoS 010 011

Area: Cutline:
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HewseFlan Conbents > HimgePlan Building Gallery Rescurces

& villazip fevaluation co

File Commands Tonols  Favorites Ophioos

T L

Add _s.tr:n: T-: Tost View  Delete Fird Wiza

ﬂ villazip - ZIP archive, unpacked size 682,717 bytes

& 01 Emp
B 00wy
o Dt

| 00ZBmp
B 070wy
w | DOZini

| (03 Bmp
8 002dwy
s | D03 ni

&| D4 emo

- Total 33 files, GE2.717 bytes

Note: When importing, the user will be prompted whether to import by appending, select "Yes" to keep
the existing outline drawings under the category, and import all the drawings in *.zip into the gallery, and
replace the files with the same name directly; select "No" to delete the existing outline drawings under
the category, and import the building outline in *.zip.

4. Delete: Right-click on the building outline to delete.

5. Building planar attributes: Building outline dimensions and its single layer area, and household type, can
facilitate statistical analysis.
(1) Area: the area of the building Buikding Gallery

base.

(2) Outline: the length and width
of the building outline.

Note:

@ The area does not include the -y p— -

base area of the balcony.
@ After the building is extruded,

the software automatically calculates the number of households that come with the building as well

as the household type information.
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2.4.4 Balcony

Inserts preset or custom balconies on buildings. Select "Home Tab > Building Panel > Balcony" to open

the following dialog box.

© Convex balcony () Concave balcony | Concave/Convex balcony

Mode  Custom
1 2 He
Hi
3 4
w380 ~|  gluso o
@ 'm' Hi:[060 v| Hz{0e0 |

: Single ﬂ Column D Middle

1. Types of balconies: Convex, concave and concave-convex.
2. There are two ways to define a convex balcony:

(1) Mode: Inserts balconies
according to the parameters
set.

(2) Custom: Defines the balcony
based on the outline of an
existing plane.

3. You can manually set width, deep,

thickness and height of selected

balcony type.

4. Insertion method:
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(1) Single: Inserts one balcony at a time.

=

Balear

ﬂl:nr-.-'ﬂ:banm-.l Concavs balcony Conzawe Convey baloony

Mode  Cusbem

Otnm'eou balcory Corcarve baloony Concave fCorey haloory

Mode  Cushom

(2) Column: Generates a balcony on the selected floor, as well as on each floor above it

(3) Middle: Automatically snaps the middle point of a building plane edge.
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© Convex hakoany Concave balcony [ Cencave MConvex balcony

Mode  Cighom

5. Direct insertion: Select the balcony type, set the size, select your insertion method, then click "Insert"
button. After selecting the above-ground floor of the building, specifying the edge and entering the
distance, the balcony will be inserted successfully.

6. Custom insertion: Select the convex balcony, switch to the "Custom" tab, set the size, select your insertion
method, click "OK" button. After selecting a horizontal plane (planes that are not surfaces buildings)
without holes, and selecting the above-ground floor of the building, the balcony will be inserted.

Note:

(@ When inserting a balcony, Hoseplan automatic generates water apron on first floor balconies.

@ Inserting preset balconies will automatically corner when they encounter building angles.

@ When defining a convex balcony, if the original position insertion method is not checked, the edge
closer to the point where the cursor is clicked on the plane that you selected will be highlighted in red,
and this edge will be specified as the insertion edge

@ After inserting a balcony its properties can be modified in the property palette.

® snapping building plane edge activates auxiliary lines when inserting balconies to facilitate precise

insertion.

2.4.5 Window
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Inserts preset or custom windows on buildings. Select "Home Tab > Building Panel > Window" to open

the dialog box shown below.

O Flat window () Bulge window () Bay window
Mode  Custom
H
/
W |1.80 P
H: [1.50 [
Windowsill height: |0.90 e
[ ]window cover
Width:  [0.10
Cepth: (0.10

Glass depthy | 0.10

7

singe ©@coumn [ | middle

1. Types of window: Flat, bulge and bay window.
2. There are two ways to define a flat window:
(1) Mode: Inserts windows according to the
parameters set.

(2) Custom: Defines the window based on the

outline of an existing plane.
3. You can manually set width, deep, thickness and

height of selected window type.
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4. Insertion method:

(1) Single: Inserts one window at a time.

O Rat window | Bulge window

Winel i

O lst wrdom Bulge wandow By vandow

(2) Column: Generates a window on the selected floor, as well as on each floor above it.
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(3) Middle: Automatically snaps the middle point of a building plane edge.

b N

O Flat wndow [ Bulge window  _ Bay window
Mode  Custom

4
6 L)
!/ s

| Middle Insert

5. Direct insertion: Select the window type, set the size, select your insertion method, then click "Insert"
button. After selecting the above-ground floor of the building, specifying the edge and entering the distance,
the window will be inserted successfully.

6. Custom insertion: Select the flat window, switch to the "Custom" tab, set the size, select your insertion
method, click "OK" button. After selecting a horizontal plane, planes that are not surfaces of buildings
without holes, and selecting the above-ground floor of the building, the window will be inserted.

Note:

(@ When customizing a flat or convex window, the window directly generates at the location of the plane
if the plane is on a building wall.
@ Inserting preset windows will automatically corner when they encounter architectural angles.

@ When defining a bay window, if the original position insertion method is not checked, the edge closer
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to the point where the cursor is clicked on the plane that you selected will be highlighted in red, and

this edge will be specified as the insertion edge.

2.4.6 Door

Insert preset or custom doors on the building. Select "Home Tab > Building Panel > Door" to open the

dialog box shown below.

Mode  Cugtom

LLs—"
. o jﬁ

2

4

a
i..
LI
i

[] Door cover width: [0.15

k3
. #ﬁ

Door cover depth; (0,05

[] Mumber of steps: |3

[] Awning height: |3.00

1
3
5

'” ‘ Step width: | 1.30

isingle € Column [ Middle

1. There are two ways to define a door:

(1) Mode: Inserts doors according to the parameters set.

(2) Custom: Defines the door based on the outline of an existing plane.
2. You can manually set width, deep, thickness and height of selected door type.
3. Insertion method:

(1) Single: Inserts one door at a time.
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(2) Column: Generates a door on the selected floor, as well as on each floor above it.

(3) Middle: Automatically snaps the middle point of a building plane edge.

——
el

J
L

Sy WS e -

4. Direct insertion: Select the door type, set the size, select your insertion method, then click "Insert" button.
After selecting the above-ground floor of the building, specifying the edge and entering the distance, the
door will be inserted successfully.

5. Custom insertion: Select the door, switch to the "Custom" tab, set the size, select your insertion method,
click "OK" button. After selecting a horizontal plane (planes that are not surfaces buildings) without holes,

and selecting the above-ground floor of the building, the door will be inserted.
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Note:
@ Inserting or drawing preset doors will automatically corner when they encounter architectural angles.
@ When a building has a basement level, the insertion of doors is done separately above and below
ground.
@ When insert a door, the edge closer to the cursor click point, when the plane is selected are highlighted

in red, and this edge is used as the insertion edge.

2.4.7 Rooftop

2.4.7.1 Crenelated Parapet Wall

A crenelated parapet wall is a low wall around the roof of a building that serves as a protection. Select "Home

Tab > Building Panel > | Rooftop > Crenelated Parapet Wall" and enter a value to determine the height of

the crenelated parapet wall.

Note:
@ Crenelated parapet wall is counted towards building height, building height = indoor and outdoor
height difference + (floor height * number of floors) + height of crenelated parapet walls.
@ When painting the material, the crenelated parapet wall and the main volume of the building are
painted separately, and when painting the crenelated parapet wall, a single-sided painting method is

available.
2.4.7.2 Flat Rooftop

A flat roof is a type of exterior roof form with a gentle roof that can be made into a terrace, roof garden, etc.
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This feature is used to add a flat roof to a building. Select "Home Tab > Building Panel > ﬂ Rooftop >

Flat Rooftop" and select the top plane of the building to create.

Note:
@ Flat roofs do not count towards building height.
@ The property palette allows you to modify the flood height, elevation angle, thickness, eave length and

extension type.
2.4.7.3 Sloped Rooftop

The sloped roof is automatically generated based on the outline of the building roof and the parameters set.

Select "Home Tab > Building Panel > : Rooftop > Sloped Rooftop" to open the dialog box.

Sloped Roof
Mumber of slopes:  Full slope o
Slope gradiant:  30.00

Eawves: 1.00

Cancel

1. Full slope: Automatically generates a full slope roof based on the outline of the roof. After setting the slope

and eaves, click on the "Confirm" button and select the top plane of the building to generate it.
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Hirher i dapes: il Sops o
Sope gradint: 3120

Exeesz 1405

Cnafin Coansal

2. Double slope: Generate a sloped roof with two slopes. After setting the slope and eaves, click on the
"Confirm" button and there are two ways of generating them.
(1) Generate gable: Select a single vertical plane of a building to generate a gable.
(2) Generate multiple gables: Enter “D” and press enter, select a building vertical plane, and all vertical

planes in the same direction as that plane will generate a gable.
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3. Four slope: Generate a four-slope roof. After setting the slope and eaves, click on the "Confirm" button.

4. Arctop: Creates a curved roof. After setting the slope and eaves, click on the "Confirm" button

5. Description of full sloped roof parameters: Once a sloped roof is selected, its properties can be viewed in
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the property palette as shown below.

Properties
(1) Hanging board height: Sets the height ;e
B Slope Roof

of the hanging board. Color atached to layers

(2) Extension panel type: Switch between
Hanging board height
flat wall and adjoining balcony.

BExtension panel type

(3) Flat top height: Enter a value to make
Detailled paramatar
the roof flatten from the top. Fiation

(4) Detailed parameter: To modify the Hanging board enclosure

slope and eaves of a sloped roof,

double-click directly on the roof or click

on the """ button of detailed parameter to open the dialog box shown below.

Setiad numbe
|
1

Click the "Slope" or "Eave" to change its value. Click "Confirm" button to regenerate the roof
according to the new parameters.
(5) Hanging board enclosure: Set whether the hanging board is closed or not.
Note:
@ Created full-slope roofs cannot switch styles on property palette.

@ After changing the flat roof height, roof cannot be arched.
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@ Arch roof does not support closed hanging board.

@ When modifying the detailed parameters, a gable may be generated if the slope is changed to 90

degrees.

® Sloped roofs count towards building height. Building height = difference between interior and exterior

heights + (floor height * number of floors) + half of the roof height of the sloped roof.

Description of Arc roof parameters: Once an

arc roof is selected, its properties can be

viewed in the property palette as shown

below.

(1) Hanging board height: Sets the height of
the hanging board.

(2) Style: Switch between double slope, four
slope and arc top.

(3) Slope gradient: Enter a value to make the

arc of the roof increase or decrease its radius.

Properties

B Slope Roof

77.114.155
030
Arc top

30.00

(4) Eaves length: Enter a value to increase eaves length of arc roof.

(5) Hanging board enclosure: Set whether the hanging board is closed or not.

Description of Double slope roof parameters: Once a double slope roof is selected, its properties can be

viewed in the property palette as shown below.

(1) Hanging board height: Sets the height of
the hanging board.

(2) Style: Switch between double slope, four
slope and arc top.

(3) Flat top height: Enter a value to make the

roof flatten from the top.

(4) Turn rooftop into arc: Click the "~ button

on the property palette to open the dialog

Properties
B Slope Rool
: 77,114,155
030

Croubla siope

box shown below, set the arcing parameters and then click the "Confirm" button to arc the roof.
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Chube langih: L
Chule grogant: 20

Chine rabo(%): 25

| Lunfirm ] Luniel

(5) Detailed parameter: Modifies the slope and eaves of a sloped roof.

(6) Hanging board enclosure: Set whether the hanging board is closed or not.

2.4.7.4 Dormer Window

Inserts a dormer window on the sloped roof. Select "Home Tab > Building Panel > Rooftop > Dormer
Window" to open the dialog box shown below. Select the dormer window and specify the location on the sloped

roof to insert it.
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Note:
@ Curved roofs and sloped roofs that are arched do not support the insertion of dormer windows.

@ You can modify dormer window properties directly on the property palette.

2.4.8 Awning

Inserts an awning on the building according to the set parameters. Select "Home Tab > Building Panel >

Awning" to open the following dialog box.

HAowning h‘

Mode  Custom

: 2,00
D: 1.00
Height: 2,70

“Isingle € Column | middle

=

1. There are two ways to define an awning:
(1) Mode: Inserts awnings according to the parameters set.

(2) Custom: Defines the awning based on the outline of an existing plane.

Page 41 of 236



Houseplan Make stunning 3D scheme with speed and ease

2. You can manually set width, deep, thickness and height of selected awning type.
3. Insertion method:

(1) Single: Inserts one awning at a time.

(2) Column: Generates an awning on the selected floor, as well as on each floor above it

(3) Middle: Automatically snaps the middle point of a building plane edge.

Pweniing
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4. Direct insertion: Select the awning type, set the size, select your insertion method, then click "Insert" button.
After selecting the above-ground floor of the building, specifying the edge and entering the distance, the
awning will be inserted successfully.

5. Custom insertion: Select the awning, switch to the "Custom" tab, set the size, select your insertion method,
click "OK" button. After selecting a horizontal plane (planes that are not surfaces buildings) without holes,
and selecting the above-ground floor of the building, the awning will be inserted.

Note:

@ Automatic cornering of inserted awnings when they encounter building angles.

@ You can modify an awning’s properties directly on the property palette.

2.4.9 Outdoor Stairs

Inserts outdoor stairs on the building according to the set parameters. Select "Home Tab > Building Panel >

Outdoor Stairs" to open the following dialog box.

E ~o | Outdoor Stairs

Drection: Cladouie

-~ ‘7|I|

nTupcmr Top roofiop i |_||
e Aun to the rIII| '%I"

Middle B accompaning ]
wal

1. There are two ways to generate it:

(1) Insert: Insert the stairs directly according to the set parameters. Click on the "Insert" button, select

the upper floor of the building and insert it by specifying the location directly or by obtaining a
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positioning edge and entering the distance.
(2) Custom: Define the stairs based on existing planes. By clicking on the "Custom" button, two types of
insertion are possible.

D Insert with the wall: select a rectangular plane, then select the upper floor of the building,
and directly specify or obtain the positioning edge line and enter the distance to insert.

@ Insert in original position: Enter “Y” and press Enter, then select a rectangular plane, click a
surface of the above-ground floor of the building, then you can insert the outdoor stairs by
using the position of the rectangular plane as a reference.

2. Parameter Note:
(1) Direction: Setting the running direction of the stairs: clockwise and counterclockwise.
(2) Top cover: Setting stairs with or without topping.
(3) Top rooftop: Whether the stairs reach the roof.
(4) Run to the accompanying wall: Whether the handrail on one side of the stairs is against the wall.
(5) Middle: Automatically snaps the middle point of a building plane edge.
(6) Railings: Sets the height of the railings.
Note:
(D Automatic generation of aprons for outdoor stairs.

@ You can modify stair properties directly on the property palette.

2.4.10 Glass Curtain Wall

[]]
Defines or draw a glass curtain wall on a building wall. Select "Home Tab > Building Panel > Glass Curtain

Wall" to open the following dialog box.
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L 3 = [c

Fram=dapth:  D.OD

Uniwidth:  2.00

Unit haight:  3.00

After selecting a curtain wall type and set its parameters . There are four ways to generate a glass curtain wall.

1. Define the glass curtain wall according to the wall or plane of the building. Click on the button, the select

a building wall to generate glass curtain wall.

2. Generate a glass curtain wall on all walls of the building. Generate by clicking on the button and selecting

the building with above-ground floors.
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3. Draw the glass curtain wall on the building wall according to the width. Click on the button, place the
cursor over a building wall and specify three points to finish the operation. To draw through other building

walls, enter “C” and press ENTER.

. Draw polygonal glass curtain wall on the building wall. Click on the @ button to draw the glass curtain wall

I

as a polygon.
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Note: The property palette can adjust the border width, border depth, unit width and unit height.

2.4.11 Building Attachments

Attachments are decorations that are placed outside of buildings walls. Select "Home Tab > Building Panel >

Draw Attachments" to open the dialog box shown below.

Duilding Attackimei
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1. Insertion method:

(1) Single: drawing one attachment at a time.

(2) Column: generates one attachment for each floor in the selected floor and above.
2. There are two ways to generate it.

(1) Generate attachments based on existing cross-sections:

D Click "Stratum" button, select the upper floor of the building, snap and get the positioning edge

line, input distance and specify orientation to generate the attachment.

@) Click "Along edge" button, select the edge of
the building or building wall, left-click to end
the drawing and specify the orientation.

® Click the "Draw" button, select the edge of
the building or building wall, left-click to end
the drawing and specify the orientation.

(2) Generate attachment according to custom cross-

section: Take "stratum" as an example, click the

"stratum" button, select a plane or line, select one
side of the plane or line as baseline and specify
insertion base point. You need to select the above-ground floors of the building to determine where

to add the attachment, then select the red path or input distance to specify a path, and finally specify
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the orientation of the section to generate it.

3. Interrupt: Click "Interrupt" button and specify two points on the attachment to break.

Note:
@ You can change attachment object on the properties palette.
@ Only the parameters of "W”, “H" can be modified in the cross-section style.
@ When customizing the section, the attachment is drawn as solid if a plane is selected, or hollow if a

closed line is selected.
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2.4.12 Move Components

Changes the position of components like windows, doors, awnings and stairs on the building. Select "Home

—
Tab > Building Panel > Move Components", select the component and press Enter, then drag the mouse or

enter the distance from the specified base point to move them.

Note:
(@ Moving elements supports the selection of balconies, windows, doors, awnings, outdoor stairs, steps
along the line and area layering.
@ When specifying the base point, the component shall be specified on the building's vertical plane.

@ When moving a component, the component moves along the side vertical plane of the building.

2.4.13 Show Floors

| —
Hide or unhide a selected building floor. Select "Home Tab > Building Panel > Show Floors" to select a

floor, and the floors above that selected floor will be hidden, showing the interior structure and making it easy to

see the building's interior layout. Click on the building again to restore the building to its original state.
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2.4.14 Draw Wall

Draw interior walls inside a building. Select "Home Tab > Building Panel > Draw Wall" to open the

following dialog box.
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Drravai Wall

1. Draw Walls: After setting the parameters in the dialog box, select Straight Wall, Curved Wall or Rectangular
Wall, and specify start and end points. You can switch the wall type in the command line prompt. You can
draw continuously, enter “U” to go back to the previous step, and right-click to end the drawing.

2. Parameter description: The wall has three directions: left, middle and right. Wall thickness, wall height
and elevation can be set.

Note:

(@ Check the "Elevation" box to specified height as wall elevation, otherwise use the default height as the
wall elevation.

@ You can modify wall properties on the property palette.

@ Drawn walls have pinch points that can be dragged directly and merge intersection points.

@ Command line allows drawing wall continuously, right-click to end to continue drawing, right-click
again to end drawing, press Escape keyboard to exit drawing.

® Changing parameters while drawing can be continue the drawing with the new parameters.

@ The next time you open the dialog box the last set wall direction and parameters are remembered.

2.4.15 Floor Hole

Draws hollow areas on selected building floor. Select "Home Tab > Building Panel > Floor Hole" to open
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the following box.

Floor Hole

kg i

Starting faor: |Eurentﬁc-ur " |

Erdirg Soor: [Current Foar w |

Railing beight: | 1.00 -

1. Draw: After setting the parameters, click the "Draw" button, and draw directly at the specified point on
the floor. You can draw continuously, enter U to go back to the previous step, and right-click to end drawing.
2. Definition: Select objects such as planes, closed lines, and spline planes to generate.
Note:
@ Holes are sub-entities of buildings and railings are sub-entities of holes; railings change as the shape
of the hole changes.
@ The instances between each layer of railings are changed together: editing one floor changes all other

floors; however, one floor can be deleted individually without affecting the other floors.

2.4.16 Draw Railings

Draw railings on specific entity. Select "Home Tab > Building Panel > m Draw Railings" to open the dialog box

shown below.
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Drraw Railings e

e8| 1A &

3

Draw along edge: Specify start and end points on the edge of an existing floor hole or the edge of staircase.

Free drawing: Specify any point inside the building to draw. Continuous drawing: enter U to go back to

the previous step and right click to end the drawing.
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3. Define rail: Select a line or plane and right click to convert the selected line entity or plane to a railing.

Note:
@ starting and ending floors are invalid for railings drawn on the exterior of a building.
@ The direction of the railing distance from the edge: can automatically determine the boundary of the
staircase or hole to offset the railing inwards; cannot determine the boundary of the original position
drawn without offsetting.

@ You can modify railing properties on property palette.

2.4.17 Stairs
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2.4.17.1 Stairs

Select "Home Tab > Building Panel > Stairs > Stairs " to open the dialog box shown below.

Heightih): Curent foer |

Length(1}: 366

Wit 2.56

1. Draw to match: Adapts the length and width of existing stair openings by drawing a rectangle.

2. Select to match: The length and width of the stairway opening can be adapted by selecting a rectangular

Page 56 of 236



Houseplan Make stunning 3D scheme with speed and ease

plane.

3. Insert staircase: Specifying an insertion point to insert the staircase into workspace.

4. Rotate 90 degrees clockwise, 90 degrees counterclockwise, 180 degrees: Rotates the stairs on workspace
and adapt the bounding box length and width.
5.  Flip left/right, flip front/back: Mirrors the stairs and adapts the bounding box length and width.

6. Stair queues: Replicates the array of stairs, starting from the selected stair location level going upward.
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7. Parameter Note:

(1) Height: Automatically matches the floor height when placed, or floor height can be entered manually.
(2) Length: Specify two points as the total length of the stairs.
(3) Width: Specify two points as the total width of the stairs.

Note:
@ If stair is placed inside the building, the stair height automatically matches the floor height; if it is
placed outside the building, the height is the original dimension.
@ Double-click on the stair pattern or drag the stair into workspace to insert it.
@ The leather band also attaches to walls (interior and exterior) when moving, copying and scaling stairs.

@ You can modify stairs properties on the property palette.

2.4.17.2 Draw Stairs

Draw a single staircase. Select "Home Tab > Building Panel > Stairs > Draw Stairs" to open the dialog

box.
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Height of flight:  3.00 [] starting height; |0.00
(") Step width: ] Railings: Both w
Q) step height:  0+15 Trend: Down v

1. Draw: Draws the stairs according to the set parameters. Click on the "Draw" button and there are two ways

to generate it.

(1) First specify the starting point to determine the location of the stair segment, followed by specifying
length and direction of the stair.
(2) Select the stair width line, enter “S” and press Enter, select the line or the edge of the plane, and
specify length and direction of the stairs.
2. Define: Select two lines to define the stairs. Click the "Define" button and select one of the lines as start of

the staircase, then select the other side line to create stairs.
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3. Parameter Note:

(1) Click on the word "Height of flight" in blue to specify two points as stair heights.

(2) Click on "Starting height" in blue to designate a point as the floor elevation of the staircase.

(3) Click on "Step width" in blue to specify two points as the width of the step.

(4) Stair railings are generated in four ways: on both sides, on the left, on the right and none.

(5) Trend: Stairs can be going either up or down.

Note:

@ Check the checkbox before "Starting height" to use the entered or specified height as the floor
elevation of the stair, otherwise use the captured height as the floor elevation of the section.

2 Step width and step height are preceded by radio boxes. If one is checked, the other parameter will be
greyed out.

@ You can modify stairs properties on property palette.

2.4.18 Furniture Gallery

Adds furniture entities such as sofas, beds, and tables into buildings. Select "Home Tab > Building Panel > Ej

Furniture Gallery", and the following dialogue will pop up.
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Furniture Gallery

I

Bed Mew
Cabinet C

Kitchen Delete
Light Clear
Office Fa Edit
Sofa

Tables And Chairs

Tea Table

Wardrobe

Ttub 01 B3 Delete

Bathtub 03 Children's Bath Crock

01
- Add -

Closestool 01 Closestool 02

1. Apply: double-click or directly drag the furniture preview in the gallery to place at specified position.

Note: previews that appear in grey in the gallery will automatically download if clicked. They can be placed

on building floors only after the download is complete.
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2. Edit the entity library list: right-click the furniture gallery list
(1) New: Creates a new furniture gallery.
(2) Delete: Deletes the newly created furniture gallery.
(3) Clear: Clears all newly added furniture entities in the selected gallery.
(4) Edit: Renames the newly created furniture gallery
3. Edit furniture gallery:
(1) Add: Right-click on a blank space in the furniture gallery, click "Add", and select an entity in the scene
to add.

(2) Delete model: Right-click on a preview image, click "Delete" to delete the newly added model.

2.5 3D Operations Panel

2.5.1 Move

Moves selected entity according to X, Y, Z axes. Select "Home Tab > 3D Operations Panel > E Move", select

entities other than roads, right-click to end the selection. Place the cursor on the axis, select axial direction, axial

plane or axis center, drag or enter a value to determine the displacement distance.

Note:
@ Roads cannot be displaced using spatial displacement, which is achieved by using the “M” move

command.

Page 62 of 236



Houseplan Make stunning 3D scheme with speed and ease

@ Default to local axes, which can be switched to global axes by entering “S” and press Enter on the
command line.
@ When the axis is selected, the entity can be moved in any direction.

@ The default axis is at the center of the selected entity, and the axis position can be reassigned.

2.5.2 3D Rotate

Rotates selected entity according to X, Y, Z axes.

Select "Home Tab > 3D Operations Panel >E 3D

Rotate".
Note:
(D The default axes can be switched to
global axes by entering “S” and press

Enter on the command line.

@ 3D rotation supports the selection of
entities other than single-sided planes,
building components, and animation paths.

@ Some entities support Z-axis rotation only, except for lines, planes and volumes.

@ Can be rotated at any angle when cursor is placed on the inner circle of the axis; when placed on the
outer circle of the axis, it is rotated according to the screen plane.

® The default axis is at the center of the
selected entity, and the axis position

can be reassigned.

2.5.3 3D Scale

Scales selected entity in space according to

axes. Select "Home Tab > 3D Operations panel >

3D Scale".

Note:
@ Default to local axes, which can be switched to global axes by entering S and press Enter on the

command line.
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@ 3D scaling supports the selection of planes, bodies, background entities, vegetation entities, skeletal
animations and free-form modeled entities.
@ If the cursor is placed at the center of the XYZ axis, all objects can be scaled as whole.

@ The default axis is at the center of the selected entity, and the axis position can be reassigned.
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3 Insert Menu

This chapter introduces the import and management of project underlay and data, as well as the project

publishing and exporting functions, which assist in creating a detailed and realistic rendering effect.

3.1 Import Panel

DWG Underlay >

3.1.1 DWG Underlay Select

Imports DWG or DXF files to be used as
Effective range of original graph:

drawing underlay for project design. Select "Insert

Tab > Import Panel > DWG Underlay" to open

its dialog box.

Draw units on original graph:  Meter w

|| Content within view only

| original height

Do not import "blod:”

1. Select: click on the III button and Do not import positive entities

Do not import invisible entities

select a DWG or DXF file to be imported.

2. Effective range of original graph:

Automatically calculates and displays the

=Previous(P) Mext{N) = Cancel{C)

size range of all objects in the inserted

drawing as a whole image.

Gadact
g P e Houseplan 1,0 {22 g l—|

I ffictrn: g o cogmnal b 400 I

Draw un ks on origingl graot ke

T L L veotbn e ondy
T !

0 oot It ook

o0 root it pssihes endtas

i vt et imihls EEtan

A0 meter
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Drawing units on original graph:
DWG Underlay X

Automatically read and display the unit that
Select

the Imported drawmg uses. (Only meter and C:\Program Files\Gstarsoft\Houseplan 1.0 (64-bit)\sam E]

millimeter are available)
Effective range of original graph: 40%29

Content within view only: When checking Draw units on original graph: | Meter o
Meter

this option, only the objects that are visible Content within view only

in the workspace when you save the DWG | Original height
Do not import "block”
drawing will be imported, otherwise, every Do not import pasitive enities

object in the drawing will be imported. Do not import invisible entities

Original height: Check this option to import o o
Unit in DWG drawings is imported as meter

according to the original height of objects

<Previous(P) MNext{N) = Cancel(C)

drawn in the CAD drawing.

Do not import blocks: Block entities in CAD
drawings will not be imported.

Do not import invisible entities: Entities that are frozen, closed, or on locked layers will not be imported.

After setting the parameters, click the "Next" button and the following dialog box will pop up.

DWG Underlay
Edit  LinePane Layer
B 0
B - Defpoints
[v = ARCH_DOORS
2 ARCH_WALL
] ARCH_WINDOWS
I ] ARCH_FURNITURE
v ARCH_STAIRS
v £ ARCH_FLOOR_LIVING

Check a layer to import as editable layer, otherwise import as
underlay layer

<Previous(F) Next{N)> Cancel(C)

(1) Checkbox: You can check the drawing layers to be imported into workspace. Objects belonging to
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imported layers are visible and ready to be edited. If you uncheck drawing layers, objects are visible

and dimmed in the workspace, those objects cannot be modified because they are locked.

FAT: Lk bry
n.u | -mq.hn !lqw
: 3 u
2 * nelpriTs
I RCH_DEE
< I3 L0 apaLwa
=3 5
__.'-I £ i ARCH_FIEEIL RS I
] I ARCH_ET RS
I3 [ ARCH_FIOINE I 4G

Dhack o by W imaatl ce sddolds over, alberess ngaslas
ey lrpa-

<HEesflE] | Roall> canelin]

(2) Import type: — imports objects that belong to a layer as polylines, ™ imports objects as planes or

2D surfaces. Click the icon to switch between them, double click the icon to select all layers at once.

Click the "Next" button to start importing.

Thetsr zazra brport as cdbmblz Inper, ctvznisn oot as
b e lager

Note: DWG supports versions 2002-2021.

3.1.2 DWG Layer Management

Manages imported DWG/DXF drawing layers. You can set storage, snap and hidden states of drawing layers
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that are currently turned off (not editable) and convert them into editable ones in workspace.

B DWG Layer Management"

Select "Insert Tab > Import Panel > I

WG Layer Management

=+ @ =

Inderlay layer: Converts to a solid layer:
Layer Storage  Snap | Hide | Layer

" ARCH_DOORS @ Ira

~ ARCH_FLOOR_L [+ F (T

T ARCH_STATRS [« F I

¥ ARCH WATT

1. Underlay layers: Displays the name, storage, snap and hidden status of imported DWG file.

(1) Storage: Sets whether the underlay layers can be saved.
(2) Snap: Sets whether the underlay layers can be snap.
(3) Hide: Sets whether the underlay layers can be displayed.

Note: Double click any checkbox to select the corresponding column at once.

2. Underlay layer check box: Check a layer name to make it visible in workspace but not editable.

Bt L
WA = =
(L (A g
Lal | o | - R eT—

= i
ARCH_BOORS

aih_FLOOE_1L

_
s o i g ||l||| -

e |

= W=
B i e
] | ey
[ ARCH_DO0ES
[ amcw_FLoom_L
| AR STAIRS

3. Convert to editable layer: Check a layer name in the list to later convert into not editable.

4. Click = button to start layer conversion. Check the layer name whether is located (Underlay layer or

Convert to editable layer list), in the conversion process, click the button again to abort.
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DWG Layer Management X |DWG Layer Management

= L A= - 4B =

Uncleriary lryer: Corverts 1o a sokkd |ayer: Undariay layer: Comverts 1o & solid layer:

Layer Somge | Snap | Hide  Lapes T

5 Storsge  Snap | Hide  Layer
[~ ARCH_DOORS  [#

[~ ARCH_FLOOR_L | [ ARCH_FURMITURE [T ARCH_DOORS |+ [ [ | [ aRcH_FURNITURE
| _FL L |« r 2

lv arcH_winDow: [~ ARCH_FLOOR_L [ -
[~ ARCH_STAIRS [# | cH 5 ) - =

: P | [~ ARCH_STAIRS [# "
[~ ARCH_WALL V/ — ARCH_WALL &
(7 iEcE_vmooes ) F [

L4 [ s

5. Click + button to move objects belonging to a selected layer to specific position in workspace.
6. Click T} button to delete all DWG layers keeping the editable layers visible in workspace.

7. Click | = button (it is recommended to uncheck all underlay layers to see the selection effect), select

any object in the workspace, the corresponding layer will be located and selected in the dialog box.

3.1.3 Merge Projects

Merge other *.cpi files into current project.Select the "Insert Tab > Import Panel > Merge Projects" to

open the following dialog box.

Merge Projects

File: |

Criginal coordinate Specify coordinate

Click the I == | button and select the CPI file to be merged.
Original coordinate: Inserts the file according to original coordinates stored.

Specify coordinate: Inserts the file according to the specified coordinates.
3.1.4 Other Formats

Insert files in different formats into Hoseplan to be used as design references.

Select "Insert Tab > Import Panel > B Other Formats" to open the dialog box shown below.
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dem [*.dem;

1. Select *. jpg, *. bmp, *. png type files, and specify the insertion location.
2. Select *. fbx, *. osgb, *. osg, *.obj, *.3ds type files. There are two ways to insert them; Insert at specified
position or Type Y to insert by original coordinates.

3. Select *. skp file, click the "Open" button to open the dialog box shown below.

Import Settings

Import hidden obiects | Import the two-sided model

(1) Import hidden objects: The option is checked by default, hidden components will be created and
imported; if unchecked, hidden components will not be imported.
(2) Import the two-sided model: If checked, the front and back sides of the skp model will be created and
imported; if unchecked, only one side of the skp model will be analyzed, created and imported.
4. Select *.rvt file, click "Open" button, and download the rvt plugin to continue importing as indicated by

message prompts.
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5. Select *.tif file, click "Open" button, and follow the command line prompts to enter a value to determine the
rendering level to complete the TIF import.
6. Select *.dem file and click "Open" button to import it.
Note:
@ The imported osgb data is model data. To import oblique photography data, please use the "Oblique
Photography " function.
@ Import version description: sketchup supports up to version 2022; fbx format supports up to version
2020.
@ RVT files cannot be imported if the plugin is not downloaded.
@ The tif file is imported with the mapping render level, the smaller the value, the clearer the mapping;
the larger the value, the blurrier the mapping.
® DEM is digital elevation model, which enable the digital simulation of ground terrain from limited

terrain elevation data.

3.2 Imagery Panel

3.2.1 Oblique Photograph

Imports oblique photography data or merge it into the current project. Select "Insert Tab > Imagery Panel >
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Oblique Photograph" to open the dialog box shown below.

1. Import: Right-click on the blank space

to open the context menu, click Oblique Photograph

"Import" to open the dialog box Project Path
Please right dick to impaort pra. ..

shown below. Click the
button to select the oblique

photography file, click the "Original Oblique photography: [:]

. " .
coordinate” button to import the Criginal coordinate Specify coordinate

scene according to the in-situ

coordinates; click the "Specify
Coordinate" button to import the
scene according to the specified coordinates.
2. Right-click on the layer node name to open the context menu, as shown above.

(1) Rename: change the name of the ,
Oblique Photograph

project. Praject Path
Note: Naming rules: after Oblique photography data.... | f:jdownloadsjobligue photoar ..
Rename
importing, all data are added Delete
Paositicning

the "skew data" prefix, followed

by sorting numbers, from 1, Import

2, ... The name in brackets reads

the name of the oblique
photography folder, and the
name cannot be changed.

(2) Delete: delete the imported oblique data and retain the source files.

(3) Positioning: Click "Positioning" to locate this oblique data in the scene.

Note:
@ Only oblique photography project data of osgb files with the same name as the sub files under the
path is supported (eg:Tile_1 /Tile_1.0sgb).

@ After importing a project, you need to specify a new path when the path is invalid. When it is invalid,
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the path location is displayed in blue.

3.2.2 Point Cloud Data

This function imports point cloud data (collection of vectors in a 3D coordinate system) into Hoseplan.

Select "Insert Tab > Imagery Panel > B Point Cloud Data" to open the following dialog box.

Point Cloud

Paint doud data:  F:\Downloads\Paint Cloud Data |

Cilute ratio: 50 =ik

Original coordinate

Spedfy coordinate

1. Point cloud data: click on the E] button to select a file in *.las format.

2. Dilute ratio: The ratio of the number of data points to be reduced during the point cloud data processing.
The larger the value, the greater the number of data points and the slower the transformation process;
the smaller the value, the smaller the number of data points and the faster the transformation process.

3. Original coordinate: Click on the " Original coordinate" button to import the scene according to the original
coordinates.

4. Specify coordinate: Click the "Specify Coordinate" button to import the scene according to the specified
coordinates.

Note:

@ After inserting the point cloud data, when using this function again, if the dilution value is the same as
the last value, it can be directly inserted into the scene in in-situ coordinates or the specified

coordinates; if the dilution value is changed, the data needs to be converted again.

@ Dilution ratio range:1-100.

3.2.3 Data Classification

A large amount of model data is automatically classified, and the number of data files after classification is
significantly reduced and more organized. This function can solve the problems of low loading efficiency and high

consumption of scene rendering when users process large batches of data.
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Select "Insert Tab > Imagery Panel > Data Classification" to open the dialog box shown below.

Data Classification

Destination Path: C:/Users/Administrator. CTFDR -, | Data Source: Fi/Downloads/Manual Data
= B Exdusive_vila_Project Select | Dats source

gs:gﬂgon Manual Data_DX

B River channel Manual Data_HX

Eroad Manual Data_JZ

B errain Manual Data_ZW

& sprit=

Compile Exit

Right-click in the margin to open the right-click menu, as shown below.

Drata Classification

Destination Path: Data Source:

Select Data source

fught chck to creats new progects

Creale new

Impnrt pra’:ch

Campile Exit

1. New Project: Click on "Create new projects" and the following dialog box will pop up.
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Data Classification x

Destination Path: Data Source:

Select Data source
Right dick to create new projects

Projectname:  Exdusive_Vila_Project

Save path:  F:/DownloadsManual Data D

Enter the project name, select the save path, click the "Confirm" button, and five layers will be

automatically created, as shown in the figure.

Destination Path: C:/UsersfAdministrator. CTPDN | Data Source:

(=R~ Exdusive_Villa_Project
B Building
ﬂ\u‘egemion
B river channel
BEroad
Terrain
B sprite

Select Data source

Compile Exit

The checkbox controls the display and hiding of that layer.

2. To open the compiled data, select "Import Project", which brings up the following dialog box.
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Data Classification

Destination Path: C:/Users/Administrator. CTPDK |, Data Source:

= B Exdusive_villa_Project Salect Data source
Euilding
H\iegeiaion
B river channel
BElroad

B Terrain
B sprite Artificial models: C:YUsers\Administrator, CTPDMUM E]

Original coordinate Specify coordinate

After selecting the compiled project.zml file, click the "Original Coordinate" button to insert the
scene according to its original coordinates; click the "Specify Coordinate" button to insert the scene
according to the specified coordinates.

3. Right-click on the layer node name to

open the context menu, as shown in the

Destination Path: Ct/UsersfAdministrator CTPDN || Data Source:

following image. =l Exclusive_vila_Project | || setect ‘

By ras
(1) Rename: Change the name of the B vegetsion —

B river channel Delete
project. Edroad Positioning
HTerrain

. Sprite
(2) Delete: Delete layers, retain local & spr

source files and data can be
restored after deletion.
(3) Positioning: Locate the item location in the scene.
4. Compilation process.

(1) Right-click on a new project in a blank space in the compiled data area.

(2) Import the data source, click on the """ | button and select the source data to be compiled.
(3) Select the compiled data layer and then check the corresponding data source in the table on the right
to map the layer to the data source.
(4) Click “Compile” button to compile the current layer data.
Note: The data source needs to save as osgb files for buildings, plants, rivers, roads, terrain, and vignettes in a

scene separately.
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3.2.4 Orthoimagery

Resamples the distorted drawings to a new correct orthoimage. The original remote sensing image with

distortions is resampled in grayscale according to the correct geometric relationship. Select "Insert Tab > Imagery

Panel > Orthoimagery " to open the dialog box shown below.

Orthoimagery

Show MName Result path

Compile

Import

Rename
New Positioning

Delete

1. New: Right-click on the blank space to

open the context menu, click "New",

and the following dialog box appear.

After entering the image data name,

click the "Confirm" button to create

new image data; click the "Cancel"

button to cancel the operation and
close the dialog box.

2. Right-click on the data list to open the context menu, as shown.
(1) Compile: Click on "Compile" and the

following dialog box will pop up.

Path: C:\Users\Administrator, CTPDNUMHVDCDNNU

@ Path: the path of the

generated project Data source:  Fi\Downloads\ImageryData \Example \Example

@ Data source: the original data eniizted
path.
Click the " ' button, select the
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result path and data source, click the "Compiling" button to start the compilation; click the "Terminated"

button to terminate the compilation.

(2) Import: Click on "Import" to open the dialog box shown below.

Import The Results

Qutcome path:

Criginal coordinate Specify coordinate

Click the " ' button to select the generated result, click the "Original coordinate" button to insert

the scene according to the original coordinates; click the "Specify coordinate" button to insert the scene

according to the specified coordinates.

(3) Rename: change the name of the image data.
(4) Positioning: locate this image data in the scene.
(5) Delete: delete the current image data.

Note:

(D When selecting the already generated results for import by clicking on the *** ' button, they can

only be imported in the in-situ coordinates.
@ check Show to show the data in the scene; uncheck Show to hide the data in the scene.

@ The source data for the orthogonal projection are in tif, jpg format (with coordinates).

3.2.5 Flatten Oblique Image

Flattens selected area of an oblique photography. Select the "Insert Tab > Imagery Panel > Flatten Oblique

Image" item, and there are three types of flattening.
1. Define the flattened area by drawing polylines.
2. Define the flattened area by typing “S” and press Enter to draw 3D polylines.

3. Define the flattened area by typing “D” and press “S” to select closed line or plane.

Note:
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(@D When drawing a horizontal area, the horizontal plane is formed at the height of the first point at the
time of drawing and is flattened according to the drawn outline.

@ When drawing a three-dimensional area, a plane is defined by the first three points and flattened
according to the drawn outline.

@ When defining the flattening area, flatten the image by the outline and height of the selected object.

@ Define the flattened area to be less than or equal to the flattened image area, less than the image base

outline, and the bottom of the image must not be overhanging.

After flattening, select the oblique photography model in the scene and click on the """ button after the
"Flattened Area" field in the properties bar to open the dialog box shown. The dialog box shows the names of all
the flattened areas. Select the name and the corresponding flattened area in the scene is highlighted; double-click
the name to quickly locate the selected area. Right-click on the name to open the context menu:

1. Delete: The selected flattened area is deleted and the

oblique photography data for that area is restored to its pre-

flattened state. Name
2. Delete all: All flattened areas are deleted and the oblique Delete
. . . . Delete all
photography data in the scene is restored to its original state.
Rename

3. Rename: Modifies the name of the flattened area.

3.2.6 Oblique Data Filter

Deletes or saves oblique photography area according to different

cutting methods. Select "Insert Tab > Imagery Panel> B Oblique

Data Filter" to open the following dialog box.

Oblique Data Filter

H Iz & R Height: |Permeate

Save selected as Delete selected Delete unselected

1. There are four ways to draw the edit range:
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(1) Rectangle: Click H putton to draw a rectangular editing area.
(2) Polygons: Click = putton to draw a polygon editing area.
(3) Circles: Click © button to draw a circular editing area.

(4) Select: Click ™ button to select a graphic as the edit area; the selected drawing can only be a line or

volume.
Note:
@ The editing area can be adjusted in extent by dragging and dropping the clip point and its position
can be moved.
@ When a custom editing area is selected, the volume of the original reference is removed and a
new editing area is created, and the new editing area is also dragged with clip points.
@ Only one editing area can exist in the scene, and when a new editing area is drawn, the last one
is automatically deleted.
2. Permeate: draw a planar edit area that includes all data on the plane and in the infinite mapping range
above and below the plane.
3. Automatically pick: draw an edit area and picks the highest point in the range as the model height to
generate a 3D edit area.
4. Height: when drawing an edit area, if a height value is manually inputted, the 3D edit area is generated
with the given value.
5. Delete Selected: the original data within the edit area is deleted and the scene is loaded with the
remaining data.
6. Delete Unselected: the original data outside the edit area range is deleted and the scene is loaded with
the remaining data.

7. Save As Selected: The data within the edit area is saved separately, and the original data is retained.

3.3 Output Panel

3.3.1 Publish
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Creates an .exe file that can be executed independently, and can realize video roaming, environment changing,

and properties display. Select "Insert Tab > Output Panel > Publish" to enter the Publish Preview screen

1. Menu: hover the cursor at the bottom to show the menu; move cursor away to hide the menu, as shown

above.
(1) Gallery: Click the "Gallery" button to turn on/off the left side gallery. When the gallery is on, hover the
cursor on the left side of the screen to show the gallery; move the cursor away to hide it. Click on any

video within the gallery to roam or position to the appropriate viewpoint.
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Interactive simulation publishing

4

% 3 L] i H

LookRound03® A VoL L TERETRTNG

(@ Click on the =] button to set the path roaming parameters.

® Click on IE button to preview the view of the path.

® Click on button to draw grounded paths in the publish scenario.

@ Click on ]EI button to Stop preview the view of the path.

®) Click on ]EI button to pause the previewing and click again to continue the previewing.

® Click @ button to clear the drawn grounded path or the path being used in the gallery.

(3) Effect Environment: Manage the environment effects in the publishing scene. For more details, see

the "Scene Tab > Environment Panel > Environment" function.
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Type Parameter
Sun&ed

Sun Intersity 251235200

Sun Colos 235,193 158

Sun Calor Bultipliar 1301890
Ambient

Skoy Color Ha1TF 21

Sky Calor Multipliar TADE0

S5AG Factor RA00N00

s5A0 Hadius TR

(D Weather: Double-click on a weather image to apply the corresponding weather effects.

@) Lighting: Set the shadow effect in the scene and adjust the azimuth and altitude angle
parameters of the sun. When shadows are on, adjusting the azimuth and altitude will affect the
effect of the shadows.

(3 Effect Parameters: Click on the "Effect Parameters", you can modify the parameters of Solar,
ambient, fog effect, volumetric light and HDR to enhance the ambient effect.

(4) Properties: Click the "Properties" button to turn on/off the properties column on the right side of the

screen. Click one element of the building and the properties column will display related information.
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(5) Data Management:
Specify the path to

correctly load the

obligue  photography
data in the scene.

(6) Publish: Click the "Publish" button to package the file and save as .exe (executable application).

+ 3 # % Dhirie. 5 Pdawe T

Organize Mew folder

v [l ThePC
Mo kerns mabch your search.
5l Deskzop

» B Docsmens

» o Downlioat

File mame: | Sampled] e

Seve as type:  Publish typel e

# Hide Folders

2. Context menu: Right-click in the scene to open the context menu.
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Orbit{0)
Eye view(D)
Full view(A)
PaniP)

View control(l)
Previous viewdl)
Front face(F)
Window view(W)

e W o P

(1) Orbit: Dynamically moves the observer around the model while maintaining the same focus point.

A O T T TR

Pressing “Ctrl + middle mouse wheel” enables orbit view as well. If you have an entity selected and
then use this function, the view is rotated with that entity as the center point.

(2) Eye view: Turn on human eye view perspective. Press and drag the left button in the scene to view
around by human perspective.

(3) Full view: Displays all entities in the workspace to the maximum extent possible.

(4) Pan: Moves the position of the view without changing the position or scale of the objects in the
drawing. Press and hold the middle mouse wheel enables Pan operation as well.

(5) View control: Switches current workspace 3D perspective view
from different directions. Click on the corresponding blue arrow to
set the view direction, and click on the "Plane" button in any view,

the view will turn to the plane state.

(6) Previous view: Returns to previous view performed.

(7) Front face: Select the plane on the volume to display its front view.

(8) Window view: Maximizes the display of selected area, and enables full display and return to the
previous view.

3. Title: Double click on the title in the top left corner of the scene to open the dialog box shown below.
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simulation publishing House Design Motion

Edit Title

Texl: House Design Mobon
Fant: mgosoftvaHeitl -~

Text height; 32

Color:

| Confirm

(1) Text: set the title name.
(2) Font: sets the font of the title.
(3) Text height: sets the size of the font.

(4) Color: Set the color of the font.

4. Full-screen: click the . button in the upper right corner to enter full screen, and press Esc to exit. Double-

click the left mouse button to enter or exit full screen; in full screen, hover the cursor at the top to show the

title bar; title bar will be hidden after the cursor moves out of it.

5. Minimize: click on the . button in the upper right corner to minimize the software to the taskbar.

6. Close: Click the . button in the upper right corner to exit the publishing scene and return to the software
scene.
Note:
@A gallery is a collection of highlights and video paths saved in a scene.
@The gallery does not show highlights saved under the axonometric view. The highlights and roam paths
are saved with the associated environment scene.
@It‘s necessary to resave the gallery after modifying the scene to update the preview image.
@Labels for particle entities in published scenarios and in published .exe files will be automatically
hidden.

@Page Up/Page Down allows you to switch the gallery.
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3.3.2 Export

Export the follow file formats; *. dwg, *. bmp, *. jpg, *. png, *. osgb, *. fbx, *3ds, *obj. Select "Insert Tab >

Output Panel > Export" to open the following dialog box.

Exporting

N __ <« Des... » Newf.. w ") Search Mew folder o

Organize « Mew folder = - (7 ]
MName Date modified Type
> WPSHE
Mo items match your search.
~ [l This PC
> Bl Desktop
> Bl Documents
File name: | Sampledl.dwg -

Save as type: | Auto CAD file (*.dwqg)
Auto CAD file (*.dwg)
Windows BitMap (*.bmp]
JPEG Image (*.jpg)

PMNG Image (*.png)
osgb(t.osgh)
FBX file (*.fbx)
3D Studie (*.3ds)
| OBJ file(*.obj)

# Hide Folders

1. Select the *.dwg format, click "Save" button and select the CAD version to export.
2. Select the *.0sgb, *.fbx, *.3ds, *.obj formats and click "Save" button to export the file in the appropriate
format.

3. Select *. bmp, *. jpg, *. png format, click "Save" button, and the following dialog box will pop up.
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(1) Output size: Sets the width and

Image Export Settings

height of the exported image in

pixel Output size Maxirmum size
. Wide: pixel Wide: 4096 pixel
(2) Maximum size: The system will i _
High: 712 pixel High: 4036 pixel
display the maximum pixels of
Image size: Image size:
. 58.8cmX 25, 1am 144, 5cmiX 144, 5cm
the exported image supported
by the system Watermark pattern
| watermark
(3) Watermark pattern:
Tile: Spadng ¥ |10 y |10
(O Watermark: if checked,
Watermark
exported image will have
Transparency
watermark.
@ Tile, spacing: select "Tile" to Cancel
%, r

display the watermark
pattern according to the
default spacing; select "Spacing" to display the watermark pattern according to the specified

spacing.

(3 Watermark image: click on the | " button to select an image in *.bmp or *.jpg format as the
watermark image.
@ Transparency: drag the slider to set the transparency of the watermark image, 1 is opaque, 100
is fully transparent.
(4) Click the "Confirm" button to export the image in the appropriate format.
Note:
@ If a file in *.dwg, *.0sgb, *.3ds, *.obj or *.fbx format is selected for exporting, the entities in the
background layer of the current drawing are not exported.

@ When exporting effect maps, it is recommended to turn on "Anti-aliasing, Shadow, Light Projection".
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4 Edit Menu

This chapter introduces the basic features of modifying the amount, size, shape, and position of model outlines.

Using these features can help the user easily improve the effects of the project.

4.1 Modify Panel

4.1.1 Copy

Copies an object to specified distance and direction. Select "Edit Tab > Modify Panel > i Copy", select the

object, specify the base point and target point, and copy continuously.

4.1.2 Cut

Copies an object to clipboard and cut. Select "Edit Tab > Modify Panel > i:! Cut" and select the object to

cut.

4.1.3 Paste

Inserts an object from clipboard into workspace. Select "Edit Tab > Modify Panel > Paste" and there are
two ways to paste. You can insert the object directly at the designated position or Enter “Y” and press Enter to

insert at the original coordinates.

4.1.4 Erase

Deletes a selected object. Select "Edit Tab > Modify Panel > Erase".

4.1.5 Move

Moves an object to the specified distance and direction. Select "Edit Tab > Modify Panel > T Move" to
select the object. There are two ways to move it.
1. Move directly by the global coordinate system: selecting the object and specifying the base and target points
to move.

2. Enter “M” and press enter, select the reference plane, select the entity to be moved, and specify the base

and target points to move along the reference plane.
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4.1.6 Rotate

o+

Rotates an object around at specified base point. Select "Edit Tab > Modify Panel > |:-_-'" Rotate", select the
object, specify the base point. There are two types of rotation.
1. Rotation is accomplished by directly specifying or entering a value to determine the angle of rotation.
2. To rotate the entity at a reference angle, enter “R” and press enter.
(1) After directly entering a value to determine the reference angle, specify or enter a value to determine
the new angle.
Note: The angle at which the final entity is rotated = new angle - reference angle.
(2) Specify the angle to determine the reference angle, such as: specify the base point ¢, specify the
reference angle after the first point g, specify the second point b, specify the new angle with reference
to a point d on the edge, and rotate the edge ab to be parallel to the edge cd. The effect is shown in

the following figure.

Before

Aft
=t Eeference

4.1.7 Scale

Scales selected object, keeping the proportion of the object unchanged after scaling. Select "Edit Tab > Modify

Panel > Iﬂ Scale", select the object, specify the base point. There are two ways to zoom in.
1. Scale by directly specifying or entering a value to determine the scaling ratio.
2. Scales the entity by the reference length. Enter R and press enter.
(1) After entering a value directly to determine the reference length, specify or enter a value directly to

determine the new length.
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(2) Specify the length to determine the reference length, such as: specify the base point c, specify the
reference length after the first point a, specify the second point b, specify a point d on the reference
edge to determine the new length, and scale the ab edge to a length equal to the cd edge. The effect

is shown in the following figure.

Lfter Before Eeference

Note: Scale factor = new length / reference length, example; enter 0.5 to reduce to 0.5 times the original length.

4.1.8 Mirror

Creates a mirror copy of selected object. Select "Edit Tab > Modify Panel > _”L Mirror", select the object. If
you enter “N”, after mirroring, the source object is not deleted; if you enter “Y”, after mirroring, the source object
is deleted. There are two types of mirroring.

1. Mirroring by direct reference to the line joining the two specified points.

2. Type “Z” and press Enter to use the Z axis as reference.

The effect is shown in the following figure.

Before After

4.1.9 Offset
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Create concentric circles, parallel lines and isometric curves of selected object. Select "Edit Tab > Modify Panel >
Offset" and there are two types of offsets.

1. Specify directly or enter a value to determine the offset distance: Select the object to be offset and specify
the point to determine the side on which the offset is to be made.

2. Make the newly generated line entity pass through the specified point: Enter “T” and press enter, select
the object to be offset, and then specify the pass-through point.
4.1.10 Trim

Trims intersected 2D objects. Select "Edit Tab > Modify Panel > = Trim", first select the boundary line, then
select the object to be trimmed. The effect is shown in the following figure.

Boundary line
| ;{/ Trim object [

»

Before

Lfter

You can also select multiple line entities with intersection points at the same time, and then select the object
to be trimmed. The effect is shown in the following figure.

1 . .
+ Trim object
A
oo -
e e S
- e
- e ] e
.-'/ ¢ %
- E \'I'
_,’ |I' |'.- "I
- 1 k
- [y ! .
A 1
r b
1
I‘I
Before After
Note:
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@ Trimming objects can be line segments, polylines, arcs, clouds and splines.

@ Trimming can only be successful when the selected line intersects with the boundary line.

4.1.11 Extend

Extend the selected boundaries or edges. The objects are extended so that the edges of other objects can be

converged. Select "Edit Tab > Modify Panel > Extend" item, select the boundary line, and then select the

object to be extended. The effect is shown in the figure below.

—  Extension hne

Before After

You can also select multiple line entities with intersection points at the same time, execute the Extend

command and select the object to be extended. The effect is shown in the following figure.

Extension line [ |

Before After

Note:
(@ Extension objects can be line segments, polylines or arcs.

@ The extension can only be successful when the extension of the selected line has an intersection

with the boundary line.

Page 93 of 236



Houseplan Make stunning 3D scheme with speed and ease

4.1.12 Break

Breaks the selected object between two points. You can create a gap between two specified points on an

object, breaking it into two objects. Select "Edit Tab > Modify Panel > Break", select the object, use the
clicked position as the first break point, and then specify the second break point; to re-designate the first break
point, enter “F” to specify the first and second break points to break.

Note: The supported line entities are line segments, polylines, arcs, clouds, splines, and ellipses.

4.1.13 Stretch

Stretches objects crossed by a selection window or polygon. Objects that are partially enclosed by a crossing

window are stretched. Select "Edit Tab > Modify Panel > Stretch", select the 2D object to be moved or

stretched, specify the base point first, and then the second point. The effect is as shown below.

10?02ﬂ7
O == 0~ O

Before After

Note:
@ Box select one or more points of a line entity to locally stretched.

@ Point or box select the entire line entity to move it as a whole.

4.1.14 Fillet

Add rounded corners to intersected 2D objects or volume. Select "Edit Tab > Modify Panel > Fillet".

1. Rounding of line entities: Selecting two non-parallel lines, set radius of the rounded corners.
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Rounding the corners of the
3D volume is generated by
selecting the edges of the 3D
volume; The effect is shown
in the following figure.

Type “R” and press Enter to
set the radius of the rounded

corner.

4.1.15 Chamfer

- R

Before After

Add chamfers to intersected 2D objects or volume. Select "Edit Tab > Modify Panel > Chamfer" item.

1.

Chamfering intersected 2D
objects, selecting two non-
parallel lines, generated at
the set chamfer distance.

Chamfering of 3D volume is
generated by selecting the
chamfered main plane and

chamfered edges.

Before After

Enter “D” and press Enter to set the chamfer distance.

4.1.16 Smooth

Converts a polyline into a spline. Select "Edit Tab > Modify Panel > ! Smooth" and select a polyline.

4.1.17 Explode

Decomposes selected objects. Select "Edit Tab > Modify Panel > E”]

Note:

Explode" and select objects to explode.

@ Break into planes when the selected object is a volume.

@ Break into lines when the selected object is a plane.

@ Break into line segments when the selected object is a polyline.
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@ Selecting a spline converts it to a polyline.

® Select grouped entities to Ungroup.

4.1.18 Array

4.1.18.1 Array Copy

Quickly generates multiple copies of objects or other components by a set distance or number. Select "Edit

Tab > Modify Panel > |II] Array > |II] Array Copy" to open the following dialog box.

Array Copy
According to layer ] B reference " | Entire row
Criginal position " |Reference Amount 5 | Base point
Select lines | Follow Amount 5 | Base point
Draw line | Follow Amount 5 _ |Base point  Two-dimensional

1. By Floor: Generate copies by building floor or opening.

(1) Reference.
(D Check "Reference" to use the selected building's vertical plane as a reference plane.
@) If "Reference" is unchecked, the building's vertical plane within 2 meters is used as the reference

plane.

(2) Entire column.
(D Check "Entire column" to generate a copy of the column with the selected entity in-situ.
2 Uncheck "Entire column" to generate a column or layer of copies starting from the entity's location

and following the cursor position.

For example, check "Reference" and uncheck "Entire column". Click the "By Layer" button, first select the
vertical plane of the building as a reference, and then select the entities to be arrayed, so that the cursor moves
up and down (by layer) and specifies the end point to generate multiple copies of the entities between the two
points. The effect is shown in the following figure.
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After

2. Pick Point: Generates multiple copies starting with the selected entity.
(1) Reference.
(D Check "Reference" to generate a copy in the direction of the selected reference line.
2 With "Reference" unchecked, specify two points to determine a line and generate a copy along
that line.
(2) Amount.
(D Amount: generate copies of the amount entered in the text box (including the original entity).
(2 Distance: Click "Amount" in blue font and switch to "Distance". Set the distance between two
adjacent copies, and generate copies at this spacing.
(3) Base point.
(D Check "Base point" to specify the position relative to the original entity, using that point as the
starting point for the reference.
(2 The entity center point is used as the base point without checking the "Base Point" box.
For example, check "Reference", "Number", and "Base". Click the "Home" button, select the edges of the
building, entities, etc., then select the entities to be arrayed, specify the base point, move the cursor, and
specify the end point to generate multiple copies of the entities between the two points. The effect is shown

in the following figure.
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Copy Source entity
..... ~ I
3 direction w2 ‘
B
o
£,
o
=
Eeference line

3. Select Line: Generates a copy along the selected path.
(1) Follow.
@ Check "Follow" and the resulting copy is rotated to match the path orientation.
@ If "Follow" is unchecked, the copy is generated at the original angle.
(2) Amount.
@ Amount: generate copies in the amount entered in the text box.
@ Distance: Click "Quantity" in blue font and switch to "Distance". Set the distance between two
adjacent copies, and generate copies at this spacing.
(3) Base point.
@ Check "Base point" to specify the position relative to the original entity, i.e. the position of the
final copy relative to the path.
@ If "Base point" is unchecked, the entity center point is the base point, i.e. the center points of the
copies are all on the path line.
For example, check "Follow", "Number", and "Base point". Click the "Select Line" button, first select the
path line, then select the entity to be arrayed, according to the relative position of the base point and the

original entity, along the path line to generate a copy. The effect is shown in the following figure.
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______

Before

Note: If the specified base point is offset by a distance from the original entity, the final generated copy is
also offset by a corresponding distance from the path.
4. Draw Line: Generates a copy along the 2D or 3D line.
(1) Follow.
(D Check "Follow" and the resulting copy is rotated to match the path orientation.
@) If "Follow" is unchecked, the copy is generated at the original angle.
(2) Amount.
(D Amount: the default quantity. Generate copies of the amount entered in the text box.
(2) Distance: Click "Amount" in blue font and switch to "Distance". Set the distance between two
adjacent copies, and generate copies at this spacing.
(3) Base point.
(D Check "Base point" to specify the position relative to the original entity, i.e. the position of the
final copy relative to the path.
@) If "Base point" is unchecked, the entity's center point is used as the base point, i.e. the center
points of the copies are all on the path line.
(4) Two dimensional.
(D Two-dimensional: by default, path lines are drawn in the same way as two-dimensional polylines.
) 3D: Click on the blue font "2D" and switch to "3D". Draws the path line in the same way as a three-
dimensional polyline.

For example, check "Follow", "Number", and "Base point" to draw in 2D by default. Click the "Draw Line"
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button, select the entity to be arrayed, specify the base point first, then specify the location of the first copy to
be generated, and use it as the starting point to create the entity. Then draw the path in the same way as

drawing a polyline, and right-click to end the generation. The effect is shown in the following figure.

Before LAfter

4.1.18.2 Planar Array

L]
Generates multiple copies of selected object. Select "Edit Tab > Modify Panel > [II] Array > Planar

Array" to open the dialog box shown below.

Apply

Number of rows : & Row spadng : 1

Mumber of columns @ 4 Column spadng : 1

Angle: 0O Select

1. Parameter settings.

(1) Setting the number and spacing of copies.

(2) Set the angle of the array, either manually or by clicking on the blue font "Angle" and specifying two
points for drawing the line, using the angle between the line and the positive direction of the X-axis as
the angle of the line.

2. Click on "Select" in blue and select the objects (entities other than roads and terrain).

3. Click the "Apply" button to complete the array and generate multiple copies.
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4.1.19 Group

4.1.19.1 Entity Group

Groups multiple objects into a whole to facilitate operations such as moving, rotating, copying or deleting them.

Select "Edit Tab > Modify Panel > Group > Entity Group", and select multiple objects for grouping.
Note:
@ Groups do not support buildings and components.
@ Press ctrl + shift to select a single entity within the group.
@ Can group entities already in a group.

@ Select an entity while pressing down “ctrl + Alt” key to separate it from the group.

4.1.19.2 Entity Ungroup

e | r_
Removes the grouping relationship. Select " Edit Tab > Modify Panel > Group > — Entity Ungroup", and

select grouped objects to ungroup. You can also use "explode" function to ungroup entities. When ungrouping

entities in multi-layered groups, each single action only ungroups the outermost group.

4.1.20 Text
. . , Enter text
Inserts text into workspace. Select "Edit Tab > Modify
Panel > D Text" item to open the following dialog box.
Note:
@ When the cursor is on an arc, the text is f bt b o LB
Ciolor: 255,255 255 Thidkness: | 0.8
adjusted to the angle of the tangent plane.
Confirm

@ In the properties palette, the position, angle,

screen-facing properties and spacing of the

text can be modified.

@ You can double-click the text, or click the "Content" item in the property palette, and select:** button

to modify the text content.

4.2 Measurement Panel

4.2.1 Distance
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Measures the distance between two points. Select "Edit Tab > Measurement Panel > H Distance ", specify
two points, and display the distance value on the command line. When measuring, the distance is displayed in real

time in the program.

4.2.2 Line Angle

Measures the angle between two lines in the same plane. Select "Edit Tab > Measurement Panel > 4588 |ine

Angle", select two lines, and display the angle value on the command line.
Note:
(D When an arc is selected, the angle of the tangent line is measured.

@ The line angle is displayed in real time in the program during the measurement.

4.2.3 Plane Angle

Measures the angle between any two plane entities. Select "Edit Tab > Measurement Panel > EVE Plane

Angle", select two planes, and display the angle value on the command line.
Note:
@ Does not support measuring curved planes.

@ When measuring, the plane angle is displayed in real time in the program.
4.3 Positioning Panel

4.3.1 Normal Move

Moves a selected object along the normal direction of the selected plane or edge. Select "Edit Tab > Positioning

Panel > [:ﬂ Normal Move", follow the command line prompt, place the cursor on the plane or edge of the selected

object, highlight it and drag horizontally or vertically.
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Note:

(@ The cursor can snap to the planes or edges of entities. For example, the sides and top/bottom of a
building can be snapped, as well as the edges of entities such as balconies, planes, etc.

@ When a plane is snapped, the whole plane is highlighted and the red cross cursor is displayed. At this
point, drag along the plane in the vertical direction in a forward or reverse direction as indicated by
the arrow to achieve continuous operation.

@ When snapping to the edge or plane of a curved shape, move along the perpendicular direction of its
tangent line.

@ During dragging, move the cursor to other planes to align entities. Generally, select a plane in the same
direction as a reference. For example, when selecting the top plane of a building to move, holding the
left button down moves the cursor to the top plane of another building or other entity to make the
tops of both at the same height.

® Line entities are not supported.
4.3.2 Bottom Leveling
Adjust the floor elevation of selected object from its base point. Select "Edit Tab > Positioning Panel >=
Bottom Leveling", according to the command line prompt, select the reference plane first, and enter the height

relative to the reference plane, then select the object. You can adjust the elevation of the entity according to the

reference plane and the relative height.
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Before After

When selecting entities, enter “W”. You can box select multiple entities and adjust the height uniformly.
Note:

(@D When a reference plane is selected, the plane is displayed in red when it is clicked on the plane of a
volume. When there is no plane at the clicked location, a horizontal plane is automatically created in
red, centered on the clicked point, to indicate the reference plane.

@ If the relative height is set, the leveled elevation = the height of the reference plane + the relative
height. For example, if the reference plane is specified at a height of 10 m and the relative height is set
at 2 m, a building is selected whose lowest point elevation is 12 m.

@ Roads are not supported. Roads can be modified via the property palette for starting and end height

or elevation.

4.3.3 Axis Rotation

Rotates a selected object by the specified axis and angle. Select "Edit Tab > Positioning Panel > ' Axis
Rotation", according to command line prompt, put the cursor on the edge of the entity itself and click or enter the

angle to rotate around this edge as the axis. You can click continuously to rotate.
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Enter “S” to rotate object by using the edge lines of other entities as axes. For example, after entering “S”, first
select entity A as the rotation object, right-click to end the selection, at which point the cursor is placed on the edge
line of entity B and clicked, i.e., the edge line of B is used as the axis to rotate, to rotate A.

Note:

(@ Rotated objects support lines, planes (except grid planes), editable polygons and text.

@ Text cannot be rotated on its own axis. Text can be rotated by selecting another object as the axis of
rotation.

@ The rotation axis supports the selection of most entities, except for special entities such as background

scenes and text.

4.3.4 Rotate to Horizontal
Take the center point of a line or plane and rotate it so that it is parallel to the XOY plane. Select "Edit Tab >

Positioning Panel > ﬁ Rotate to Horizontal" and select the object to rotate it horizontally.

~ gy

Before After

Note:
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@ If the point is on a line, rotate the clicked line segment to horizontal by its midpoint; if the point is on
the plane of a plane or volume, rotate the clicked plane to horizontal by its center.

@ Grid planes are not supported.

4.3.5 Rotate Vertical

Take the center point of a line or plane and rotate it so that it is perpendicular to the XOY plane. Select "Edit

Tab > Positioning Plane > E Rotate to Vertical" and select the object to rotate horizontally.

Before

4.3.6 Adjacent Entities

Fits the selected plane or line to the specified position. Select "Edit Tab > Positioning Panel > Ef#8 Adjacent
Entities", first select the plane or edge of object 1 as reference, then select the plane or edge of object 2 to fit

together with object 1.

Before After

Note:
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(D When the plane of a volume is selected, it is aligned with the center of the plane.
@ When the edges of the entity are selected, they are aligned at the midpoint of the edges.
(@ Reference entities and parallel entities can be any one of: buildings and components, line and other

entities.

4.3.7 Align Entities

Aligns the selected plane or line to the specified position. Select "Edit Tab > Positioning Panel >iAIign
Entities" item, first select the plane or edge of object 1 as reference, then select a plane or edge of object 2, and

align with object 1.

Before

Note: Reference and parallel objects can be any one of: buildings and components, lines and other objects.

4.3.8 Arrange

4.3.8.1 Arrange Along Line

Arrange entities in order along a path. Select "Edit Tab > Positioning Panel > III Arrange Along Line" and follow

the command line prompts as follows.
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Before

Eeference object Entity net distance
- *I—F-
Lfter - -
MNormal net distance
------- Feference hine T

1. Enter a value to determine the normal net distance. For example; the distance between the object and the
reference line when it is finally lined up.

2. Select the edge lines of the objects as reference lines. Next, enter values to determine the distance between
aligned entities and select the entities to be aligned.

3. Finally, select the reference entity, and the other entities are arranged equidistantly with the reference entity

as the base.
4.3.8.2 Directional Copy

Copies a selected object in parallel or perpendicular direction to the reference line. Select "Edit Tab >

Positioning Panel > E Directional Copy", and follow the command line instructions as follows.

Page 108 of 236



Houseplan Make stunning 3D scheme with speed and ease

1. Select lines or solid edges as reference lines.
2. Select the entity to be copied, and at this point move the cursor to the parallel, perpendicular, or Z-axis
direction of the reference line, using the center of the entity as the base point to specify where the copy

is to be generated. Enter S to reassign the base point for copying.
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5 Modeling Menu

This chapter introduces various traditional and advanced modeling features that allow users to create,

modify and refine the buildings and entities in the scheme according to the rendered effect.

5.1 Advanced Modeling Panel

Advanced Modeling has powerful modeling capabilities, providing flexible and versatile point, line, plane-

related operations to deal with all kinds of complex modeling process easily and efficiently.

5.1.1 Advanced Modeling

Select "Modeling Tab > Advanced Modeling Panel > E&&d Advanced Modeling" to open the dialog box

shown below.

Advanced Modeling H
Vertex: 0O Edge: 0 Polygan: O Edged Faces e
/Create | Vertex | Edge | Polygon | Element | Object
[ Rectangle ] Box Convert
MGon Sphere
Polygon Cylinder
Circle Torus
Ellipse Cone
Donut Pyramid
Star
Polygon Ohject Convert
Transform: Q) Select Move Rotate Scale [ |Lock
State: [ Snap | orthogonal " | Ignore BackFacing [ Local
Constraint: | X L z XY ¥Z ZX

Note: In the vertex, edge, polygon, element and object tabs of advanced modeling, the Copy, Delete, Move,

Rotate, Scale and Delete functions or tools under "Edit" tab are not available.
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5.1.2 Display Mode

Click ™ button in the upper right corner of the panel to expand the drop-down list, as shown below.

1. Edged Faces: Editable polygons are displayed as "model + wireframe" by
Edoed Faces e

default. Wireframe
Facets

2. Wireframe: Displays in wireframe form.
3. Facets: Displays in model mode.

Note: You can use the shortcut key F9 to cycle through the three display modes.

5.1.3 Vertex, Edge, Polygon

Dynamically displays the total number of
Vertex: 146 Edge: 308 Polygon: 162

vertices, lines, and planes of editable polygons.

Note: Contains both selected and

unselected, hidden ones are not counted.

5.1.4 Transform

5.1.4.1 Select

Select is a status command that defaults to the selected state. Normally, objects can be added to the selection

set by "selecting them one by one" or "window selecting" for subsequent operations. As shown below:

1. To add objects to the selection set, you need to hold down the "Ctrl" key and select the object to be added.
2. To remove individual objects from the selection set, you need to hold down the "Alt" key and select the

object to be removed.
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3. To invert the current selection of objects, you need to hold down the "Shift" key and select the object to
invert the selection.
Note: The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can

be activated at any time.

5.1.4.2 Move

O Move

Selects and moves the object. When in the selected state, the object is moved in the following ways.

1. Move directly, click on an object and drag the mouse directly to move the object.

2. Select and move. Add the object to be moved to the selection set first, and move it by specifying the

reference point in the selection set as the base point.
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3. Right-click the Move button and set the move distance of the selected object in the pop-up window.

Move Transform Type-In

7. 0.000

The direction of movement is determined by the mouse and the current reference coordinate system. To
restrict the object's movement relative to the plane defined by the X, Y or Z axes or any two of them, click the
corresponding button on the Constraints toolbar or click directly on the axis to temporarily lock the corresponding
axis.

Note:

Page 113 of 236



Houseplan Make stunning 3D scheme with speed and ease

@ You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and
click the "OK" button to batch copy objects along the direction with equal intervals.

@ The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can
be activated at any time.

@ This command corresponds to the move command in the UV Editor.

5.1.4.3 Rotate

O Rotate

Selects and rotates the object. When is selected, the object is rotated in the following ways.

1. Direct rotation, click on an object and drag the mouse directly to rotate the object.

2. Select and rotate, the object to be rotated is first added to the selection set and rotated by specifying the

reference point in the selection set as the base point.
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469.45]

[42.69,-94.83

7. 0.000

The direction of rotation is determined by the mouse and the current reference coordinate system. To restrict
the rotation of the object to the plane defined by the X, Y or Z axis or any two of them, click the corresponding
button on the Constraints toolbar or click the axis directly on the axis to temporarily lock the corresponding axis. If
the XY, YZ or XZ axes are locked at the same time, the model will remain unchanged.

Note:
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@ You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and
click the "OK" button to batch rotate objects with equal angle.

@ The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them
can be activated at any time.

@ This command corresponds to the rotation command in the UV Editor.

5.1.4.4 Scale

0 scale

Selects and scales the object. When in the selected state, the object is scaled in the following ways.

1. Direct scaling, click on an object and drag the mouse directly to scale the object.

2. Select and scale, the object to be scaled is first added to the selection set and scaled by specifying the

reference point in the selection set as the base point.
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3. Right-click the “Scale” button and set the zoom scale of the selected object in the pop-up window.

Scale Transform Type-In

The direction of scaling is determined by the mouse and the current reference coordinate system. To restrict
object scaling to the plane defined by the X, Y or Z axis or any two of them, click the corresponding button on the

Constraints toolbar, or click directly on the axis to temporarily lock the corresponding axis.
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Note:
@ You can press the Shift key and dragging the axis, enter the number of copies in the dialog box, and
click the "OK" button to batch copy objects with equal proportion.
@ The Select, Move, Rotate and Scale options cannot be enabled at the same time; only one of them can
be activated at any time.

@ This command corresponds to the scale command in the UV Editor.
5.1.4.5 Lock

Enables or disables selection locking, which prevents accidental selection of other entities in complex scenes.

By default, this button is unchecked. By checking the lock button and enabling this feature, you can click or
drag the cursor anywhere in the viewport without losing that current selection set or adding unwanted new objects
to the current selection set. To cancel or change the selection, uncheck the lock item.

On the toolbar, check the lock button and activate one of the move, rotate, or scale buttons. Drag anywhere in

the viewport to move, rotate, or scale the objects in the selection set.

5.1.5 State

5.1.5.1 Snap

Snap Mode Settings

When creating and editing editable polygons in the

Advanced Modeling panel, you can enable the snap function Endpoint | center of drde
to assist in the operation for precise positioning. Click the 8 Midpaint B4 Closest paint
checkbox E5nap at the bottom of the panel to turn the | Intersection B Flane

snap function on or off. Right click on the checkbox & snap &4 Perpendicular point

i -5 &
to open the dialog box shown below. Mouse pick box(0-50): &

. . Mouse capture frame(2-20); 10
You can set snapping options, where "plane" refers to P (2-20) S—

) . Cursor length (1-100): 6
the surface of a plane or entity. Click the "Select All" button —

to check all the boxes; click the "Confirm" button to apply

Select all Cancel

the settings. \ y

Note: When snapping to the circle center of an arc,

you need to hover the cursor over the edge line to display the center of the circle.

5.1.5.2 Orthogonal
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Restricts the operation to horizontal or vertical orientation. Click the

Uzer
checkbox B Orthogonal at the bottom of the panel to turn the orthogonal function

on or off. Right-click the checkbox & Orthoganal to open the following menu. e
1. Select "World": Operation is performed in the world coordinates
direction (i.e., the axes in the lower left corner of the software).
2. Select "User": Operation is performed in the self-defined axis direction.

You can follow the command line prompts and enter the angle with the X direction of the world
coordinate system as the X-axis direction in the user coordinate system; or select the edge or line as the
orthogonal direction; you can also draw the line to obtain it. Enter “D” and press ENTER, specify two points,
and draw the orthogonal direction. If you need to clear the defined orthogonal direction, enter “C” and press
ENTER.

Note:

(@D When orthogonal is turned on, operations such as drawing can only be performed in the X, Y or Z axis

directions.

@ When both snapping and orthogonal are enabled, snapping takes precedence.

@ When drawing a line to obtain it, the two points are drawn with different directions and different

angles.
5.1.5.3 Ignore BackFacing

When this option is enabled, only points, lines, and planes visible in the workspace can be selected. With this
option disabled, all points, lines, and planes in the viewport can be selected. Click the checkbox [ Ianore BackFading

at the bottom of the panel to turn this feature on or off.
5.1.5.4 Local

The native position, i.e., the object's own coordinates. Click the checkbox kd Lacal at the bottom of the panel to
turn this function on or off.
Note:
@ When its own coordinates are checked, the axial direction of the operation is affected; when its own
coordinates are unchecked, it is the axial direction in world coordinates.
@ The operations affected are move, rotate, scale, mirror, array, align, transform, etc.

@ You can view the direction of the entity's own coordinates by using the "Axis Transformation" function.
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5.1.6 Constraint

Constraints, i.e., axial constraints. Click the button at the bottom of the panel to turn on or off the constraint

function for the corresponding axis, as the following figure shows.

Constraint: | * ¥ z XY YZ X

Note:

@Axis constraints affect the axes of move and zoom functions. For example, if you constrain the x-axis,
you can only move in the x-axis direction when you perform a move. Similarly, if the xy-axis is
constrained, the movement can only be made in the XOY plane.

@When "Snap" is checked, movement is in the direction of the constraint, although it is possible to move
by snap point.

@You can also achieve the constraint effect by dragging the cursor in an axial direction without checking

the "Constraint" box.

5.2 Create Tab

Convert objects such as planes and volumes into editable polygonal entities.

5.2.1 Polygon Tools

5.2.1.1 Rectangle

Creates a rectangular plane. Select "Create Tab > Polygon > Rectangle", specify the first corner point, drag it
to the target location as another corner point.
Note: After activating the drawn rectangular plane, its alias, accompanying layer color, smoothing, length,

width and other parameters can be modified on the property palette.

5.2.1.2 NGon

Creates a regular polygonal plane. Select "Create Tab > Polygon > NGon", enter a value to determine the
number of sides, and then start drawing. There are three ways to generate.
1. Draws asquare polygon internal to a circle: Specifying the center point and entering the radius generates

a square polygon.
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2. Draw a regular polygon based on the specified side lengths: Input or Enter “E” and press Enter to specify
two points as the lengths of the sides of the regular polygon.
3. Todraw asquare polygon tangent to a circle: Input or Enter “C”, specify the center point, enter the radius,
and generate a square polygon.
Note:
@The generated result is an editable plane.
@You can modify polygonal plane properties on properties palette.
@If the drawn polygon plane has been edited, the number of sides and the internal tangent radius

parameters in the property palette cannot be modified.
5.2.1.3 Polygon

Create polygonal planes. The generated result is an editable plane. Select "Create Tab > Polygon > Polygon",
specify the starting point, and draw the polygon directly; or enter “S” to draw the polygon in 3D space. To abort

the previous operation, type “U” and press enter.
5.2.1.4 Circle

Creates a circular plane. Select "Create Tab > Polygon > Circle" to create a circle with the specified center and

radius.
5.2.1.5 Ellipse

Create an elliptical plane. Select "Create Tab > Polygon > Circle" to create an ellipse with the specified center

and axis length.
5.2.1.6 Donut

Creates a ring with a circular cross section. Select "Create Tab > Polygon > Donut", specify the center of the
circle, and then set the inner and outer radii respectively.
Note:
@ To set the radius, specify the location with the mouse or enter the value at command line.
@ The property palette allows you to modify parameters such as alias, accompanying layer color,

smoothing, outer circle radius, inner circle radius, center point, etc.
5.2.1.7 Star
Creates a star-shaped closed plane. Select "Create Tab > Polygon > Star", specify the center point, enter a
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value to determine the number of star angles, and then set the outer and inner radii.
Note:
@To set the radius, specify the position with the mouse or enter the value at command line.
@The property palette allows you to modify information about parameters such as alias, accompanying

layer color, smoothing, corner points, outer radius, inner radius, center point, etc.

5.2.2 Object Tools

5.2.2.1 Box

Creates a box. Select "Create Tab > Object > Box", draw the bottom side of the box, enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached

to layers, smooth, length section, width section, height section, length, width, height, center, elevation, etc.
5.2.2.2 Sphere

Creates a sphere. Select "Create Tab > Object > Sphere", specify the center of the sphere, enter the radius.
Note: The property palette allows you to modify information about parameters such as alias, color attached

to layers, smooth, number of sides, radius, center, elevation, etc.
5.2.2.3 Cylinder

Creates a cylinder. Select "Create Tab > Object > Cylinder", draw the base of the cylinder, enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached

to layers, smooth, number of sides, height section, face section, radius, height, center, elevation, etc.
5.2.2.4 Torus

Creates a ring volume. Select "Create Tab > Object > Torus ", specify the center of the circle, enter the circle
radius and the radius of the torus.

Note: The property palette allows you to modify information about parameters such as alias, color attached

to layers, smooth, number of sides, section, rotate angle, inner circle radius, out circle radius, center, elevation,

etc.
5.2.2.5 Cone

Creates a cone. Select "Create Tab > Object > Cone", specify the center of the circle, enter the radius of the top

and bottom planes, enter the height.
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Note: The property palette allows you to modify information about parameters such as alias, color attached
to layers, smooth, number of sides, height section, face section, bottom radius, top radius, height, center,

elevation, etc.
5.2.2.6 Pyramid

Creates a pyramid. Select "Create Tab > Object > Pyramid", specify the center point, enter the number of sides,
enter the radii of the top and bottom external circles, and enter the height.
Note: The property palette allows you to modify information about parameters such as alias, color attached

to layers, smooth, number of sides, bottom radius, top radius, height, center, elevation, etc.

5.2.3 Convert Tools

5.2.3.1 Convert

Converts objects such as volumes, planes and buildings into editable polygons. Select "Create Tab> Convert >
Convert" and select the entity to convert it to an editable polygon.
Note: All entities except oblique photography, point cloud, and imagery data, can be converted to editable

polygons and their points, lines, and planes edited.

5.3 Vertex Tab

5.3.1 Delete

Erase the selected point. Select "Vertex Tab > Delete" and select the vertex to delete. The planes formed with

this point will be deleted together after deletion.

5.3.2 Copy

Copies the selected point. Select "Vertex Tab > Copy", select the point, specify the base point, and then specify

the target point to create a copy.

5.3.3 Select Invert

Selects all points in the current workspace other than the selected points. Select the "Vertex Tab > Select

Invert" item to select the object, all points other than the object are selected.

5.3.4 FFD
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Adds control vertices to the selected point, making it more evenly to adjust the shape of an object. Select
“Object Tab > FFD” to open the dialog box shown.

1. Control Points: when using FFD under this submode,

Free Transformation

the lattice frame will be shown in yellow and the © Contral Points Lattice Set Volume

control points on it can be selected and FFD Style

manipulated to change the shape of the object. A FFD 2x2x2 FFD 3x3x3

single or multiple control points can be adjusted at FFD s Custom

the same time. Current mode:  Cuboid mode

2. Lattice: when using FFD under this submode, the Cumrentsecion: |FED 3G

lattice frame will be shown in orange. The frame can

Select

be moved, rotated, or scaled. By default, if the

frame is moved or scaled, only vertices within the
volume of the object can be used for
transformation.
3. Set Volume: mainly used to set the initial state of lattice frame. Under this mode, when using FFD the
frame will be shown in green. The control points can be adjusted without affecting the shape of the

object. This provides better control when transforming irregular objects.
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4. FFD style: The default setting is rectangular mode,
with three different FFD styles: "FFD 2x2x2", "FFD
3x3x3" and "FFD 4x4x4". You can also customize the
style by clicking the "Customize" button to bring up
the dialog box shown below.

(1) Cuboid mode: Creates rectangular shape lattice
free-form transformations, where the number of
edit points in the XYZ axis can be set separately in
the rectangular parameters.

(2) Cylinder mode: Creates cylindrical shape lattice
free form. Radial, lateral and height edit points can
be set separately.

5. Set the parameters, select the editable polygon, and the
FFD edit box will appear on the selected volume to enter
the transformation edit mode.

Note:

(@ During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the

command will end.

Custorm FFD Parameter

© cuboid mode Cylinder mode

Cuboid parameters

Points in X direction: 3

Points in ¥ direction: 3 }_\@

Points in Z direction: 3

Cylinder parameters
Default Parameter: FFD 4264
Radial points: 4

Side points:

o
e

"l
ey

Height points: 4

Confirm Cancel

@ During operations, the three submodes can be switched to one another.

@ The precision of the FFD edit point on the object is related to the number of segments of the object

itself. The higher the number of segments, the higher the precision.

@ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more

FFD edit points, the smaller the range controlled by a single point.

® Ignoring back side is valid for FFD edit points.

@ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities

at the same time; if you need to execute deformation commands on multiple 3D entities at the same

time, you can " Attach" them as one volume and then use FFD transformation.

@ When FFD editing, move, rotate, and scale under "Edit" tab are not available.

5.3.5 Slice
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Specify a slicing line to generate a slicing plane. New vertices and lines will be generated where the model

and the plane intersect. Select "Vertex Tab > Slice", and select two points.

5.3.6 Cut

Cut planes to create new vertices and lines. Select "Vertex Tab > Cut", then click on an entity to continuously

specify positions to cut the plane of the entity.

5.3.7 Tessellate

Tessellate models by choosing to split the selected planes

Tessellate

with edge midpoint connections or with vertex connections.

After selecting a vertex, select "Vertex Tab > Tesselate", to Q) Edge Face
open the following dialogue.

Tension: 1
Choose to tessellate either edge or face, set tension, and click

Confirm to apply. Cancel

5.3.8 Drag

Drag select, with which vertices will be automatically
selected when the cursor hovers over them. Select "Vertex Tab > Drag", hold down left mouse button, and hover

over vertices to select them.

5.3.9 Target Weld

Drag the selected point to the target point to be merged (as close as possible) to automatically perform the
merge. Select "Vertex Tab > Target Weld" and select the starting point and target point to merge.
Note:
@ The starting point and the target point must be on the same line.
@ When the planes on which the points are located are not closed, points which do not lie on the same
line may be welded.
@ When points on different entities need to be merged, multiple entities should be "Attach" before

merging.

5.3.10 Break
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Break a shared vertex into multiple independent vertices for separate editing. Select "Vertex Tab > Break" and

select the vertex to break.

5.3.11 Weld

Weld multiple vertices of an editable polygon together into a single vertex. Select "Vertex Tab > Weld", select
the vertex and enter the weld distance, and the vertices within the range are welded as one.
Note:
@A successful weld is achieved when the distance entered is greater than or equal to the distance
between any vertices to the average position of the combined vertices.
@The vertices selected must be vertices in the same plane on the entity.

(3)When vertices on different entities are to be welded, multiple entities must be "Attach" before welding.

5.3.12 Exit

All points will exit the editing state. Select "Vertex Tab> Exit" to exit the editing state.

5.3.13 Remove

Removes a selected point. Unlike Erase, removing vertices does not destroy the integrity of the plane. Select

"Vertex Tab > Remove" item to remove the selected point.

5.3.14 Connect

Connect points on editable polygons with lines. Select "Vertex Tab > Connect", and draw lines by clicking on
vertices.

Note: while connecting vertices, the connecting line cannot intersect with other lines.

5.3.15 To Edge

By selecting a point, the line associated with that point is selected and switched to line mode.

Select "Vertex Tab > To Edge" item and select the line to select the line that connects this point.

5.3.16 Shrink

Shrink vertex selection towards the inner circumference direction from the currently selected point.

Select the "Vertex Tab> Shrink" item, select the vertex, and then shrink the selection one turn inward along the
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selected range.
Note:
(@ Automatically selects the vertices on the lines that shares sides with this point.

@ The Ignore Backfacing option has no influence on this command.

5.3.17 Grow

Extend vertex selection of the currently selected vertices in the peripheral direction.
Select the "Vertex Tab > Grow" item, select the vertex, and then expand the selection one turn outward along
the selected range.
Note:
@ Automatically selects the vertices on the lines that shares sides with this point.

@ The Ignore Backfacing option has no influence on this command.

5.3.18 Chamfer

Fillet selected points. Slice the selected edge to create a

Vertex Slicing

new plane. Select the "Vertex Tab > Chamfer ", select the Slidng amount: 5.000 .
vertex to be sliced fillet. Set the slicing amount and segment Segment: 1 =
parameters in the dialog box, and click Confirm. Open sliced corners: (]

Parameter Description: Cancel

1. Slicing amount: specifies the size of the chamfered
plane.
2. Segment: Input value between 1 and 10.

3. Open sliced corners: decides whether the cut corners are closed.
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5.4 Edge Tab

5.4.1 Delete

Erases the line on the selected editable polygon. Select "Edge Tab > Delete" and select the line to delete. The

planes formed with this line will be deleted together after deletion.

5.4.2 Copy

Copies lines on editable polygons into separate 3D polylines. Select "Edge Tab > Copy", select the line, specify

the base point, and then specify the target point to create a copy.

5.4.3 Select Invert

Selects all lines in current workspace other than the selected lines. Select the "Edge Tab > Select Invert" item

to select the object, all lines other than the object are selected.

5.4.4 FFD

Add control vertices to the selected edge to evenly adjust the shape of the object. Select “Edge Tab > FFD” to
open the dialog box shown.
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1. Control Points: when using FFD under this submode,

Free Transformation

the lattice frame will be shown in yellow and the ] ]
0 control Foints Lattice Set Volume

control points on it can be selected and FFD Style

manipulated to change the shape of the object. A FFD 2% 2%2 FFD 3x3x3

single or multiple control points can be adjusted at
FFD dx4xd Custom

the same time.
Current mode:  Cuboid mode

2. Lattice: when using FFD under this submode, the
Current selection:  FFD Jx3x3

lattice frame will be shown in orange. The frame can

Select

be moved, rotated, or scaled. By default, if the

frame is moved or scaled, only vertices within the
volume of the object can be used for
transformation.

3. Set Volume: mainly used to set the initial state of lattice frame. Under this mode, when using FFD the
frame will be shown in green. The control points can be adjusted without affecting the shape of the
object. This provides better control when

transforming irregular objects. Customn FFD Parameter

4. FFD style: The default setting is rectangular mode, 0 cuboid mode Cylinder mode

Cuboid parameters

with three different FFD styles: "FFD 2x2x2", "FFD
Points in X direction: 3

3x3x3" and "FFD 4x4x4". You can also customize the

Points in ' direction: 3 }\@
style by clicking the "Customize" button to bring up
Points in Z drection: 3

the dialog box shown below.

. Cylinder parameters
(1) Cuboid mode: Creates rectangular shape lattice Y P

) Default Parameter: FFD 4x6=4
free-form transformations, where the number of

Radial points: 4
edit points in the XYZ axis can be set separately in

Side points: [ }
the rectangular parameters.
Height points: =
(2) Cylinder mode: Creates cylindrical shape lattice

free form. Radial, lateral and height edit points can Cancel

be set separately.

5. Set the parameters, select the editable polygon, and the

FFD edit box will appear on the selected volume to enter the transformation edit mode.
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Note:

@ During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the
command will end.

@ During operations, the three submodes can be switched to one another.

@ The precision of the FFD edit point on the object is related to the number of segments of the object
itself. The higher the number of segments, the higher the precision.

@ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more
FFD edit points, the smaller the range controlled by a single point.

® Ignoring back side is valid for FFD edit points.

@ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities
at the same time; if you need to execute deformation commands on multiple 3D entities at the same
time, you can " Attach" them as one volume and then use FFD transformation.

@ When FFD editing, move, rotate, and scale under "Edit" tab are not available.

5.4.5 Slice

Specify a slicing line to generate a slicing plane. New vertices and lines will be generated where the model and

the plane intersect. Select "Edge Tab > Slice", and select two points.

5.4.6 Cut

Cut planes to create new vertices and lines. Select "Edge > Cut", then click on an entity to continuously

specify positions to cut the plane of the entity.

5.4.7 Tessellate

Tessellate models by choosing to split the selected planes with edge

. . . . . . Teszellate
midpoint connections or with vertex connections. After selecting a
" " . . © Edge Face
vertex, select "Edge Tab > Tesselate", and the following dialogue appears.
Choose to tessellate either edge or face, set tension, and click Confirm to Tension: 1 =
apply.

5.4.8 Drag

Drag select, with which lines will be automatically selected when the
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cursor hovers over them. Select "Edge Tab > Drag", hold down left mouse button, and hover over lines to select

them.

5.4.9 Fence

Fence select. Select all lines that intersect the line you draw. Select "Edge Tab > Fence", draw a polyline, and all

intersecting lines will be selected.

5.4.10 Create Shape

Extracts the contour lines. Select the "Edge Tab > Create Shape " item and select the line to generate a 3D
polyline.

Note: The 3D polyline generated can only be edited if you exit advanced modeling mode.

5.4.11 Measure

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines

evenly to divide the line or plane. Select the item "Edge Tab > Measure" and the dialog box pops up:

Measure

Ohject Method
O Line One line

Plane

Solid

Equipartition parameter

Segment: |2 — = +
Shrink: |0 _ - +
Slider: |0 s - +

Apply Cance
h, 4

1. Object: You can choose lines, planes, and solids.
(1) Line: "one line", an equal division of the selected line.
(2) Plane:

(D One line, one plane: an equal division of the selected plane according to the vertical direction of
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the selected line.
@ Multi-line: equally divide the associated planes based on the selected polyline.
(3) Solid:
(D One line: the volume is divided equally according to the vertical direction of the selected line.

@ Two lines: the volume is divided equally according to the two lines chosen.

-

2. Equipartition parameter: you can enter the value directly, or click the [=| button to adjust how many

segments you want to add, or you can drag the slider to adjust it.
(1) Segment: the default value is 2, means an equal division into 2 parts.

(2) shrink: moves all newly generated segment lines or points, either towards the center or towards the

ends.
(3) Slider: offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes,

both lines must belong to the same entity and must be coplanar.

5.4.12 Exit

All lines will exit the editing state. Select "Edge Tab> Exit" to exit the editing state.

5.4.13 Remove

Removes a line from an editable polygon. Select "Edge Tab> Remove" item to remove the selected line.
Note: After selecting the object:
@ Right-click or press space: removes the line and its endpoints, and the two planes that have a common
side with the line are combined into one plane.

@ Press Enter: removes the line and keeps the endpoints.

5.4.14 To Vertex

In line mode, select the point on the selected line and switch to point mode. Select "Edge Tab > To Vertex " and

after selecting the line, the point on the line is selected.

5.4.15 To Polygon

In line mode, select the plane associated with the selected line and switch to plane mode. Select "Edge Tab >

To Polygon " and after selecting the line, the associated plane is selected.
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5.4.16 Shrink

Shrink the selection of lines in the inward direction of the currently selected line. Select "Edge Tab > Shrink"

item, select the line, and then shrink the selection one turn inward along the selected range.

5.4.17 Grow

Extend the selection of lines in the outward direction of the currently selected line. Select "Edge Tab > Grow"

item, select the line, and then expand the selection by one circle along the selected range.

5.4.18 Chamfer

Slice the selected edge to create a new plane. Select the "Edge Tab> Chamfer", select the line to be sliced, and

the following dialog box appears.

Set the slicing amount and segment parameters in the Vertex Slicing
dialog box, and click Confirm. Slicing amount: 5.000 =
Parameter Description: Segment: 1 =
1. Slicing amount: specifies the size of the chamfered Cpen sliced corners: []
plane. Cancel
\, b

2. Segment: integer between 1 and 10.
3. Open slice corners: decides whether the cut corners

are closed.

5.4.19 Bridge

Within the same model, the Bridge command can create a plane between edges, and the new bridging plane

will be a part of the original mesh. Select " Edge Tab > Bridge", and the following dialogue will pop up:
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Bridge
Segments: 1 % Type:
Taper: 0,000 % Offset:  0.000 %
Twist 1: 0 % Twist2: 0 %
Cancel

Set number of segments, type, taper, offset, twist 1 and twist 2 parameters, click "Confirm" to apply.

Parameter Description:

1. Segments: Sets the number of equal segments for the plane generated by the bridge.

2. Type: Sets the type of plane generated by the bridge, the Liner and Curve are available.

3. Taper: Sets the extent to which the bridge width becomes smaller or larger toward its center. Negative value
tapers it smaller; positive value tapers it larger.

4. Offset: Determines the position of the maximum taper. Ranges from -99 to 99, with default 0.0, the amount
of taper is greatest at the center of the bridge.

5. Twistl. Twist2: Rotates the order of connection between the edges of the two selections. The two controls

let you set a different twist amount for each end of the bridge.

X
N\ |/ /.

a7 o

5.4.20 Ring

Creates one edge ring based on the current sub-object selection and selects the results. Select "Edge Tab > Ring
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" to select a line of a quadrilateral and press enter, then the opposite line is selected. For example, if the you select

the line “i”, the line “i+2” will be RING selected.
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Note: The command is only available to the quadrilateral plane.

5.4.21 Loop

Creates one edge loop based on the current sub-object selection and selects the results. Select the "Edge Tab >

Loop", and after selecting the line and pressing enter, connecting lines are selected.

advaroed Moceing |

Verts: 0 Eelyer: 10 Folvgon: 0 Edged Fazss

Crvale [ irlen M Eoge | Pulpgon | FBement [T Objeet ]

et Fence G

Caze

Note: The command is only available to the quadrilateral plane.

5.4.22 Border
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Quickly select border lines. Select "Edge Tab > Border", after selecting lines and press enter, all lines on the

edge will be selected.

5.4.23 Cap

In line mode, select the boundary line that needs to be sealed to generate a new plane. Select the "Edge
Tab > Cap" and select the closed line on the editable polygon to seal.
Note: Window select the editable polygon, and the system automatically searches for the closed lines on the

current polygon, and automatically excludes those that already have planes.

5.4.24 Insert Vertex

Manually add points to the edge for subdivision. Select "Edge Tab > Insert Vertex " and specify the insertion

point on the line.

5.5 Polygon Tab

5.5.1 Delete

Erase the selected plane. Select "Polygon Tab > Delete" and select the plane to delete.

5.5.2 Copy

Copy the selected plane. Select "Polygon Tab > Copy", select the plane, specify the base point, and then specify

the target point to create a copy.

5.5.3 Select Invert

Selects all planes in the current scene other than the selected plane. Select the "Polygon Tab > Select Invert"

item to select the object, all planes other than the object are selected.

5.5.4 FFD

Add control vertices to the selected plane to evenly adjust the shape of the object. Select “Object Tab > FFD”

to open the dialog box shown.
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1. Control Points: when using FFD under this submode,

Free Transformation

the lattice frame will be shown in yellow and the ] ]
0 control Foints Lattice Set Volume

control points on it can be selected and FFD Style

manipulated to change the shape of the object. A FFD 2% 2%2 FFD 3x3x3

single or multiple control points can be adjusted at
FFD dx4xd Custom

the same time.
Current mode:  Cuboid mode

2. Lattice: when using FFD under this submode, the
Current selection:  FFD Jx3x3

lattice frame will be shown in orange. The frame can

Select

be moved, rotated, or scaled. By default, if the

frame is moved or scaled, only vertices within the
volume of the object can be used for
transformation.

3. Set Volume: mainly used to set the initial state of lattice frame. Under this mode, when using FFD the
frame will be shown in green. The control points can be adjusted without affecting the shape of the
object. This provides better control when

transforming irregular objects. Customn FFD Parameter

4. FFD style: The default setting is rectangular mode, 0 cuboid mode Cylinder mode

Cuboid parameters

with three different FFD styles: "FFD 2x2x2", "FFD
Points in X direction: 3

3x3x3" and "FFD 4x4x4". You can also customize the

Points in ' direction: 3 }\@
style by clicking the "Customize" button to bring up
Points in Z drection: 3

the dialog box shown below.

. Cylinder parameters
(1) Cuboid mode: Creates rectangular shape lattice Y P

) Default Parameter: FFD 4x6=4
free-form transformations, where the number of

Radial points: 4
edit points in the XYZ axis can be set separately in

Side points: [ }
the rectangular parameters.
Height points: =
(2) Cylinder mode: Creates cylindrical shape lattice

free form. Radial, lateral and height edit points can Cancel

be set separately.

5. Set the parameters, select the editable polygon, and the

FFD edit box will appear on the selected volume to enter the transformation edit mode.
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Note:

@ During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the
command will end.

@ During operations, the three submodes can be switched to one another.

@ The precision of the FFD edit point on the object is related to the number of segments of the object
itself. The higher the number of segments, the higher the precision.

@ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more
FFD edit points, the smaller the range controlled by a single point.

® Ignoring back side is valid for FFD edit points.

@ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities
at the same time; if you need to execute deformation commands on multiple 3D entities at the same
time, you can " Attach" them as one volume and then use FFD transformation.

@ When FFD editing, move, rotate, and scale under "Edit" tab are not available.

5.5.5 Slice

Specify a slicing line to generate a slicing plane. New planes will be generated where the model and the plane

intersect. Select "Polygon > Slice", and select two points.

5.5.6 Cut

Cut planes to create new vertices and lines. Select "Polygon Tab> Cut", then click on an entity to continuously

specify positions to cut the plane of the entity.

5.5.7 Tessellate

Tessellate models by choosing to split the selected planes with edge

. . . . . . Tessellate
midpoint connections or with vertex connections. After selecting a
Edge Face
vertex, select "Polygon Tab > Tesselate", and the following dialogue Ocdg
appears. Choose to tessellate either edge or face, set tension, and click Tension: 1 =

Confirm to apply.
Confirm Cancel
5.5.8 Drag

Drag select, with which planes will be automatically selected when
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the cursor hovers over them. Select "Polygon Tab > Drag", hold down left mouse button, and hover over lines to

select them.

5.5.9 Fence

Fence selected. Select all lines that intersect the line you draw. Select "Polygon Tab > Fence", draw a polyline,

and all intersecting lines will be selected.

5.5.10 Smooth

Smooth the selected entity. Select "Polygon Tab > Smooth", after select editable polygons, and the following
dialog box appears.
Set number of iterations whether to display smooth effect, click "Confirm" to apply.

Parameter Description:

Iterations: Controls number of vertices that

are added to the polygon to smooth the mesh. [anme Show Smooth
< 0 show
Show: The smooth effect will be displayed. Iterations: ! - Hidden

Hide: The smooth effect will not be

displayed. 9 =

Note: when the number of iterations is O,

only display smoothness is active.

5.5.11 Measure

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines

evenly to divide the line or plane. Select the item "Polygon Tab > Measure" and the dialog box pops up:
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Measure
Ohject Method
Line One line, One plane
O rlane Multiine
Solid

Equipartition parameter

Segment: |2 = = +
Shrink: |0 - - +
Slider: |0 oo +

Apply Cance
., y,

1. Object: You can choose lines, planes, and solids.

(1) Line: "one line", an equal division of the selected line.

(2) Plane:
(D One line, one plane: an equal division of the selected plane according to the vertical direction of

the selected line.

@ Multi-line: equally divide the associated planes based on the selected polyline.

(3) Solid:
@ One line: the volume is divided equally according to the vertical direction of the selected line.

@ Two lines: the volume is divided equally according to the two lines chosen.

-

2. Equipartition parameter: you can enter the value directly, or click the [=| button to adjust how many
segments you want to add, or you can drag the slider to adjust it.
(1) Segment: the default value is 2, means an equal division into 2 parts.
(2) shrink: moves all newly generated segment lines or points, either towards the center or towards the
ends.
(3) Slider: offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes,

both lines must belong to the same entity and must be coplanar.
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5.5.12 Exit

All planes will exit the editing state. Select "Polygon Tab> Exit" to exit the editing state.

5.5.13 Detach

Break the selected plane into a new volume. Select "Polygon Tab > Detach " to select a plane for breaking,

which is shown in gray by default.

5.5.14 To Edge

While under the Polygon mode, select the lines on the selected plane and jump to the Edge mode. Select
"Polygon Tab > To Edge" and after selecting the plane, the lines on the plane are selected and switched to the Edge

Tab.

5.5.15 To Element

In polygon mode, select the elements related to the selected polygon and switch to element mode.
After selecting a polygon, select "Polygon Tab > To Element", and the related elements will be selected and

switched to the Element Tab.

5.5.16 Shrink

Shrink the selection of planes in the inward direction of the currently selected plane. Select "Polygon Tab >

Shrink" item, select the plane, and then shrink the selection one turn inward along the selected range.

5.5.17 Grow

Add planes on the outward direction of the currently selected plane into selection. Select "Polygon Tab > Grow"

item, select the plane, and then expand the selection by one circle along the selected range.

5.5.18 Flip Normal

Flip the planes with reverse direction of normal in the selection set so that the UV material can be displayed
properly. Select "Polygon Tab > Flip Normal " item and select the plane.
Note: The selected plane is flipped 180° along the center of its own, the results of modifications by other

commands to the editable polygon like Weld and Break, will not be changed.

5.5.19 Bridge
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Within the same model, the Bridge command creates a connecting plane between edges, and the bridging

plane will be part of the original mesh. Select "Polygon Tab > Bridge", and the following dialogue will pop up:

Bridge
Segments; 1 % Type:
Taper: 0.000 % Offset:  0.000 %
Twist 1: 0 % Twist2: 0 %
Cancel

Set number of segments, bridge type, taper, offset, twist 1 and twist 2 parameters, click Confirm to apply.

Parameter Description:

1. Segments: Sets the number of equal segments for the plane generated by the bridge.

2. Type: Sets the type of plane generated by the bridge, the Liner and Curve are available.

3. Taper: Sets the extent to which the bridge width becomes smaller or larger toward its center. Negative value
tapers it smaller; positive value tapers it larger.

4. Offset: Determines the position of the maximum taper. Ranges from -99 to 99, with default 0.0, the amount
of taper is greatest at the center of the bridge.

5. Twistl. Twist2: Rotates the order of connection between the edges of the two selections. The two controls

let you set a different twist amount for each end of the bridge.
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5.5.20 Outline

Offset the selected plane within the selection by the same proportion. Select "Polygon Tab > Outline" item,

select the polygon plane, and drag the cursor or enter a value to determine the offset distance.

5.5.21 Extrude Polygon

Performs vertical or horizontal extrusion of multiple planes of editable polygons within a selection set
according to polygons, groups, or local normal. Select "Polygon Tab > Extrude Polygon" and select the plane. Set the
parameters in the dialog box and click the "Confirm" button to squeeze the selected plane.

1. Polygons:  Vertical or lateral

extrusion in the normal direction of Extrude
the selected plane itself.
P Paolygon 0 Group Part normal
2. Group: Vertical or lateral extrusion in . .
Height: 1.000 — Outline: 0.000
the average normal direction of the
Apply Confirm
selected planes.
LW r

3. Local normal: Selected planes
adjacent to each other are merged

in the direction of their combined normal for vertical or lateral extrusion.

5.5.22 Extrude

Extrude the selected plane. Select "Polygon Tab > Extrude" item, the selected object will be highlighted, drag
the mouse or enter the exact value to extrude. Entering “Y” on the command line will retain the selected plane;
entering “N” will not retain the selected plane; before pressing Enter to finish the command, you can select any
additional planes to continue extruding.

Note: Align the cursor to other entities when extruding, then the selected extrusion plane can be extruded to

the same height as the selected entity.

5.6 Element Tab

5.6.1 Delete

Erases the selected element. Select "Element Tab > Delete" and select the element to delete. Erases a single
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instance element and also deletes other instance entities of the same source.

5.6.2 Copy

Copies the selected element. Select "Element Tab > Copy", select the element, specify the base point, and then

specify the target point to create a copy.

5.6.3 Select Invert

Selects all elements in the current scene other than the selected element. Select the "Element Tab > Select

Invert" item to select the object, all elements other than the object are selected.

5.6.4 FFD

Add control vertices to the selected elements to evenly adjust the object shape. Select “Object Tab > FFD” to
open the dialog box shown.

1. Control Points: when using FFD under this submode,

Free Transformation

the lattice frame will be shown in yellow and the © Contral Points Lattice Set Volume

control points on it can be selected and FFD Style

manipulated to change the shape of the object. A FFD 2x2x2 FFD 3x3x3

single or multiple control points can be adjusted at FED 4xdx4 Custom

the same time. Current mode:  Cuboid mode

2. Lattice: when using FFD under this submode, the )
Current selection:  FFD 3x3x3

lattice frame will be shown in orange. The frame can

Select

be moved, rotated, or scaled. By default, if the

frame is moved or scaled, only vertices within the
volume of the object can be used for
transformation.
3. Set Volume: mainly used to set the initial state of lattice frame. Under this mode, when using FFD the
frame will be shown in green. The control points can be adjusted without affecting the shape of the

object. This provides better control when transforming irregular objects.
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4. FFD style: The default setting is rectangular mode,
with three different FFD styles: "FFD 2x2x2", "FFD
3x3x3" and "FFD 4x4x4". You can also customize the
style by clicking the "Customize" button to bring up
the dialog box shown below.

(1) Cuboid mode: Creates rectangular shape lattice
free-form transformations, where the number of
edit points in the XYZ axis can be set separately in
the rectangular parameters.

(2) Cylinder mode: Creates cylindrical shape lattice
free form. Radial, lateral and height edit points can
be set separately.

5. Set the parameters, select the editable polygon, and the
FFD edit box will appear on the selected volume to enter
the transformation edit mode.

Note:

(@ During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the

command will end.

Custorm FFD Parameter

© cuboid mode Cylinder mode

Cuboid parameters

Points in X direction: 3

Points in ¥ direction: 3 }_\@

Points in Z direction: 3

Cylinder parameters
Default Parameter: FFD 4264
Radial points: 4

Side points:

o
e

"l
ey

Height points: 4

Confirm Cancel

@ During operations, the three submodes can be switched to one another.

@ The precision of the FFD edit point on the object is related to the number of segments of the object

itself. The higher the number of segments, the higher the precision.

@ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more

FFD edit points, the smaller the range controlled by a single point.

® Ignoring back side is valid for FFD edit points.

@ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities

at the same time; if you need to execute deformation commands on multiple 3D entities at the same

time, you can " Attach" them as one volume and then use FFD transformation.

@ When FFD editing, move, rotate, and scale under "Edit" tab are not available.

5.6.5 Slice
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Specify a slicing line to generate a slicing plane. New planes will be generated where the model and the plane

intersect. Select "Element Tab > Slice", and select two points.

5.6.6 Cut

Cut elements to create new vertices and lines. Select "Element Tab > Cut", then click on an entity to

continuously specify positions to cut the plane of the entity.

5.6.7 Tessellate

Tessellate

Tessellate models by choosing to split the selected planes with edge
0 Edge Face

midpoint connections or with vertex connections.

) Tension: 1
After selecting a vertex, select "Element Tab > Tesselate", and the

following dialogue will pop up: Cancel

Choose to tessellate either edge or face, set tension, and click

Confirm to apply.

5.6.8 Drag

Drag select, with which objects will be automatically selected when the cursor hovers over them. Select

"Element Tab > Drag", hold down left mouse button, and hover over objects to select them.

5.6.9 Fence

Fence selected. Select all elements that intersect the line you draw. Select "Element Tab > Fence", draw a

polyline, and all intersecting elements will be selected.

5.6.10 Smooth

Smooth the selected entity. Select "Element Tab > Smooth", and the following dialogue will pop up:
Set number of iterations and whether to display smooth effect, click Confirm to apply.

Parameter Description:
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Iterations: Controls number of vertices that
are added to the element to smooth the mesh.

Show: The smooth effect will be displayed.
not be

Hide: The smooth effect will

displayed.

Note: when the number of iterations is O,

only display smoothness is active.

5.6.11 Measure

TurboSmoaoth

Iterations: O =

Show Smooth
0 show

Hidden

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines

evenly to divide the line or plane. Select the item "Element Tab > Measure" and the dialog box pops up:

Object

Line
Flane

0 solid

Equipartition parameter

Segment: |2
Shrink: |0
Slider: |0

Apply

1. Object: You can choose lines, planes, and solids.

Method

One line
Two lines
- +
- +
- +
Cancel

(1) Line: "one line", an equal division of the selected line.

(2) Plane:

(D One line, one plane: an equal division of the selected plane according to the vertical direction of

the selected line.

@ Multi-line: equally divide the associated planes based on the selected polyline.

(3) Solid:
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(@ One line: the volume is divided equally according to the vertical direction of the selected line.

@ Two lines: the volume is divided equally according to the two lines chosen.

-

2. Equipartition parameter: you can enter the value directly, or click the [~ button to adjust how many
segments you want to add, or you can drag the slider to adjust it.
(1) Segment: the default value is 2, means an equal division into 2 parts.
(2) Shrink: moves all newly generated segment lines or points, either towards the center or towards the
ends.
(3) Slider: offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes,

both lines must belong to the same entity and must be coplanar.

5.6.12 Exit

All elements will exit the editing state. Select "Element Tab> Exit" to exit the editing state.

5.6.13 Detach

Break the selected element into a new, independent object. Select "Element Tab > Detach" and select the
polygon to be broken, which is grayed out by default.
Note:
@The entity to which the relationship is attached is separable.
@If the volume is divided into separate parts by operations such as removing points and lines, one of

the parts (elements) can be separated.

5.6.14 To Polygon

Select polygons related to an element and switch to the Polygon mode.
After selecting an element, select "Element Tab > To Polygon", and the related polygons will be selected, while

jumping to the Polygon Tab.

5.7 Object Tab

5.7.1 Delete

Erase editable polygons or other entities. Select "Object Tab > Delete" and select the object to delete.
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5.7.2 Copy

Create copies of editable polygons. Select "Object Tab > Copy", select the object, specify the base point, and
then specify the target point to create a copy. The default is no instance copy. Enter “Y” and press Enter, and the
entity generated by the copy has an instance relationship with the original entity. You can copy on indefinitely

before entering and exiting this command.

5.7.3 Select Invert

Selects all editable polygons in the current scene other than the selected volume. Select the "Object Tab >
Select Invert" item to select the object, the editable polygons other than the object are selected. Hidden editable

polygons cannot be reverse selected.

5.7.4 FFD

FFD is a special lattice transformation editing tool. A lattice frame will be visible after selecting a model (a
lattice frame is a frame that envelops the object), and the shape of the object can be adjusted using the control
points on the frame to produce a smooth transformation and avoid tearing. FFD can be used directly as an editing
tool or as an implied space shifting tool. Select "Object Tab > FFD" to open the dialog box shown.

1. Control Points: when using FFD under this submode,

Free Transformation

the lattice frame will be shown in yellow and the © Contral Points Lattice Set Volume

control points on it can be selected and FFD Style

manipulated to change the shape of the object. A FFD 2x2x2 FFD 3x3x3

single or multiple control points can be adjusted at FED 4xdx4 Custom

the same time. Current mode:  Cuboid mode

2. Lattice: when using FFD under this submode, the Cumrenit selection:  [FED Sea3

lattice frame will be shown in orange. The frame can

Select

be moved, rotated, or scaled. By default, if the

frame is moved or scaled, only vertices within the
volume of the object can be used for
transformation.
3. Set Volume: mainly used to set the initial state of lattice frame. Under this mode, when using FFD the
frame will be shown in green. The control points can be adjusted without affecting the shape of the
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object. This provides better control when transforming irregular objects.

4. FFD style: The default setting is rectangular mode,

Custom FFD Parameter

with three different FFD styles: "FFD 2x2x2", "FFD

© Cuboid mode Cylind d
3x3x3" and "FFD 4x4x4". You can also customize the Yiinder mode

Cuboid parameters

style by clicking the "Customize" button to bring up Pinks in X drection: |3

h,

'

the dialog box shown below. Points in Y direction: 3 }..":‘."F

(1) Cuboid mode: Creates rectangular shape lattice Paints in Z direction: 3

free-form transformations, where the number of
Cylinder parameters

edit points in the XYZ axis can be set separately in
Default Parameter: FFD 426 =4

the rectangular parameters. Radial points: |4
(2) Cylinder mode: Creates cylindrical shape lattice Frorre }@
free form. Radial, lateral and height edit points can Height paints: 4

be set separately.

5. Set the parameters, select the editable polygon, and L )

the FFD edit box will appear on the selected volume
to enter the transformation edit mode.
Note:
@ During operations, the advanced modeling dialogue will not disappear. Close the dialogue and the
command will end.
@ During operations, the three submodes can be switched to one another.
@ The precision of the FFD edit point on the object is related to the number of segments of the object
itself. The higher the number of segments, the higher the precision.
@ The fewer the number of FFD edit points, the larger the range controlled by a single point; the more
FFD edit points, the smaller the range controlled by a single point.
® Ignoring back side is valid for FFD edit points.
@ Only one volume in the scene can be transformed at a time, you cannot edit two or more 3D entities
at the same time; if you need to execute deformation commands on multiple 3D entities at the same
time, you can " Attach" them as one volume and then use FFD transformation.

@ When FFD editing, move, rotate, and scale under "Edit" tab are not available.
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5.7.5 Slice

Specify a slicing line to generate a slicing plane. New planes will be generated where the model and the plane

intersect. Select "Object Tab > Slice", and select two points.

5.7.6 Cut

Cut an editable 3D solid into multiple entities. Select "Object Tab > Cut", select the entity to be cut, specify the
starting point, and draw a polyline as the cutting line; or enter S and press Enter, and select a line as the cutting line
to cut the 3D entity.

Note:

@Two points specified Cutting line is not available to cut 3D objects in the 3D View (available when in
the Front, back, top, bottom, left or right View).

@Selected cutting lines are available to cut 3D objects when in the Front, back, top, bottom, left or right
View.

@The selected cutting line must go through the model.

5.7.7 Tessellate
Tessellate
Tessellate models by choosing to split the selected planes with edge
O Edge Face

midpoint connections or with vertex connections.

After selecting a vertex, select "Object Tab > Tesselate", and the Tension: 1 -
following dialogue appears. Choose to tessellate either edge or face, set Cancel
tension, and click Confirm to apply. b i

5.7.8 Drag

Drag select, with which 3D objects will be automatically selected when the cursor hovers over them. Select

"Object Tab > Drag", hold down left mouse button, and hover over objects to select them.

5.7.9 Fence

Fence selected. Select all 3D objects that intersect the line you draw. Select "Object Tab > Fence", draw a

polyline, and right-click, all intersecting 3D objects will be selected.
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5.7.10 Smooth

Smooth the selected entity. Select "Object
Tab > Smooth", and the following dialogue will
pop up:

Set number of iterations and whether to

display smooth effect, click Confirm to apply.

Parameter Description:

TurboSmoath Show Smooth

= 0 show
Iterations: |0 =
Hidden

Iterations: Controls number of vertices that are added to the element to smooth the mesh.

Show: The smooth effect will be displayed.

Hide: The smooth effect will not be displayed.

Note: when the number of iterations is 0, only display smoothness is active.

5.7.11 Measure

Select a line or plane on an editable polygon, enter the number of equal segments, and add vertices or lines

evenly to divide the line or plane. Select the item "Element Tab > Measure" and the dialog box pops up:

1. Object: You can choose lines, planes, and solids.

Ohject Method
Line One line
Flane Two lines
0 solid
Equipartition parameter
Segment: |2 - +
Shrink: |0 = +
Slider: |0 - +
Apply Cancel

(1) Line: "one line", an equal division of the selected line.
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(2) Plane:
(D One line, one plane: an equal division of the selected plane according to the vertical direction of
the selected line.
@ Multi-line: equally divide the associated planes based on the selected polyline.
(3) Solid:
@ One line: the volume is divided equally according to the vertical direction of the selected line.

@ Two lines: the volume is divided equally according to the two lines chosen.

-

2. Equipartition parameter: you can enter the value directly, or click the [=| button to adjust how many
segments you want to add, or you can drag the slider to adjust it.
(1) Segment: the default value is 2, means an equal division into 2 parts.
(2) shrink: moves all newly generated segment lines or points, either towards the center or towards the
ends.
(3) Slider: offsets all newly generated segment lines or points as a whole on the plane.
Note: For the equipartition of planes, multiple lines must be coplanar; and for the equipartition of volumes,

both lines must belong to the same entity and must be coplanar.

5.7.12 Select by Name

Select the object by name.

Select the "Object Tab > Select by Name" item and the following dialog box will appear.
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Choose A Body By Mame

|| Caze sensitive

Modeld01 Sort

Modeloo2

Modeld3 D alphabet sequence
By color
By size

1. Screening:
(1) Search box: search for entity names, with support for fuzzy searches, where the names of models that
match the criteria are selected in the list.
(2) List of names: the names of entities under the list can be selected singly or multi-selected (by pressing
ctrl or shift).
(3) Sort: Search results can be sorted alphabetically, by RGB value of the color or by size.
2. All: select all entities in the list.
3. Click the Confirm button to select the entities filtered in the list in the scene.
Note:
@Double-click on the entity name to position it in the middle of the view and maximize its display.
@You can select all models with the same initials by entering the first letter of the model name in the
list in the search field.

@The name selection is only valid for entities with free-form properties.

5.7.13 Attach

Attach multiple editable polygons into one volume for easy editing and mapping operations. Select the "Object

Tab > Attach" item, and select the volume and attached objects.
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Note:
(D Additional entities cannot select instance entities that are homologous to the subject.
@ The editable polygon subsets when appended are all elements.

@ To detach, you can use the detach function under element.

5.7.14 Extrude Line

Extrudes a selected line into a plane. Select "Object Tab > Extrude Line" and select the line to open the dialog
box shown below.

1. Parameter settings.

Squeeze Undefined Line

(1) Squeeze direction.

. Squeeze direction
(D Select "Horizontal squeeze" to
Horizontal squeeze ) Vertical squeeze out

squeeze the line horizontally into

a plane. Sgueeze parameter
2 Select "Vertical squeeze" to Sgueeze value: 1.000 =
squeeze lines in the vertical Segment: 1 =

direction to form a plane.

(2) Squeeze parameters. e

Sealing begin
@Squeeze value: used to set the S
Sealing end
squeeze value.

@Segment: Used to set the

number of segments in the

squeeze direction.
(3) Sealing parameter: When selecting a
closed line for squeezing, the sealing parameter can be set to control whether the beginning and end
are closed.
2. Click "Confirm" button to generate editable polygons according to the set parameters.
Note:
@ The "squeeze" command may be executed on only one line at a time.
@ Only "Vertical Squeeze" can be selected for 3D lines, and there is no squeeze effect for lines drawn in

the Z-axis direction.
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5.7.15 Lattice

Converts a line segment or edge of a drawing into a cylindrical structure with optional polyhedrons on the
vertices, mostly used to produce frame of buildings. Select "Object Tab > Lattice" and select Editable Polygons to
open the following dialog box.

1. Parameter settings. Crystal Lattice

(1) Parameter: Parameter

(D Show points only: Only points of editable Show points only

polygons will be shown. SIaT=In

(2 Show lines only: Only the lines of editable O oth

polygons will be shown. Line

jus:  0.150 =
3 Both: Displays both points and lines of Radius:

Mumber of sides: 5
editable polygons.

Angle:  g.oon :
2) Line.
) € Ignore hidden edges
(D Radius: Sets the size of the radius of the " |End sealing

volume generated by the crystal lattice. —

. Tetrahed Octahed
2 Number of sides: Sets the number of edges EEET (elEEEE

) ) Icosahedron
of the cross-section, the larger its value the

o Radius:  0.150] =
more rounded it is. _—

3 Angle: set the angle of lattice lines.
Confirm Cancel

@ Ignore hidden edges: Check this checkbox . s

to lattice only the visible edges; uncheck it
to lattice all edges.

® End sealing: Check this checkbox to cap the volume generated by the latticed lines to make a
closed shape.

(3) Point.
(D Tetrahedron, octahedron, icosahedron: For setting the basic shape of the node.
(2 Radius: Used to set the radius of the node, i.e. the size of the node.
2. Click the "Confirm" button to generate it.

Note: Editable polygons cannot be latticed twice, and latticed lines cannot be angularly rotated.
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5.7.16 Boolean

Two intersecting bodies can be intersected, subtracted or combined to produce a new object. Select "Object
Tab > Boolean", select the subtracted object, and then select the reference object, you can directly do subtract
operations; enter “I”, select two objects for intersection operations; enter “U”, select two objects for merging
operations.
Note:
@The two objects on which the Boolean operation is performed must be closed models.

@The order in which the two objects are selected during the subtraction operation affects the result of

the operation.

5.7.17 Mirror

Generates a mirror copy of the selected volume. Select "Object > Mirror", select the object, enter “N”, the
entity generated by mirroring is not an instance of the original entity; enter “Y”, the entity generated by mirroring
is an instance of the original entity. Select the object to be mirrored to open the dialog box shown below.

1. Parameter settings.

Mirrering

(1) Mirror axis: Used to set the symmetry axis or symmetry plane Mirror axils
H . n n o O.!c Xy
of the mirroring. Where "offset" is used to set the offset
Y ¥z
distance of the mirrored object from the original object. , .
(2) Clone current selection: Used to set whether to keep the Offset: 0,000 2
original entity. Clone the current selection
© o doning
2. Click the "Confirm" button to generate it. Copy
Note: Instance
@Mirroring is affected by the in-situ position and is mirrored by
Cancel
its own axes when the in-situ position is turned on.

@When the mirror-generated entity is an instance of the original
entity, the original entity will be changed when internal changes such as point/line/plane/element are

made; when it is not an instance, they are not affected by each other.
5.7.18 Instance

Entities and their properties can be assigned to other editable polygons. When an instance object is modified,
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other instance objects bound with it will change as well. Select "Object Tab > Instance" item, first select the instance
representative, and then select other editable polygons, enter to confirm. To revoke instancing, enter “U” and press
Enter and select the object you want to revoke instancing.
Note:
@Objects after instantiation, when making internal changes such as point/line/plane/element, other
instanced objects will also change.

@If the instance is moved, rotated, or scaled under the volume level, the instance object does not change

with it.
5.7.19 Loft
Align Pivot
Causes the selected section to generate a volume along the specified . »
path. Select "Object Tab > Loft" to open the dialog box shown below. N . T .
1. Align Pivot: the loft cross-section is, by default, centered on the A
” [ »
path, and it can be proportionally aligned to different positions as
Parameters
desired.
Angle:  |0.000
2. Parameters: Path: |z
(1) Angle: Sets the rotation angle of the loft cross-section. Step: (4
(2) Path: Sets the number of path segments. Mirror Horizontal
(3) Step: When the section is a line, you can set the fineness of Mirror Vertical
the graph cross-section. | |

3. Mirror Horizontal / Mirror Vertical: set the mode of mirroring.

After setting the above parameters, click " button, select a path,

and select lines or planes of editable polygons as the lofting object. Click Apply, and an editable polygon will be

generated by lofting the selected object.

5.7.20 Array

The array operation allows multiple identical bodies to be copied at the same time and for these objects to be

arranged in space in a certain order and form. Select "Object Tab> Array" item, select the object, and the following
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dialog box will pop up.

1. Parameter Note:
X
(1) Offset distance: Sets the spacing between each Offeet distance:  0.000 .
array object along the X, Y and Z axes. Rotation angle: 0,000 =
(2) Rotation angle: Sets the angle at which the
Y
array object is rotated. Offeet distance:  0.000 =
2. Amount: i.e. the number of copies generated. Rotation angle;  0-000 =
3. After setting the parameters, click "Confirm" button
z
to generate it. Offest distance: 0,000 :
Note: Rotation angle:  0.000 =
@ The array is affected by the in-situ position, -
Mumber: 2 =
which when turned on arrays by its own axes.
@ Adjusting the number and Z-axis rotation angle

to achieve a circular array.
@ In the case of a ring array, for the same

editable polygon, if the axis position changes, the array shape changes.

5.7.21 Adjust Pivot

Changes the position of the editable polygon axis. Select "Object Tab> Adjust Pivot", and select the object, the

following dialog box will pop up.

Adjust Pivot

1. Axial transformation.

. Axis center transformation
(1) Set axis center to center: resetting the

Set axis center to center | | Set axis center to bottom
axis to the position of the object's center.
Custom Axis reset
(2) Set axis center to bottom: placing the

axis at the point of minimum Z value of Cancel

the object's axis.

(3) Custom: Customize the position of the
axis, drag the axis or axis to move it, see "Move" for details.
(4) Axis rest: reset the axis location back to default.

2. Click the "Confirm" button to apply the axis settings.
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5.7.22 Align

Move the selected object so that it has the same X, Y, or Z coordinates as the other objects. Select "Object Tab >

Align" item, select the reference object, and then

select the current object, the following dialog box will Center Aligned
pop up. Alignment position
0 ¥ Axis ¥ Axis Z Axis

1. Alignment position: aligning the coordinate

values of the current object with the reference L e L

object by different alignments.

2. Click the "Confirm" button to apply the current \ y

settings.

Note: Turning on the in-situ position only affects the coordinates of the reference object, while the current

object is always aligned to its own coordinates.

5.7.23 ShapeMerge

Project the line or plane onto a selected plane. Select "Object Tab > ShapeMerge" item, select editable polygons,

and then select Line or plane.

Note:

@The selected line or plane is projected onto the plane closest to the editable polygon.
@The lines are selected must be in the same plane and closed.

@The selected plane must be flat.

5.7.24 shell

Increase entity thickness in its local normal direction or the reverse direction. Select "Object Tab > Shell", and

the following dialogue will pop up:

Page 161 of 236



Houseplan Make stunning 3D scheme with speed and ease

Parameters:

Inner Amount: increase thickness along the opposite
Parameters
direction of local normal; Inner Amount:  0.000 =
Outer Amount: increase thickness along the direction of Outer Amount:  1.000 =
local normal; Segments: 1 =
Segments: divide the added thickness into segments.
Select
Select:
Select Edges | | Straighten Corners | |
Select Edges: select the edges of the segments of added - -
Inner Faces || Quter Faces ||
thickness;
Straighten Corners: the thickness of corners will be the Cancel

same as the entered thickness while executing the shell
command;
Inner Faces, Outer Faces: select inner faces or outer faces;

After the parameters are set, click "Confirm" to apply.

5.8 Solid Editing Panel

5.8.1 General Extrude

Extrudes a selected plane or line of a volume.
Note:
@ General extrusion supports buildings, lines, planes, and volumes.

@ Lines are not involved in extrusion.
5.8.2 Extrude Cross-section
Select a closed area on a plane of an entity and extrude it into a volume.
5.8.3 Make Arc

5.8.3.1 Strings into Arcs
Arcing a plane or part of a plane on a volume. Select "Modeling Tab > Solid Editing Panel> H Make Arc >
H Strings into Arcs" item. There are two types of arcing.
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1. To arc the whole plane, select a plane or plane on the volume and specify or enter a value to determine the

arcing distance. The effect is shown in the following figure.

2. Type “P” and press Enter to specify two points for local arcing. The effect is shown in the following figure.

Befaore After

Note:
@ Plane arcing supports planes, volumes, buildings, convex balconies, and concave balconies.
@ When plane arcing a building, only its vertical planes may be manipulated.
(@ Dragging the arced node to adjust the length, position and distance of the arc.

@ Chord length arcing does not support curved planes.

5.8.3.2 Tangents into Arcs
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Arcing a straight edge of a prong or plane on a volume. Select "Modeling Tab > Solid Editing Panel>n

Make Arc >-Tangents into Arcs", select the edge or plane to be arched, enter the radius of the corner, you
can specify the mouse or enter a value less
than or equal to the maximum radius to
determine the radius of arcing.

Note: Tangent arcing supports planes,

volumes, buildings, convex balconies,
Before After

and concave balconies.

5.8.4 Multi-plane Loft

3D solids are created by lofting between several cross-sections. Select "Modeling Tab > Solid Editing Panel >

” Multi-plane Loft", there are two loft methods.

1. Lofting by straight grain effect. Select lines or planes to be generated in the selected order.

2. Type “F” and press enter to loft with Smooth Fit Effect.
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Note: The generated models differ in the order in which the sections are selected.

5.8.5 Single-plane Loft

5.8.5.1 Move
Places the plane vertically and tangentially to the selected path. Select "Modeling Tab > Solid Editing Panel >

D Single-plane Loft > D

Move", select the line or

plane as cross-section, then

specify the base point on the

section, select the path, and |::>
specify the placement point <

of the section on the path.
Before

Note:
@ If the cross-
section and the path are coplanar, no volumes can be generated, so it is necessary to use "Placement".

@ The location of the cross-section is where the volume is generated.

5.8.5.2 Mirror
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Mirrors the selected plane along the
specified edge to adjust its location.

Select " Modeling Tab > Solid Editing o o

Panel > D Single-plane Loft > EIE [‘1:_[# P

Mirror", select the line or plane as the

Bafare Aftar

cross-section, select the path as the
mirror axis, and mirror the section.

Note: The cross section must be on either side of the path range, otherwise the mirroring will not succeed.
5.8.5.3 Path Generation

Generates a volume along the

specified path. Select "Modeling Tab >

P P i M
. S
Solid Editing Panel > D Single-plane " /.//

. -~ E > - \
P m— 3

- . .
Loft > E Path Generation ", select the “‘9-*" %

line or plane as cross-section, then
Before After

select the path. You can select multiple

lines as the path line.

5.8.6 Lathe

Rotates a 2D entity around an axis to generate a 3D entity. Select "Modeling Tab > Solid Editing Panel > u_j

Lathe", select the object to be rotated, line or plane, specify the starting point of the axis. In the command line
prompts there are three ways to specify the axis.
1. After specifying the start and end points of the axes, generate entities around the axes at the angles entered.
2. Press return and pick the line as the axis of rotation.
3. Enter X, Y, or Z and press Enter to form a rotation axis parallel to a coordinate axis. For example, enter X to
specify the X-axis base point through which a rotation axis parallel to the X-axis is generated following the

command line prompt. Using the selected axis as an example, the effect is shown in the following figure.
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Note: A line wrapped around an axis generates a plane, and a plane wrapped around an axis generates a volume.

5.8.7 Split Entity

Splits an entity into multiple entities. Select "Modeling Tab > Solid Editing Panel > ﬂ Split Entity " and
select the plane of the object to be split.
1. Creates a splitting plane directly at the
specified point. Specifying points and
orienting the splitting plane to split the

volume.

2. Enter “S” and press Enter to split the

volume with the selected split line.
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3. Type “H” and press Enter to draw split lines
in the same way you would draw a

polyline to split a volume.

Note: Before
@ splitting objects does not support
building components.

@ splitting lines does not support 3D polylines and spirals.

5.8.8 Union

Creates a new solid by joining two or more solids. Select "Modeling Tab > Solid Editing Panel > |_I_F Union",

select multiple intersecting entities and perform union operation.

RN

e,

aee
aes

Befaore After

Note:
@ Merging objects supports planes, volumes, buildings, and flower pools.
@ The building and the volume are merged as entities to produce the building.

@ Entities, other than buildings, must be of the same type to be merged.

5.8.9 Subtract

Creates a new solid by subtraction. Select "Modeling Tab > Solid Editing Panel > |__I Subtract ", select the

subtracted object, then the reference object to perform the subtraction operation.
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Note:
@ The objects to be subtracted and the reference objects can be planes, volumes, buildings, flower pools
and water bodies.

@ The newly generated entity attributes after subtraction follow the subtracted object.

5.8.10 Intersect

Creates a new solid from overlapping two solids. Select "Modeling Tab > Solid Editing Panel > . Intersect",

select two intersecting entities and perform the intersection operation.

Note:
@ Intersection object can be planes, bodies, buildings, flower pools and water bodies.

@ The newly generated entity attributes after intersection follows the first object selected.

5.9 Generate Panel
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5.9.1 Line/Plane Conversion
Converts a line whose beginning and end are connected enclosing a closed area into a plane, or converts a

plane into a line. Select "Modeling Tab > Generate Panel > E Line/Plane Conversion" and select the line or plane

to convert.

Progmaiia

n B Fiars
Alban

] Coda anached w ayers

5.9.2 Polysolid

Draws or extracts edges on a volume, and stretch them into planes or volumes. Select "Modeling Tab >

Generate Panel > 88 Polysolid" item to open the following dialog box.

Drawing Line And Surface Body

4 8 m &8

1. Free drawing: draw line entities freely and stretch them into planes or volumes. Click on the [4 button to
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draw a line in the same way as a polyline, right click to end the drawing. After the cursor captures the axis
is highlighted in yellow, move or enter a value, right click to end, and stretch it into a plane; to stretch it into
a volume, continue to move the mouse to stretch or enter a value.

2. Draw along the edge: draw along the edge of the entity to obtain a line entity, and you can stretch it into a

plane or a volume. Click on the 3 button, specify a point on the edge of the entity, move the cursor along

the edge, right click to end the drawing, and stretch or enter the stretch distance.

3. Select a building component: draw along the floor line of a building or component to obtain a line entity,

which can be stretched into a plane or a volume. Click on the button, specify a point on the floor line of
the building or component, and stretch or enter the stretch distance.
Note:
(@ Building components support the selection of balconies, windows, doors, roofs.
@ When picking a point, picking a corner point that is coplanar cannot get the edge.

4. Select objects: Select lines, edges of planes, and edges of volumes to stretch them into planes or volumes.

Click the ) button, select the object and stretch or enter the stretch distance.

i o -
& O
draw draw draw Generate
Line ™ Ploygon — ™ Solid — ™ crate

5.9.3 Extract Single Plane

Extracts the outline of the specified plane of the entity and generates the plane by the outline. Select

"Modeling Tab > Generate Panel > #s Extract Single Plane" and select the entity you want to extract the plane
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from.
5.9.4 Plane Offset
Creates plane entities that are equidistant from all sides of the original plane. Select "Modeling Tab > Generate

Panel > E Plane Offset", select the plane to be offset, specify the offset position directly or enter the value to be

offset.

Note: When entering a distance, positive values are shifted outward and negative values are shifted inward.
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6 View Menu

This chapter presents a range of commonly utilized 3D viewing tools, which can be employed by the user to

fine-tune the project's visual impact for optimal results during the design process.

6.1 Perspective Panel

6.1.1 Pan

Moves the position of the view
without changing the position or
scale of the objects in the drawing.
Press and hold the middle mouse

wheel enables Pan operation as well.

6.1.2 Orbit

Dynamically moves the
observer around the model while
maintaining the same focus point. Pressing “Ctrl + middle mouse wheel” enables orbit view as well. If you have an

entity selected and then use this function, the view is rotated with that entity as the center point.

6.1.3 Centering

Zooms to display the largest extents of all objects. It calculates all extent of objects and the original coordinates

of drawings will not be modified. Select Centering tool to fix these problems.

6.1.4 Full View

Displays all entities in the workspace to the maximum extent possible. Enter “Z” and press Enter at the

command line. Enter E and press Enter can achieve full map operation as well.

6.2 3D Navigate Panel
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6.2.1 View Control

Switches current workspace 3D perspective view from different
directions. Click on the corresponding blue arrow to set the view direction,

and click on the "Flat" button in any view, the view will turn to the flat state.

6.3 View Tools Panel

6.3.1 Eye View

Turn on human eye view perspective. Select "View Tab > View Tools Panel > Eye View", follow the command
line prompts, set the height offset, and specify the site location. The angle of view will automatically shift to the
current eye height, and the default is the sum of the site height and the offset height. You can continue to enter
values to adjust, and the view will be lowered or raised. Press and drag the left button in the scene to view around

by human perspective.

Note:
@Height offset means height of human eye. Height offset + height of site location = final eye height.
@After designating a position, you can rotate the view by dragging the mouse to browse, or use the

arrow keys 1, |, «<—, — on the keyboard to rotate and move the operation.

6.3.2 Front Face

Select the plane on the volume to display its front view.
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6.3.3 Window View

Maximizes the display of selected area, and enables full display and return to the previous view. Select Window
View tool, and directly specify a two-point box range to zoom in on the view within that range. At the command

line prompt, enter “E” to display the full view; enter “P” to return to the previous view.

6.3.4 Previous View

Returns to previous view performed.

6.4 Hide Panel

6.4.1 Hide Selected

Hides the selected entities. Select "View > View Tools > H Hide Selected" and select the entities to hide.

6.4.2 Hide Unselected

Hides unselected entities. Select "View > View Tools > H Hide Unselected", select entities, and hide all other

entities.

6.4.3 Unhide

Unhide entities. Select the "View > View Tools > H Unhide" item to display the hidden entities in the view.
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7 Material Menu

Material refers to the texture of an object and can be seen as a combination of object material and texture. In
rendering programs, it is the combination of the various visual properties of the surface, referring to the color,

texture, smoothness, transparency, reflectivity, refractivity, luminosity, etc. of the surface.

7.1 Material Panel

7.1.1 Image

Automatically calculates the texture of the plane of an entity and attaches the image material to the entity at

the appropriate size. Select "Material Tab > Material Panel > Image", the following dialog box will appear.

Obnge-ndz rutifacstad Lanypmrad Singls =nhby
7 - Residenlial buibkdng
1 - ffice buiding
Commercial buiding
Sk
Haspital
1 2

Mohile structure
+ -::c:lt:ﬂ-:b-.lldm; Standard e
”Eat":": Paameler adjust=enl Rafacton map Bumpmap
@ @ oifise: [ 120,120,100
speailr cobr: [ o000
i * emsve: [ .00
Smoothress: 0 : I
Speculr level: 0 =1
Gow: [ =1
5 5 Anisstropy!  1x
Dpadty: 100 = 1

Alpha test: 0 =1
||' Color adjustment | | LV Tramsformeson || Double-sded display

1. Apply Material

(1) Single-sided: Applies the material on a single side of an entity, and paste a whole material image on
one plane. Click "Single-sided" button, the cursor will change to a straw, and select the material in
the dialog box or pick the material of existing entity.

(2) Multi-sided: Paints multiple sides of the entity continuously, and calculate the texture size

automatically according to the height. Click "Multi-sided" button, select the material, select the

Page 176 of 236



Houseplan Make stunning 3D scheme with speed and ease

2.

starting plane of the entity.
(3) Floor: Painting materials according to the floor of the building.
(4) Single-Body: Paints the material on the entire entity.
Material Adjustment.
(1) Preview window.
(DA preview window can be added after double-clicking on the default material in the dialog box or
after drawing a material on a scene entity.
@Right-click on the preview image to reset, reset all the materials in the preview window and view
the path of the material.
(@ Drag and drop the material to a new preview window to copy the material.
(2) Material effects: The dialog box is preset with five material effects: standard, glass, metal, wood and
dirt, which can be selected in the drop-down menu.
(3) Parameter adjustment: Adjustment of

. . Color Adjustment
the parameters of the material. Glow is E

only effective at night. Hue: 0 -
(4) Color Adjustment: Adjust the color SN L
. L Brightness: a ':.

parameters of a material, click "Color _—
Contrast: 0 =

Adjustment" button to open the dialog

box shown below.

LR

]| IIIIIIIi!!III SR

]

Users can adjust different color

=

parameters like hue, saturation, brightness

and contrast.

R

After adjusting the parameters, click on

the "Save" button to save the adjusted

Apply Reset

parameter values and apply them; click
"Reset" button to restore all parameter
values to their default values.

(5) UV Transform: Adjusts the UV animation rate of the material to make it have dynamic effect. Click the

"UV Transform" button. Adjustment of parameters changes material effects in real time.
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LV Transformation
UV Animation
Speedu 0.0 =1 |
SpeedV 0.0 =1
%, .

(6) Double-sided display: Check to display both sides of the entity after painting the material; uncheck to
display one side of the entity after painting the material.
(7) Reflection map: Adds a reflection map to the material and adjust the parameters to make the material
more realistic.
(8) Bump map: Adds a bump map to the material to give it a bumpy feel.
3. Add material.
(1) Click the right mouse button in the category list to open the context menu, as shown above.
@ New: New material type.
@ Delete: Deletes the newly created material type.
@ Edit: Modifies the name of the new material type.
@ Import: Select the folder and import the folder's material images.
(2) Right-click on the material image or on a blank space to open a context menu to remove or add
materials.
Note:
@ External images can be in jpg, png, dds formats.

@ You can drag an external image into workspace, select the paint method and object to paint it.

7.1.2 Material

Paints the material on the entity with the default texture parameters. Select "Material Tab > Material Panel >

Material" to open the following dialog box.
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(1) Single-sided: Paints a material on a single side of an entity, applying the material to the plane in
accordance with the default texture.

(2) Floor: Paints materials according to the floor of the building.

(3) Element: Paints the material on a single element of the attached entity. Only for elements in editable
polygons.

(4) Single-body: Paints material on the entire entity.

(5) Multi-select: Selects multiple entities to paint the material at same time.

7.1.3 Coating

Paint coating onto entities. Select "Material Tab > Material Panel > ﬁ Coating".
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Base color(B):

T .
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Custom color{C):

00 0 N HueE): 0 RedR): 250
- - - - l_ l_ - - Saturation(s): D_ Green(G): ﬂ
O singleside [ Single entity (| Group Color |Purity(0) Brightness(L): 250 Blue(B): 250
layered () Multiselect Add to custom color(A)

"Custom colors" are saved in the software, so you can add frequently used colors to "Custom colors" for future

use.

When drawing in colors, the RGB values drawn in can be inaccurate due to ambient light effects.

7.2 Edit Panel

7.2.1 Adjust Texture

Adjusts the display scale, orientation,

and position of entity materials. Select Adjust Textures

Zoom
Horizontal |0.708 Z|

"Material Tab > Edit Panel > Adjust

Texture " to open the following dialog box. Vertical 0,708 ﬂ
- +
1. Texture scaling: Adjusts the scale of Rotate
Angle 0.000 3
material textures. 0 . 50
. Panning
2. Texture rotation: Adjusts the
Horizontal | 0.000 3
R R e
orientation of the material texture. %’3
Verical  |0.000 ﬂ '
3. Texture offset: Adjusts the position of - +
the material texture. Body Editing Modify All Mirror Horizontal ~ Mirror Vertical

4. Single-sided modification:
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Modification of the material texture of a single side.

5. Single entity modification: Modification of the texture of the same type of material on a single entity.

6. Modify all: Modifies the textures of all materials of the same type in the scene.

7. Horizontal mirroring: Mirrors the selected single-sided, single-volume or full material in the horizontal
direction.

8. Vertical Mirroring: Mirrors the selected single-sided, single-volume, or full material in the vertical
direction.

Note: You can use the "Material" function if you want to apply an adjusted texture to another entity.

7.2.2 Replace Material

Replaces materials of the same type on multiple

L . . Texture Replacement
or all entities in the scene. Select "Material Tab > Edit

Multi-select ) all
Replace Material ". wall space o

Panel > =t

1. Multi-select: Replaces the same type of

material on the selected entity. Click on the

"Multi-select" button, select the default 2
material or the material of the entity on

workspace, then select the object to replace

the material, and finally select the material to 5

be replaced.

2. All: Replace the same type of material on all

entities. Click on "All" button, select the

default material or the material that draws
the entities on workspace, and then select the
material to be replaced. | 587

Note: "Replace Material" only replaces the

texture and material effect, not the UV of the

texture.

7.2.3 Free Adjustment
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The material textures of the entities are mapped to the appropriate projection and adjusted to refine the

effect of the project. Select "Material Tab > Edit Panel > E Free Adjustment".

Free Adjustment

BEOEE | B B |Osnestc Omitracnd Osety O
Range
L |1.000 =] -
-
w (1000 i + {»-::3:
|_L_I.'I
H |1.000 3 -
Amount
u |1.000 - - + .
{,_,an.:-
"'l‘_ll"'l
v | 1.000 =1 - 2
Panning
U |0.000 =] -
-
vy |0.000 = - + {»-:i?:
|_L_I_'.
W |0.000 - - -
Rotate
U |0.000 =
-180 0 180
v |0.000 = N
-180 0 180 %-;ii‘:'
W |0.000 = =
-180 0 180
Zoom
u | 1.000 - - -
-
v | 1.000 So- + {»-:ﬁ:
._-\_1_'.
w | 1.000 =1 -

1. Material texture projection method.
(1) Rectangle: Retextures the material of an entity as a rectangle projection.
(2) Column: Retextures the material of an entity as a cylindrical projection.
(3) Spherical: Retextures the material of an entity as a spherical projection.
(4) Planar: Retextures the material of an entity as a planar projection.

(5) Plane: Retextures the material of an entity as a default projection.
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2. Mirroring.
(1) Horizontal mirroring: Mirrors in U-direction selected single-sided, multi-sided, single-body or all
materials.
(2) Vertical Mirror: Mirrors a selected single-sided, multi-sided, single-body or all materials in the V-
direction.
3. Adjustment: Review "Image" and "Material" functions for more details.
4. Parameter adjustment.
(1) Range: Sets the length, width and height of the edit box.
(2) Amount: Sets the number of times the material texture is repeated.
(3) Offset: Sets the offset distance in the UVW direction of the material texture.
(4) Rotation: Sets the rotation angle in the UVW direction of the material texture.
(5) Scale: Sets the scale of the material texture in UVW direction.
Note:
@ Free adjustment does not support the selection of file entities (fbx/skp/osgb models, image maps,
matching entities, plant entities, skeletal animations).

@ Click on the blue texts to reset the parameters.

7.2.4 Match Material

Matches and applies a selected material of existing plane, volume or building to other ones. Select "Material

Tab > Edit Panel > Match Material" to pick a material. You can choose the painting method according to the
command prompt. There are five types of painting methods.

1. Direct select the entity material to totally match another entity.

2. Pick a material, type “D” and press Enter to apply the material to a single plane.

3. Pick a material, type “L” and press Enter to apply the material to a single floor of the building.

4. Pick a material, type “M” and press Enter to apply the material to multiple entities.

Note: "Pick Material" not only mimics the texture and material effect, but also mimics the uv of the texture,

which is different from "Replace Material ".

7.2.5 Glass Effect

Applies glass effect to existing glass component. Select "Material Tab > Edit Panel > Glass Effect".
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1. Single-select: Click on the glass

material to apply a glass effect to the
single dick to select the entity. Double dick to select &l glasses

selected glass component.
2. Select All: Double-click the glass
material to apply a glass effect to all

glass components.

Note: Supports the selection of

balconies, windows, doors, dormer
windows, and glass curtain walls. The

effect can also be applied to glass materials on other entities.

7.2.6 Outside Wall Region
Zoning of the building's vertical planes and the gables to allow for material painting to refine the project's effect.

Select "Material Tab > Edit Panel > Outside Wall Region".

1. Horizontal area: Draws horizontal zones. Click the Q
Outside Wall Region

button to specify the starting position or enter “C” on the

O
=
[
[w]
H

command line to select by floor.

(1) After specifying start and end points, then follow the I E—

command line prompts to select another vertical
plane.

(2) To draw by floor, enter “C” and press Enter, specify

directly or enter the number of floors to determine the -

starting floor, then determine the ending floor, then

select other vertical planes as prompted on the

command line.

2. Vertical Area: Draws vertical zones. Simply click on the |]:| button and follow the command line prompts

to specify the start and end positions.

3. Horizontal Wrap: Draws a zone through the floors. Click on the % button to specify the starting position

or enter “C” on the command line to select by floor, in the same way as for "Horizontal Area".
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4. Image mapping: Defines closed lines or planes as zones or project onto a building to automatically

generate zones. Clicking on E button and select a plane or closed line will allow the selected object to be
projected onto the building to generate a zone.

T button and select the

5. Place Zone on Top: Adjusts the display order of overlapping zones. Click on the
overlapping zones to display the selected zone on top.
Note:
(@ Snap needs to be turned on when drawing zones.
@ Floor Zoning can only be drawn or defined on the above-ground part of a building, and they belong to
the building and are changed when the building is moved, deleted or copied.
@ Roofs do not support Floor Zoning for drawing horizontal areas.
@ For image mapping, the cursor click point must be projected on the building and the selected object
must be £ 2 m from the building for the mapping to be successful.
® Double-click on the Floor Zoning to drag and drop the clip point to edit or press Delete to delete.
@ Double-click on a building to select all zones on it.
@ When the height of a building changes, the zones selected by floor also changes.
Checking the Floor Zoning allows modifying the hierarchical relationships in the right-hand property

column.

@ Please use the "single-body" paint method when painting the zoned material.

7.2.7 Material Optimization

Optimizes and merge same materials. Select "Material Tab > Edit Panel > Material Optimization" to apply

this function. Use this feature to optimize material efficiency when the scene is large.

7.2.8 UV Editor

UV Editor can adjust the textures of model materials. The interface is a 2D space and the UV textures
dynamically change with related 3D model. While adjusting texture coordinates, if the UV texture is complicated,
just execute the Mapping UVs feature to update the 2D texture coordinates of the 3D model, and the curved faces
will be cut into proper shells, which are displayed on the same plane and available to be exported to other drawing

software to apply textures for the 3D model. After that, the UV Editor also supports to perform necessary minor
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adjustments.

Select "Material > Edit Panel > UV Editor", and the following window will pop up:

U Editar [ = |

Wiz UWiepchot  MeppmgWVs Gt Sem  Uefokl Layeut  Ted - [ ibhon

-a—Siatus Bar

7.2.8.1 State
Switch texture border display, shade UV shells, and toggle whether textures are shown in UV Editor. Select "UV
Editor > State", and the dropdown menu will be as follows:
1. Texture Borders: toggle display of texture borders on UV

Texture Borders
shells. If on, the borders will be shown in yellow highlight. Distorbion Shader

2. Distortion Shader: determine the stretched or compressed Image

areas by coloring the shell. Red means stretched, and green

means compressed. The darker the red, the more stretched, and vice versa. White means normal.

3. Image: toggle whether to show textures in UV Editor.

7.2.8.2 UV Snapshot

Export the current UV images to external files. Select "UV Editor > UV Snapshot", and the following dialogue
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will pop up:

UV Snapshot >

File name: | | |

1024

Size(pixel):

Color Value: -

Parameter Description:

1. File name: set the name and save path of the current UV images. Click | *** | button, enter a file name, and
specify a file location.
2. Size (pixel): set the size of current UV maps;
3. Color Value: set the border color of UV maps
After setting these parameters, click Confirm to export.
Note:
@ Exporting cannot be done if no models are selected.
@ Under point, line, or UV vertex mode, the entire model in the UV editor will be exported even if only

partial is selected; under poly, ele, or UV shell mode, only selected part will be exported.

7.2.8.3 Mapping UVs

Mapping includes automatic, planar, spherical, and cylindrical mapping. Select the appropriate mapping
method based on the general shape of the model. Select "UV Editor > Mapping UVs", and the following dialogue

will pop up:
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Mapping UVs >

Automatic LIV &

Planar UV ¥ ¥ z

Spherical Uy

Cylindrical Uy

Parameter Description:
1. Automatic UV:

Automatic UV tries to find the best UV placement by projecting from multiple planes. It creates UV
coordinates for the selected object or polygon, with the default being six projection planes. Click the
dropdown button to select the number of projection planes and set projection plane parameters to affect the
result of automatic UV mapping. The more projection planes, the fewer stretched and compressed planes

there are. As shown below:

Model in the 3D scene Unfolded maps in the editor

When using automatic UV mapping, the 3D view will display projection planes, gizmo, and rotation axis

relative to the screen with the selected object in the center, as shown below:
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Projection Plane

Gizmo

Rotation axis
relative to screen

uUv
Coordinate Axes

(1) Projection planes are blues planes with an opacity of 60%. Each border of a projection plane is
displayed in either red or green, corresponding to the UV coordinate axes, the axes of the
viewport of the mapped model.

(2) The gizmo can be moved, rotated, and scaled to adjust the bounding box of the 3D model to
change the mapping result.

(D Move: put the cursor on the axis, axial plane or axial center of the gizmo. When the gizmo is
highlighted in yellow, hold down left mouse button to drag.

2@ Rotate: click on the rotation axis relative to the screen to activate. Put the cursor on any rotation
axis, and when the axis is highlighted in yellow, hold down left mouse button to drag.

3 Scale: click on the cube at the end of the axes and put the cursor on a cube. When the cube is
highlighted in yellow, hold down left mouse button to drag.

2. Planar UV
Use planar UV to create UV texture coordinates for the selected object. The default is the X-axis. Click to

select X, Y, or Z axis and generate a projection plane based on that axis, as shown below:
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Model in the 3D scene Unfolded maps in the editor

When using planar UV, the border will be shown with the selected object as the center in the 3D view, as

shown below:

(1) The border frame is shown in "H" shape. Move and scale the border frame to change the width to
height ratio in the mapped result to avoid distortion.
@ Move: put the cursor on the cube at the center of the border frame. When the cube is highlighted
in yellow, hold down left mouse button to drag.
@ Scale: put the cursor on the corner or the midpoint of an edge. When the point is highlighted in

yellow, hold down left mouse button to drag.
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(2) Click the intersecting lines on the frame to activate gizmo and rotation axes relative to screen. Click
again to hide them. See Automatic UV for detailed instructions on gizmo and rotation axes.
3. Spherical UV
Use spherical UV to create UV texture coordinates for the selected object. This projection loops around

the mesh. It's best used for completed closed spheres without holes. The effect is shown below:

Model in the 3D scene Unfolded maps in the editor

When using spherical UV, the bounding frame will be shown in the 3D view with the selected object in

the center, as shown below:

(1) There are cubes of different colors on the bounding circles which can be used to adjust the position

and size of the bounding circles.
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(@D Green cube: put the cursor on the green cube, and when it's highlighted, hold down left mouse
button to drag the cube and the bounding circle will be changed along the local Z axis.
@ Red cube: put the cursor on the red cube, and when it's highlighted, hold down left mouse button
to drag the cube and the bounding circle will be changed along the local X axis.
@ Blue cube in the center: put the cursor on the blue cube in the center of the bounding circle, and
when it's highlighted, hold down left mouse button to change the scaling of the bounding circle.
@ Blue circle: put the cursor on the blue circle, and when it's highlighted, hold down left mouse button
to change the rotation of the bounding circle.
(2) Click on the cubes on intersecting lines to activate gizmo and rotation axes relative to screen. Click
again to hide them. See Automatic UV for detailed instructions on gizmo and rotation axes.
4. Cylindrical UV
Use cylindrical UV to create texture coordinates for the selected object. This projection loops around the

mesh. It's best used for completed closed cylinders without holes. The effect is shown below:

Model in the 3D scene Unfolded maps in the editor

When using spherical UV, the bounding frame will be shown in the 3D scene with the selected object in

the center, as shown below:
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(1) There are cubes of different colors on the bounding circles which can be used to adjust the position
and size of the bounding circles.

@ Green cube: put the cursor on the green cube, and when it's highlighted, hold down left mouse
button to drag the cube and the bounding circle will be changed along the local Z axis.

@ Red cube: put the cursor on the red cube, and when it's highlighted, hold down left mouse
button to drag the cube and the bounding circle will be changed along the local X axis.

@ Blue cube in the center: put the cursor on the blue cube in the center of the bounding circle,
and when it's highlighted, hold down left mouse button to change the scaling of the bounding
circle.

@ Blue cube connected to the center: put the cursor on the blue cube, and when it's highlighted,
hold down left mouse button to change the rotation of the bounding circle.

(2) Click on the intersecting lines to activate gizmo and rotation axes relative to screen. Click again to hide

them. See Automatic UV for detailed instructions on gizmo and rotation axes.
7.2.8.4 Cut

Separate UV along selected edge to create UV borders. Select "UV editor > Cut", put the cursor on the edge to
be cut, and when the edge is highlighted in white, hold down left mouse button and hover over it.
Note:
(@ The cut function can be used in the UV view and the 3D view.

(@ Before the cut command is finished, the selected cutting line is green by default. Hover over the green
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line and it will be sewed.
7.2.8.5 Sew

Sew the UV along selected edge to sew two separated lines together. Select "UV editor > Sew", put the cursor
on the edge to be sewn, and when the edge is highlighted in white, hold down left mouse button and hover over it.

Note: when the cursor hovers over sewn edges, the sewing is done automatically.
7.2.8.6 Unfold

Unfold UV along cut lines. By unfolding the UV onto a 2D space, texture drawing can be easily done and applied
to the model. Select "UV Editor > Unfold", and select the model to unfold.
Note: UV make up the UV grid, similar to how vertices make up polygon meshes. The unfolding process is like

cutting a piece of cloth and laying it on top of a table.
7.2.8.7 Layout

Automatically arrange the UV shells to maximize the space utilization from 0 to 1. It can also set the size of UV

shells. Select "UV Editor > Layout", and the dropdown menu is shown below:

Layout Along
Texel Density

1. Layout Along: Automatically arrange the UV shells to maximize the space utilization from 0 to 1. Click

Layout Along and the following dialogue will pop up:

Layout Along it

Texture Map Size(pixel): 1024 =

Shell Padding: | 10.000

Preserve 30 Ratios: |:|

Apply Reset

(1) Texture Map Size (pixel): set the resolution in UV space to calculate the pixel filling value.

(2) Shell Padding: set the pixel gaps between UV shells.
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(3) Preserve 3D Ratios: toggled, the shells will be scaled according to their corresponding area on the 3D
model; untoggled: the shells will be scaled according to the size of the shells after unfolding.
After setting the parameters, click Apply to get the layout. Click Reset to reset to default.
2. Pixel Density: set the size of UV shells by specifying the amount of texels included per unit. Click Texel

Density and the following dialogue will pop up:

Texel Density et

Pixels per unit: |3.140

After setting the density, click Get to show the texel density of selected part; click Set to scale the UV shell

to fit the specified texel density.
7.2.8.8 Tool

The texture borders may be unable to be detected for unfolded external models imported to this software. Or
models made with this software might sometimes be unable to show the texture borders. You can solve the issue

by using the Refresh Shell command.
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Select "UV Editor > Tool", and the dropdown menu is shown below:

1. Refresh Shell: get the texture borders of UV shells.

. Refresh shell
2. Orient to Edges: Select an edge on the shell as reference,

Orient to Edges

rotate this edge to make it parallel to the u axis or v axis to
adjust the direction of the shell. The rotation direction can be
set by the angle between the selected edge and the u or v axis. Normally the rotation direction is toward
the side with the smaller angle. If the angle is exactly 45 degrees the direction will be on the u axis.

Note: Orient to Edges can only be used under the line mode.
7.2.8.9 Status Bar

Before entering a sub-mode, the default state does not allow editing in the unfolded model view. Click a button

on the status bar to enter editing mode. Different buttons correspond to different editing objects.

1. Point: after clicking button, only points can be selected in the editor, and the shared points of which

are selected at the same time automatically.

2. Line: after clicking = button, only lines can be selected in the editor, and the shared lines of which are

selected at the same time automatically.

3. Polygon: after clicking |:| button, only polygons can be selected in the editor.
4. Element: after clicking button, only elements can be selected in the editor.

5. UV Vertex: used alongside Point. Click |I| button, and point button is automatically selected. Select
points in the 3D view and all corresponding UV vertices in the editor are selected as well. And the shared
points of the selected points in the editor won’t be selected automatically.

6. UV Shell: the button cannot be used by itself. It must be used in conjunction with the Point, Line, or Poly

Fe=

button. After clicking L.

r
oo

button and anyone of the Point, Line or Poly button, and select part of the model

in the editor, which will be shown in points, lines, or polygons.

7. UV Symmetry: Make another part with a symmetry relationship in the UV view to get the same change as

the selected part. For example, after making the modification of source objects, clicking the button,
selecting the source objects and right click, a bold symmetric line appears, you can select the bold

symmetric lines or hold down Ctrl while dragging with the left mouse button to adjust the position of the
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bold axis vertically and horizontally to determines where the symmetric shell is placed in the UV Editor

workspace. Then, specify the symmetric plane in the 3D entity and right-click.

Y Lt .

SR UWSegshal MEppngUvs  Cn Sow urhid et Teal

8. Symmetrize: this option is for models that have a symmetry relationship in the 3D view. After selecting the
symmetry axis, a part of the model is selected and the symmetric part of the model is also selected at the
same time. You can click the dropdown button to select the axis, and then operate in the editor.

9. Material: the checkboard is the default material of the software, mainly used to check whether the UV
shells are stretched. Additionally, the material information will also be shown in the dropdown list.

Note: when entering point, line, or element mode in the editor, select a point/line/UV shell, and the

corresponding point/line/UV shell in the 3D view will also be selected.

7.2.8.10 Toolbar

1. Move: clicking the button, in addition to selecting an entity in the UV Editor window for the move

operation, you can also select an entity in the 3D view for the move, which corresponds to the Move
command in the advanced modeling. The object is moved in the following ways.

(1) Move directly, click on an object and drag the mouse directly to move the object.
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(2) Select and move. Add the object to be moved to the selection set first, and move it by specifying the

reference point in the selection set as the base point.

(3) Right-click the Move button and set the move distance of the selected object in the pop-up window.
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Move Transform Type-In

7. 0.000

The direction of movement is determined by the mouse and the current reference coordinate system. 2D
coordinate system is displayed in the UV Editor window, the object can only move in 2D plane, it has linkage
with the advanced modeling interface movement. To restrict the object to move in the X or Y axis, click directly
on the axis to temporarily lock the corresponding axis, you can also use the "constraint" related commands in

the advanced modeling window to lock the axis.

2. Rotate: clicking the L button, in addition to selecting an entity in the UV Editor window for the rotate
operation, you can also select an entity in the 3D view for the rotate, which corresponds to the Rotate
command in the advanced modeling. The object is rotated in the following ways.

(1) Direct rotation, click on an object and drag the mouse directly to rotate the object.
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[0.00.0.00,-41.92]

(2) Select and rotate, the object to be rotated is first added to the selection set and rotated by specifying

the reference point in the selection set as the base point.

(000,000, -109.38]

(3) Right-click the Rotate button and set the rotation angle of the selected object in the pop-up window.
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Rotate Transform Type-In

The direction of rotation is determined by the mouse and the current reference coordinate system; the UV
Editor window shows a 2D coordinate system, the object can only be rotated in the 2D plane, it has a linkage with
the rotation of the advanced modeling interface. To restrict the object to rotate in the X or Y axis, click directly on
the axis to temporarily lock the corresponding axis, you can also use the "constraint" related commands in the

advanced modeling window to lock the axis.

3. Scale: clicking the IE‘ button, select an object, in addition to selecting an entity in the UV Editor window for

the scale operation, you can also select an entity in the 3D view for the scale, which corresponds to the Scale
command in the advanced modeling. The object is scaled in the following ways.

(1) Direct scaling, click on an object and drag the mouse directly to scale the object.
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(2) Select and scale, the object to be scaled is first added to the selection set and scaled by specifying the

reference point in the selection set as the base point.

(3) Right-click the “Scale” button and set the zoom scale of the selected object in the pop-up window.

Scale Transform Type-In

¥: 100,000 vy, 100,000 2 100.000  [ep 200.000

The direction of scaling is determined by the mouse and the current reference coordinate system; the UV
Editor window shows a 2D coordinate system, and the object can only be scaled in the 2D plane, which is linked
to the scaling of the advanced modeling interface. To restrict the object to scale in the X or Y axis, click directly
on the axis to temporarily lock the corresponding axis, you can also use the "constraint" related commands in

the advanced modeling window to lock the axis.
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4. Ring Select: click on the button, set the interval, select an object, and appropriate lines will be selected.
5. Loop Select: click on the . button, set the interval, select an object, and appropriate lines will be selected.

6. Target Select: click on the H button, hold down left button, and hover over points to select them.

7. Borders: click on the ## button, select an object, right click to select points, lines, polygons, and UV vertices

on the outermost ring of the UV shell.
7.3 Display Panel
7.3.1 Backface Cull
The Backface Cull command determines whether the back faces of polygon planes are culled and not displayed.

Select "Material Tab > Display Panel > m Backface Cull" to apply this function. The direction the polygon normal

faces determines whether it is displayed when Backface Cull is enabled.

Polygons that are facing away from the viewport or polygons that are inside of an object and facing the

viewport are not displayed, if you click the Backface Cull feature again, they can be displayed again.
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8 Scene Menu

In the process of planning and designing a project, the layout of the scene is particularly important. It reflects
the style and design effect of the final plan, and also reflects the scenery ability and aesthetics of the designer. This
chapter talks about the creation of roads and site entities, the arrangement of background entities, and the insertion
of skeletal animation elements, so that the user can flexibly use the functions when arranging the scene and make

the project present a delicate and realistic effect.

8.1 Road

8.1.1 Urban Road
Urban roads are the main traffic routes in the city or outside residential neighborhoods. Hoseplan provides

templates for urban roads to facilitate quick drawing. Select "Scene Tab > Road Panel > Ilill Urban Road" to open the

following dialog box.

Urban Road
One-ane  Twodane Threedane Fourdane
Sidewalk:  2.00
Lane: &.00 White single line  ~  Dottedline -~
Sidewalk: 2.00
Total width: [12.00

Page 205 of 236



Houseplan Make stunning 3D scheme with speed and ease

1. Draw urban roads: Select the lane type and set the parameters in the dialog box, click "Confirm" button,
and then draw directly at the specified point in the scene. You can draw a curved road according to the
command line: input “A” to draw as "tangent arc", input “B” to draw as "convex arc", input “C” to draw as
"three-point arc". Can be drawn continuously; enter “U” to go back to the previous step and right-click to
end the drawing.

2. Line to Road: Import or draw the line entity representing the road in the scene, select the lane type and
set the parameters in the dialog box, click "Confirm" button, enter Z in the command line, select the line
and right click to finish. The selected line entity will be converted to an urban road.

3. Parameter Description: In the dialog box, switch the Tab page to select the lane type (e.g., "two-lane
roads"), set the sidewalk width, lane width, separation width, and other parameters. "Total width" is
calculated automatically according to the width of the sidewalk, etc. In the right side, check the sidewalk
to be displayed and set the color, single and double lines and dashed line style of the sidewalk. If you want
to set a different width, you can modify the value below separately.

Note:

(D When drawing a curved road, "tangent arc" means the section of the arc road is tangent to the
previous section of the road, "convex arc" means the ends of the arc road are drawn before specifying
their radius, and "three-point arc" means the specifying second and third points of the arc in sequence
to generate the arc road.

@ When a road is drawn with a turning point, a range of arc radius is given based on the angle between
two roads, with the default arc radius being the width of the road.

@ When roads that are drawn and converted from lines cross, the road surface and pavement and other
components are automatically fused. When road segments are moved or deleted, the roadway with
which they were originally fused also automatically handles the boundaries.

@ For roads that are drawn and converted from lines, they are made up of individual sections and road
corners, requiring all sections to be selected for overall movement.

® For roads that are drawn and converted from lines, after selecting a road section, drag the midpoint
to move the road section, and drag the start and end points to change the position of their ends.
Dragging will snap to the height of the target point, e.g., if the road has a start elevation of 10, if the
start is dragged to the 0 plane, the start elevation will also change to 0.

@ Fillet: refers to the curved sharp corner of the road surface generated between intersecting roads. The
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corner is selected and its radius can be changed by setting it in the property palette or by dragging and
dropping the edit point.
@ In the property column:

» Click on the type to switch to another type of road. When switching back to urban roads, the
pavement width needs to be set manually.

» Width and area exclude sidewalks.

» It's possible to modify the start and end elevations to give the road a three-dimensional form.

» Plasticity affects the size of the triangular mesh calculated inside the road. The smaller the value,
the more detailed the road rendering will be, but the performance will also be greatly reduced. A

suitable plasticity value can be set as appropriate.

8.1.2 Residential Street

Residential roads refer to the main access roads in an area dominated by residential buildings, and this function

is used to map or quickly generate residential roads by converting lines. Select " Scene Tab > Road Panel >|ﬂl
Residential Street" to draw a road or convert the road according to the command line prompt.

1. Draw residential roads: You can draw a curved road according to the command line: input “A” to draw as
"tangent arc", input “B” to draw as "convex arc", input “C” to draw as "three-point arc". Can be drawn
continuously; enter “U” to go back to the previous step and right-click to end the drawing.

2. Line to Road: Import or draw the line entity representing the road in the scene, select the lane type and set
the parameters in the dialog box, click "Confirm" button, enter Z in the command line, select the line and
right click to finish. The selected line entity will be converted to an urban road.

Note: The property palette allows you to modify information about parameters such as type, width, starting

point elevation, endpoint elevation, curbstone width, length, area, shapable etc.

8.1.3 Edit Road

8.1.3.1 Rounded Corner

Generates rounded sections of both roads. Select "Scene Tab > Road Panel > I : I Edit Road > Rounded
Corner", according to the command line prompts, select two road sections and specify or enter the turn radius. You

can connect two sections of the road to generate rounded corners.
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Before After

Note:
@ Cannot round corners on parallel sections.
@ The maximum turning radius is automatically calculated based on the angle between the two roads,

and the default radius is generated by the width of the road.
8.1.3.2 Extend Road

Uses the road a line as the boundary so that the selected road extends to the boundary. Select "Scene Tab >

: Iy
Road Panel > I 5 I Edit Road > Extend Road", according to the command line prompts, first select the road
section or line to be used as the boundary, and then select the road section to be extended. You can extend the

selected road to the boundary.

Note: When selecting an extension section, the cursor must point at the end closer to the boundary, otherwise

the extension fails.

8.1.3.3 Fillet

Modifies the turning radius of the two connecting roads. Select "Scene Tab > Road Panel > I g I Edit Road > IE
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Fillet", according to the command line prompts, respectively select the road on the two connected straight edge,
enter or use cursor to specify the radius of the arc.
Note: Drawing a road requires
that the straight edge of the
road on the same side of two
connected sections be selected

and that the two sections must

blend Before Aizer

8.2 Facilities Panel

8.2.1 Greening

8.2.1.1 Flower Pool

Aflower poolis a fenced area for raising flowers and planting trees, a small structure enclosed by brick masonry
or concrete structure for planting flowers or shrubs. The pool is filled with planting soil and provided with drainage

holes; its height generally does not exceed 600 millimeters. This feature is used to draw and define flower pools.

Select "Scene Tab > Facilities Panel > Greening > Flower Pool" and there are three ways to generate

1. Directly drawing the flower pool in the same way as a polygon.

2. Enter “S” and press Enter to draw the flower pool in the same way that a three-dimensional polygon is
drawn.

3. Enter “D” and press Enter to select the plane or closed line, and define it as flower pool.

Note: The property palette on the right side of the screen allows you to adjust the parameters for the height

and side width of the planter.
8.2.1.2 Hedge

Hedge, also known as wall tree or trellis, a tree or other plant that grows prostrate in patches along a wall or
trellis, also refers to the wall or trellis to which such a tree is attached. This function is used to draw and define

hedges.

Select "Scene Tab > Facilities Panel > Greening >
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height of the hedge respectively, there are three ways to generate.
1. Draw hedges directly by drawing polylines.
2. Enter “D” and press Enter, select a line and define it as a hedge.
3. To draw a hedge along a line, enter “Y” and press Enter and follow the command line prompts to draw it.

Note: The parameters for the height and width of the hedge can be adjusted in the properties bar on the right.

8.2.2 Water

A volume of water is one of the recurring elements in a landscape setting. This function is used to draw and

define a water surface or pool.

Select "Scene Tab > Facilities Panel > Water" to open the dialog box shown below.

#=EH 4

Em Lakes

O Hap redection 2nal tve rirfactian

Vimter surface :alar:- *.77,122
specua Coor: [  1.120.120

E: Srootress: 155 2 | ]
Spedar lewelz 0.1 = 1

Cie
ﬁ
Fored

st mate Refector nt=skn & < i
rresyel offset 1,4 = 1
. Fresrel indes: 4 : i
p— Water spesd: 0,5 s 1
‘Wiater ripple raba: 0.3 = 1
Appe begnt: pog |2 B
Cpadby: (0,25 - i

i

1. Drawing water surface: click on the button and there are three ways to generate it.

(1) Drawing the water surface in the same way that polygons are drawn.

(2) Enter “D”, press Enter and select the horizontal plane, horizontal closed line, and define as a water
surface. To auto-generate a water surface, enter “Z” and press Enter, select the entity that you want
to auto-generate the water surface, and specify it directly or enter the height value to enter.

Note:

@Automatic generation is generally used to generate water surfaces in low-lying areas of the terrain.
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@The entities that support automatic water surface generation are terrain, planes, and roads.

2. Draw pools: See "Draw water surface" for more details.

3. Paint: Click - button, select the type of water volume in the dialog box (clear water, pond, lake, still water
and sea), you can paint to the water volume, plane or any other entity. Right click in the scene, you can also
draw the water volume material, paint to the water volume, etc.

Parameter Description:

1. Map reflection: Water reflections according to a preset map.

2. Real time reflection: Water surface reflections in accordance with the actual environment.

3. Water surface color: Sets the color of the water.

4. Specular color: Add a specular map to the water surface.

5. Smoothness: Controls the degree of smoothness of the material when exposed to light.

6. Specular level: Controls the level of specular brightness.

7. Reflection intensity: The magnitude of the reflection effect; the higher the value, the stronger the reflection
effect.

8. Fresnel offset: The reflectance of the surface directly facing the viewer (or incident light); this value is lower
for water materials.

9. Fresnel index: Decay of the Fresnel curve.

10. Water speed: The rate at which water flows.

11. Water ripple ratio: Controls the proportion of the water ripple tiling, the higher the value the denser the
water ripple.

12. Ripple height: Sets the ripple height of the water surface.

13. Opacity: Sets the opacity of the water surface.

8.2.3 Steps

8.2.3.1 Stairs Along Lines

Along Line Steps are steps that are generated along existing outlines. This function is used to define steps.

Select "Scene Tab > Facilities Panel > Steps > Stairs Along Lines", first enter the value to determine
the number of steps and the width of the top plane of the steps, then set whether to generate steps at both ends,

select a line or a point on the edge of the entity, directly specify or enter a value to determine the length of the step;
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if you want to close the steps along the edge of the entity, enter “C” and press Enter.

Note: The width of the top plane of the steps is the width of the topmost step.
8.2.3.2 Fixed Position Stairs
In-Place Steps are custom generated steps based on an existing outline. This function is used to define steps.
Select "Scene Tab > Facilities Panel > Steps > Fixed Position Stairs", select the side of the plane to generate
steps, and enter the value to determine the number of steps to be generated.
Note:
@ The edges of a plane generating a step may be multiple edges.

@ When the distance from the building is less than 0.2 m, the "Step in place" is automatically associated

with the building.
8.2.4 Fence
A fence is architecturally a heavily rectilinear spatial partition structure used to enclose, divide or protect an

area, generally enclosing the wall of a building volume. Select "Scene Tab > Facilities Panel > Fence".

1. Fence

(1) Click | button to draw the fence in

a direct polyline.

=

(2) Click 't putton to select a line as

the fence.

Bounding wallD2

(3) Select the fence type and click |

button to select and change the

fence type.

(4) Fence Height: Click on the drop-

down arrow or enter a value directly Bounding wallg3 Bounding wall04

to change the fence height. wallbeight: 2|

2. Gates: Switch to the Gates Tab, just

double click or drag the selected gate type and place it in the scene.
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Ferce Gate

A Phe

Entrance door01 Entrance door02
Entrance door(3 Enfrance doorl4

8.3 Environment Panel

8.3.1 Label

Turns on/off the labels of particles and lights for easy selection of particles, lights entities. Select "Scene Tab >

Environment Panel > Label" to turn/off the labels of particles and light entities. Please close the tab when

publishing effects and recording roaming videos to avoid affecting the effect.

8.3.2 Particle Entity

Adds dynamic fountains, smoke, vapor, and other particle entities to the scene to complete the scenario effect.

Select "Scene Tab > Environment Panel > n Particle Entity".
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Particle Entity

Fountain &
Smoke
Spray
Water Vapor

i =

.'.':-}' i

Defoliation 01 Defoliation 02

Defoliation 03

1. Place entity: Double-click on a particle entity in the gallery or drag it directly on workspace.
2. To edit an entity library: Right-click on the list of entity categories:
(1) New: Creates a new particle entity category.
(2) Delete: Deletes the newly created particle entity.
(3) Clear: Removes all newly added particle entities in the selected category.
(4) Edit: Renames the newly created particle entity category.
3. Add: Right-click on a blank space in the library window, click "Add" and select particle entity in workspace

to add it.

4. Delete: Right-click on the thumbnail and click "Delete" to delete the added particle entity.
5. Parameter Description:
(1) Particle amount: The higher the value of the parameter, the greater the number and density.
(2) Particle lifetime: The time the particle exists, the higher the value the lower the particle density and
the longer the particle exists.
(3) Initial speed: The higher the value, the faster the speed.
(4) Acceleration: There are three values representing the velocity of xyz in three directions, the larger the
value the faster the velocity, for example: with an x-axis velocity of 5 and a y-axis z-axis velocity of 0,
the particle is deflected in the x-axis direction.

(5) Initial scale: Refers to the size of the particle at the beginning, the larger the value the larger the
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particle.

(6) Final scale: The size at the end of the particles' lifetime.
8.3.3 Light Entity
Add spotlights, floodlights, and other lighting entities to the scene to complete the effect. Select "Scene Tab >

Environment Panel > Light Entity" to open the dialog box shown below.

Floodlight

Spotight o

Floodlights 01 Lawn Light 01

1. Place entity: Double-click on a light entity in the gallery or drag it directly on workspace.
2. To edit an entity library: Right-click on the list of entity categories:

(1) New: Creates a new light entity category.

(2) Delete: Deletes the newly created light entity.

(3) Clear: Removes all newly added light entities in the selected category.

(4) Edit: Renames the newly created light entity category.
3. Add: Right-click on a blank space in the library window, click "Add" and select light entity in workspace to

add it.

4. Delete: Right-click on the thumbnail and click "Delete" to delete the added light entity.
5. Spotlights parameters description:

(1) Activation: Double-click to activate or deactivate.

(2) Radius: The size of the light range.
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(3) Direction: Direction of light.
(4) Light cone: The greater the value the greater the range of light radiation.
(5) Attenuation: The higher the value the lighter is concentrated.
(6) Light intensity: The higher the value the brighter the light.
(7) Specular intensity: The higher the value the stronger the highlight.
6. Floodlights parameters description:
(1) Activation: Double-click to activate or deactivate.
(2) Radius: The size of the light range.
(3) Light intensity: The higher the value the brighter the light.
(4) Specular intensity: The higher the value the stronger the highlight.

7. There is no lighting effect during the day, and the lights turn on automatically at night.

8.3.4 Scene Entity

Adds different types of components as exterior design. Select "Scene Tab > Environment Panel >. Scene

Entity" to open the dialog box shown below.

Bench F
Bilboard ‘ u M mf
4

Bridge
Canopy Amusement fadlities  Amusement fadlities  Amusement fadilities
Communal facilities 01 n2 03

Corridaor frames

Featured landscape
Glass volume
Pavilion

Person

Public building

) .ﬁ.rnusement facilities Amusement facilities Arnusement facilities
Residence

Sports field

Street lamp
Transportation fadlities
Vehide

Al

Spacing: 10 Sethadk: 0.0 : ]

1. Place entity.

(1) Direct placement: Double-click on a model in the gallery or drag it directly on workspace.
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[
(2) Place along the line: Select the model, click *== button and place the entities equally spaced between

the specified start and end points.

(3) Place along the object: Select the model, click = button. If you select a road, you can arrange along

the road; if you select water volume, you need to select a point as the starting point of entity

arrangement to place along the water volume.

oo

(4) Select Layout: Select the model and click == button to place the entities along the road in three ways.

(D Enter “C” and select "Urban Road" for the equal-spacing placement of entities.

@ Enter “Q” and select "Residential Road" for the equal-spacing placement of entities.

(3 Enter “Z” to simultaneously select both "Urban Road" and "Residential Road" and place entities

with equal spacing.
Note:
@ Previews that appear in grey in the gallery will automatically download if clicked. They can be
placed in the scene when they are downloaded.
@ Margin distance refers to the horizontal distance of the starting point of the arrangement from

the beginning of the road or water volume. As shown in the figure below.

Margin distance

L

2. To edit an entity library: Right-click on the list of entity categories:
(1) New: Creates a new model category.
(2) Delete: Deletes the newly created model.
(3) Clear: Removes all newly added models in the selected category.

(4) Edit: Renames the newly created model category.
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3. Adding objects: Right-click on a blank space in the library window, click "Add Object" and select a model in

workspace to add it.

® Flower.cpi
4. Add File: Right-click on the blank space in the [ Flower fi
E poolfbx
library window and click "Add File", the following P
dialog box will pop up. After selecting the cpi or e
fbx file, click the "Open" button to add the e o] Fie Pucpi )

Cipen Cencel

selected file.

5. Delete model: Right-click on the thumbnail and

click "Delete" to delete the newly added model.

8.3.5 Vegetation Entity

Adds vegetation entities to the scene to refine the scene. Select "Scene Tab > Environment Panel >

Vegetation Entity" to open the dialog box shown below.

Vegetaion Entity

/ .
Flowier ] )
Shrub w W
Tree

Aguatic plants 01 Aguatic plants 02 Grass 011

Iris 01 Iris 02 Iris 03
Lotug 01 Lotus 02 Lotus 03
Spadng: 10 Sethack: 0.0 el

1. Place entity.

(1) Direct placement: Double-click on a model in the gallery or drag it directly on workspace.

[
(2) Place along the line: Select the model, click == button and place the entities equally spaced between

the specified start and end points.
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(3) Place along the object: Select the model, click = button. If you select a road, you can arrange along

the road; if you select water volume, you need to select a point as the starting point of entity

arrangement to place along the water volume.

il

(4) Select Layout: Select the model and click button to place the entities along the road in three ways.

(D Enter “C” and select "Urban Road" for the equal-spacing placement of entities.
@ Enter “Q” and select "Residential Road" for the equal-spacing placement of entities.
(3 Enter “Z” to simultaneously select both "Urban Road" and "Residential Road" and place entities
with equal spacing.
Note:
@D Previews that appear in grey in the gallery will automatically download if clicked. They can be
placed in the scene when they are downloaded.
@ Margin distance refers to the horizontal distance of the starting point of the arrangement from
the beginning of the road or water volume.
2. To edit an entity library: Right-click on the list of entity libraries:
(1) New: Creates a new model category.
(2) Delete: Deletes the newly created model.
(3) Clear: Removes all newly added models in the selected category.
(4) Edit: Renames the newly created model category.
3. Add object: Right-click on a blank space in the library window, click "Add Object" and select a model in

workspace to add it.

LE) Plowser.cpi
4. Add File: Right-click on the blank space in the i flawer
;,—Eo:vl.ﬂ:x
library window and click "Add File", the following () stonecp
dialog box will pop up. After selecting the cpi or e o
File pame y | Fie [*,cpi;" fha)

fbx file, click the "Open" button to add the
Cipen Cemcel
selected file.
5. Delete model: Right-click on the thumbnail and

click "Delete" to delete the newly added model.

8.3.6 Environment
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Applies weather, lighting and fog effects in the environment. Select "Scene Tab > Environment Panel >E

Environment".

Weather

Sunrise Sunset Snow Rain Might

Lighting

Effect parameter

1. Weather: Double-click on a weather image to apply the corresponding weather effects.

2. Lighting: Click on "lighting" and the dialog box will look as follows.

Weather

Sunriza

“E ar 5|l.'|-'

Sunsat Snow Rain Hight
| 2 Lighting
Lighting
Chadow
Drecton: -53 [ ]
Height: 36 ]
o Efect parameter

(1) Show shadows: Check “show shadows” and “show shadow effects” in the scene.

(2) Enter a value in the text box or drag the slider to adjust the azimuth and altitude angle parameters of

the sun. When shadows are on, adjusting the azimuth and altitude will affect the effect of the

shadows.

3. Effect Parameters: Click on "Effect Parameters" and the dialog box will look like this:
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Weather
—
E...:::::: I I! .
Clear sy Sunres Sunset Snow Ran Might
4+ Lighting
Effect paramatar
Type Parameter
= Sunfet
Sun Intensity D 251,235,205
Sun Color ] 235,193,156
Sun Colar Mubipli... 1301220
= Ambienk
Sky Colar [ 149,177,219
Sky Calor Bultiplier 1404060
5540 Factor 0500000
55A0 Radius 1000000
= Fog
Erm Tom Falmn = wn3 1ED T1E

Solar, ambient, fog effect, volumetric light and HDR parameters can be modified separately to enhance
the ambient effect.
(1) Sun
(D cColor: Sun color, which can be drawn directly from the color panel.
2 lllumination: The color of sunlight.
3 Intensity: The intensity of the sun's rays on the ground (higher the value, stronger intensity).
(2) Environment
(D Color: The environment, and the color of objects in the environment
@ Intensity: The intensity of the color (higher the value, stronger intensity).
(3 Light-blocking intensity: The intensity of the shadow at the angle between objects (higher the
value, stronger intensity).
@ Radius of light blocking: The size of the shadow area at the angle between objects (larger the
value, larger area).
(3) Fog Effect
D Color: Applies fog color.
@ Intensity: The density of the fog in the part of the sky (higher the value, denser the fog).

(3 Density: The density of the overall fog (higher the value, denser the fog).
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(4) Volumetric Light
@ Color: Volumetric light color.
2 Weight: The proportion of the color of the volume light. When the weight is 0, the color of the
volumetric light will be displayed completely, the larger the weight value, the smaller the

proportion of the color of the volume light setting.

@)

Intensity: Controls the sun's halo and light, the higher the value, the stronger the halo and light.

®

Attenuation: Controls the intensity of sunlight reaching the ground; the smaller the value, the

stronger the light reaching the ground.

8.3.7 Optimization

Optimization

Sets anti-aliasing, visual balance, and arc

Anti aliasing: 1 | 4 3
segments to adjust the entity effects in visual balance: 1 I o
workspace. Greater values are not necessarily Arc segment: 1 | 0 500

better. Select "Scenes Tab > Environment Reset

Panel > 14 Optimization".
1. Anti-aliasing
Remove jagged display and aliasing to make the view smoother and prettier. Set the value of anti-aliasing

and click "Apply". The Anti-aliasing button on the right bottom corner can turn this effect on or off as well, as

shown below:

|sometric | Perspective | Shadow | Anti-Aliasing | Light Projection

2. Visual Balance
Simplifies surface details of entities to reduce the geometrical complexity of a scene while not affecting
the visual effects. Set a value to increase the performance of the scene without losing noticeable graphic details.
Drag the slider or enter a value to change the LOD display distance. Entities farther away will be displayed in
simpler models or not rendered at all; entities close to the viewpoint will be displayed in detailed models.
Note: during drawing, if imported drawings are not visible, it could be that the imported drawing is too
big and the viewpoint is too far away. Increase the value of LOD and the drawing should display normally.

3. Arc Segments
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Sets the display effect of arcs and curved planes. Drag the slider or enter a value directly to adjust the
number of segments. The smaller the value, the fewer the segments, and the more efficient the rendering; the
greater the value, the more detailed the arcing effect, but the performance will be lower.

Note: Arc segments affect the following entities:

@ Line: sphere, arc, ellipse, elliptical arc.
@ Edge: The edge of planes and volumes that contain sphere, arc, ellipse, or elliptical arc.

@ Curved plane: individual curved plane entity or curved plane on volumes. In other words, all non-flat

planes are affected.

8.4 Animation Panel

8.4.1 Skeletal Animation

Adds animated objects to the scene to add animation effects. Select "Scene > Animation Panel > ﬁ Skeletal

Animation" to open the following dialog box.

Skeletal Animation

Bird r
gc {*
Brd 01 Bird 02 Bird 03
Bird 04 Bird 05
Velodty: 7.00 mjs W Height: 10.00 m

1. Select the animated entity and set the movement speed and insertion height.
2. Double-click the animated solid model or drag the model to the scene to insert it.

Note: Previews that appear in grey in the gallery will automatically download if double-clicked. They can be
placed in the scene only after the download is complete.
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8.4.2 Play Animation

Play the animation or stop playing the animation according to the set path. Select "Scene Tab > Animation

Panel > & Play Animation" to start or stop playing the movie.

8.4.3 Wavy Path

Adds undulating paths to animated entities, generated when drawing based on the height of the specified

point. Select "Scene Tab > Animation Panel > M Wavy Path", select the animated entity, and draw the undulation
path.
Note:
@ If there is no control point for snapping in the scene, the drawn path is a horizontal path, and you need
to click the "Edit Path" command to modify the control point, see "Edit Path" for the specific operation.
@ The property palette allows you to adjust parameters such as frequency of the animated entity,
whether it moves itself, whether it follows the path, the path speed, whether the movement mode is

single or circular and whether it casts a shadow.

8.4.4 Edit Path

Edit the drawn animation path. Select "Scene Tab > Animation Panel > B3 Edit Path" to open the dialog box

shown below.

1. Selection: Click by button to select the animated entity or click on the name of the animated entity on

the left side of the dialog box to display its path and control points in the scene and its control points and

height on the right side of the dialog box.

Page 224 of 236



Houseplan Make stunning 3D scheme with speed and ease

2. Undulating Path: Click ¥ putton to

Edit Path

draw undulating paths.
;o7 @ X
3. Move: Click ¥ button and select the ""El"‘jt?:% mfs
I Person\Person || | Control point . Height e
control point to move.
p Person'.Person | 1 point 0.0 100
v Butterfly'Butter 2 point 00
4. Delete: Click button to delete the * 40 50
Delete animation 0.1
selected control point. Clear path 0.0
: 0.0
. . . B point 0.1 0 |
5. Right-click on the name of the animated 7 point 00
entity on the left side of the dialog box & point 0.0
-50
to open the context menu;
(1) Delete animation: Deletes the N -100

selected animated entity and its
path.
(2) Clear path: Removes the animation path of the selected entity.
Note:
@ Itis not permitted to delete or move the first control point.
@ Double click on the blue text "height", and all points below the selected row will be modified to the

height value of the selected row.

8.4.5 Erase Path

Clears the defined animation path. Select "Scene Tab > Animation Panel > B8 Erase Path" and select the

entity you want to delete the animation path from.

8.4.6 Show Path

Shows or hides the defined animation path. Select "Scene Tab > Animation Panel > Show Path" to show

or hide the defined animation path.
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9 Video Menu

To facilitate users to experience the real 3D model world, Hoseplan outputs HD video based on the real

environment path to show the effect of the design dynamically in all aspects.

9.1 Path Panel
9.1.1 Draw Path

Draw roam path in the scene. Select "Video Tab > Path Panel > Draw Path" to draw a path in the scene.
Note:

@ The drawing is captured in three dimensions.

@ After drawing a path, when drawing it again, continue along the last path by default.

@ If you want to redraw it, you can click on "Delete path" command and draw it again.

@ If the previous path needs to be saved, save it in the "Video Highlights" before clearing the path.

® If the drawn path line is not saved in "Video Highlights", the path line information will not be

recorded, and the path will be lost when the file is opened again.

9.1.2 Grounded Path

Draw video paths that adhere to the ground in the scene, enabling video to undulate with the ground

automatically when roaming. Select "Video Tab > Path Panel > Grounded Path" to draw a path in the scene.
Note:
@ The ground includes the earth, the terrain and the roads.
@ When there is a superposition of ground entities, the path falls on the higher entity.
@ When the two paths are drawn by switching between them, the drawn path is generated in the same

way as the newly drawn path.

9.1.3 Edit Path

[l

Edits the current roaming path. Select "Video Tab > Path Panel > B Edit Path” and the following dialog box

will appear.
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4 X — + Input points: 63.07,51.40,0.00
Height
Control point Height Height Angle Azimuth Velocity | Angular Velocity 100
2 1.23 Look Up Front View 10.0
3 2.22 Crverlook Front View 2.0 10.0 30
4 3.56 Front View Front View 2.0 10.0
5 4,78 Front View Front View 2.0 10.0 0 ‘E’-."
& 0.00 Front View Front View 2.0 10.0
-50
-100

1. Control Point Parameters: Click on an item in the dialog box to modify it.

(1) Height: The height of the camera when roaming to that point, either by entering the value directly,
or by dragging the right slider to change it.

(2) Height Angle, Azimuth: Seta horizontal and vertical viewpoint when roaming, click the drop-down
list and select "Pick", you can use the selected point in the scene as the viewpoint. After that, select
the control point, you can modify the coordinates of the point at the top of the "Enter Viewpoint".

(3) Velocity: Speed at which the roaming is running.

(4) Angular velocity: Speed at which the camera turns, which needs to be increased to match if the
camera is going too fast.

(5) Blue Font: Select a value and double-click the blue font above the column to change all the values

below to the same value as that item.
2. Clicking i button to move the selected control point and allow capturing.
3. Click the  * | button to delete the selected control point.

4. Clicking *~* | button to move the selected control point horizontally without changing the height of the

control point.

5. Click the 't button to add control points to the path line.

Note: Grounded paths do not support panning.
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9.1.4 Delete Path

Deletes the currently drawn roaming path. Select "Video Tab> Path Panel > B

clear the roaming path in the scene.

9.2 Video Panel

9.2.1 Roaming Operation

I Delete Path" to automatically

Implement roaming effects and generate roaming videos. Select "Video Tab> Video Panel > Roaming

Operation" to open the following dialog box.

Roaming Operation

1. Click on the ] button to open the dialog box

shown below.

(1) Click on "Detailed Parameters" to open the

"Edit Path" dialog box, refer to the "Edit

Path" item for details.

Path Roaming Settings

Detailed parameters

(2) Select "Temporary Parameters" and the
dialog box will lo Confirm like this.

(D Moving speed: Enter the speed at

Temporary parameters
Moving speed 20,0 mys
©  rathheight 18 m
View  Front w
Video size 1920*1080 e

Video quality  High -

®

®

which the viewpoint moves when
roaming.
Path height: Enter the horizontal

height of the roaming viewpoint.

View: Select the camera view, which contains five options: Front, Overlook, Look up, Left, and

Right.

(3) Video Size: Sets the size of the generated video. Select "Custom" in the drop-down list to open the
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dialog box shown below.

Enter width and height dimensions and click
"ok" button to add it to the video size list.

Note: The larger the size, the larger the file width: 1920

generated. Considering that saving data to height: 1080

the hard disk takes up system resources and

carce

affects the recording process, please choose

the right size according to your computer
performance.
(4) Video quality: Sets the video quality, including High, Medium, and Low. After setting the parameters,

click on the "Confirm" button to roam according to the settings.

2. Click on the ]EI button to start roaming through the scene according to the drawn path and its

parameters.

3. Click on the ]EI button to stop roaming.
4. Click on the ]EI button to pause the roaming and click again to continue the roaming.

5. Click the button, set the save path and file name and then start roaming and record the roaming

process as *. mp4, *. mky, *. mov format files.

9.2.2 Roam Path List

&) Roam Path

Saves the current roam path or apply a saved roam path. Select "Video Tab > Video Panel >

List" to open the following dialog box.

Roam
Mame Turning point Length
Path name: namel Save
Rename

|E| IE‘ Delete itermn

0% 25% 5006 T5% 10096

A Delete all

0.05
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1. Save path: enter the path name and click the "Save" button to save the current drawn path.
2. Apply path: double-click on the line where the path is located in the dialog box to invoke the path.
3. Context menu: Right-click in the list to open the "Context menu", you can delete or rename the path.

4, Click on the E button to set the path roaming parameters.

5. Click on the button to start roaming through the scene according to the drawn path and its parameters.
6. Click on the IEI button to stop roaming.

7. Click on the IZI button to pause the roaming and click again to continue the roaming.

8. Click the button, set the save path and file name and then start roaming and record the roaming process

as *. mp4, *. mky, *. mov format files.
Note:
@ Modified paths require a click on “Save” to update the path to the latest.

@ When saving a path to a video set, the ambient weather is also recorded in the path information.

9.3 Camera View Panel

9.3.1 Camera View List

Saves the viewpoints in the scenario for quick positioning. Select "Video Tab > Camera View Panel >

Camera View List", the following dialog box will pop up.
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Camera View List

=
Mame Camera position  Camera viewpoint View type
O 1 61,51,2 62,51,2 Perspective
O 2 64,28,-22 65,28,-21 Perspective
[l 3 -3025,11834,418  -3025,1185,417 Perspective
[] 4 7938,7969,64960  7938,7969,6461 Isometric
B s | 3166,5069,505 | sieccoeacine | toometric |
Rename(M)
Delete itermn(s)
Delete alliD

Enter the viewpoint name and click = button to save the current viewpoint to the list. Check the viewpoint

and click = button to export the viewpoint to local in image format. Right-click on the viewpoint name to open
the context menu, which allows you to rename, delete and delete all the viewpoints. You can also remove the

viewpoint all together by right-clicking in the blank space of the dialog box.
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10 Others

Hoseplan provides some common tools and shortcuts to help users categorize and manage entities in the

process of designing solutions in an organized and efficient manner.

10.1 Graphic Class Control

When designing entities or elements, you can use the layer Graph Control

[ Close the selected dass

control function for easy operation management. Click E
Close dasses other than selected
button to open the dialog box shown below.
Turn off the selected layer

Click on each item to close or open the class, layer and Tiam ofF the selecied outer layer

background. For example, click on the "Close the selected class" All dasses open

button to select the entity to be closed. For example, if you select All dasses closed

- . - Close underlay DWG
a building, you can turn off the main volume of the building and
Open underlay DWG

the balcony and other components. L )

Note: You can also click on the top of the software to have

control over the graph class layers, as shown in the following image.

[/ building ~ O building bod;

@ Click on the checkbox [¥|in front of a class or T in front of a layer to turn a single class/layers on or off.

@ Double-click the checkbox [¥]in front of the category to close all categories. Double-click again on [
to open all categories.

@ Classes and layers are linked. For example, if you close the class on the left, the corresponding layer

on the right closes with it.
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10.2 Right-Click Context Menu

If you right-click on the workspace, a context menu
will pop up with the following commands; Last command,
Orbit, Eye View, Full View, Frame Selection, Pan, View
Control, Previous View, Front Face, Window View,
Polyline, Rectangle, Polygon, Box, Extrude Building,
General Extrude, Copy, Move, Rotate, Erase, Hide
Selected, Hide Unselected, Unhide.

For more operation details, see the description of

each of these commands above in this guide.

10.3 Orthogonal

Restrict the operation to horizontal or vertical

orientation.

1. Click on Orthogonal button at the below the command line to turn the orthogonal function on/off.

2. Right click on Orthogonal button to open the context menu, as shown below.

(1) Conventional: Switches to the normal orthogonal

orientation.

~  user orthogonal

conventional

(2) User Orthogonal: Switches to the user orthogonal direction.

There are three methods of access.

(D Direct selection of solid edges, as orthogonal directions.

@ Angles may be entered as orthogonal directions, as prompted on the command line.

(3 Enter “D” to specify two points and plot the orthogonal direction, and “C” to clear the defined

orthogonal direction and return to the default state.

Note: Set user orthogonal, i.e., re-designate the direction of the positive half-axis of X-axis. In some

project drawings, the orientation of land, roads and other entities is not according to the default XY

axis direction of the system, so for the convenience of drawing, you can define your own orthogonal

direction.
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10.4 Polar Axis

During drawing and editing, you can turn on the polar axis to easily obtain capture points in the X-, Y-, or Z-axis

direction.

10.5 Snap

When drawing or editing, you can turn on the snapping function to assist in the operation for precise

positioning.
1. Click the m button below the command line or press the F3 key to turn snapping on or off.

2. Right-click on button to open the context menu, as shown below.

setting

Select "Settings" option to open the dialog box shown

Snap Mode Settings

below.
You can set snapping options, where "plane" refers to the Endpaint | Center of dirde
surface of a plane or solid. Midpoint Closest point

Click the "Select All" button to check all the boxes; click the | Intersection Plane

Perpendicular paint
"Confirm" button to apply the settings.
Mouse pick box (0-50);  ©

Note: When sn ing to the circl nter of an ar
ote en snapping to the circle center o c, you Mouse capture frame(2.20): 10

need to hover the cursor over the edge line to display the Cursor length (1-100): 6

center of the circle.

Select all Cancel

10.6 Follow \

Use this function to display distances and angles at the

Follow

mouse pointing position when drawing and editing objects. Click button at the bottom of the command

line to turn the follow function on/off. The angle displayed is the angle with the positive half-axis of the X-axis.

10.7 Reference
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When drawing and editing objects, a temporary extension line, vertical line, or a polar axis through an
entity's endpoint, midpoint, or other capture points is displayed as a dashed line when the cursor passes over that

point, so that the user can specify a point at the extension line or capture the intersection of multiple reference

lines. Click button at the bottom of the command line to turn the reference function on/off. The

reference is based on snapping and requires snapping to be on in order to use it.

10.8 Isometric

Switches the design environment to isometric mode. Click the Isometric button in the bottom right corner to

turn the feature on, and click it again to turn it off. As shown in the figure below.

10.9 Perspective

Switch the design environment to Perspective projection. Click the Perspective button in the bottom right

corner to turn on the feature, and click it again to turn it off. As shown in the image below.

Isometric | Perspective Light Projection

10.10 Shadow

Simulates the shadow shading effect of the project. Click the Shadow button in the bottom right corner to turn

the feature on, and click it again to turn it off. As shown in the image below.

Light Projection

|sometric | Perspective | Shadow

10.11 Anti-Aliasing

Jaggies are eliminated and the edges of the image are softened to make the edges of the image look smoother
and closer to the physical object. Click the light blocking button in the bottom right corner to turn on the feature,

and click it again to turn it off. As shown in the figure below.
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|sometric | Perspective Anti-Aliasing

Light Projection

Shadow

10.12 Light Projection

Ambient light masking, which depicts the effect of blocking out surrounding diffuse light when objects and
objects intersect or are close together. Click the Light Projection button in the bottom right corner to turn on the

feature, and click it again to turn it off. As shown in the figure below.

Shadow

|sometric | Perspective Anti-Aliasing | Light Projection
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